¿Repositorios?

Hola a todos,

estoy intentando instalar php en mi ubuntu en una máquina con un amd64. Bueno, el problema es que me dice que tiene un problema con los repositorios y que no los carga, que me lo ha instalado mal y ahora no es capaz ni de reinstalarlo ni de desinstalarlo. ¿Pasa algo con los repositorios nerim? Os paso mi sources.list:

#############################
deb http://es.archive.ubuntu.com/ubuntu hoary main restricted
deb-src http://es.archive.ubuntu.com/ubuntu hoary main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu hoary-updates main restricted
deb-src http://es.archive.ubuntu.com/ubuntu hoary-updates main restricted

##Main
deb http://us.archive.ubuntu.com/ubuntu hoary main
deb-src http://us.archive.ubuntu.com/ubuntu hoary main

##Seguridad-Main
deb http://security.ubuntu.com/ubuntu hoary-security main restricted
deb-src http://security.ubuntu.com/ubuntu hoary-security main restricted

##Seguridad-Universo
deb http://security.ubuntu.com/ubuntu hoary-security universe
deb-src http://security.ubuntu.com/ubuntu hoary-security universe

##Universo
deb http://us.archive.ubuntu.com/ubuntu hoary universe
deb-src http://us.archive.ubuntu.com/ubuntu hoary universe

##Multiverso
deb http://archive.ubuntu.com/ubuntu hoary multiverse
deb-src http://archive.ubuntu.com/ubuntu hoary multiverse

##Marillat
deb ftp://ftp.nerim.net/debian-marillat stable main
deb ftp://ftp.nerim.net/debian-marillat unstable main
deb ftp://ftp.nerim.net/debian-marillat testing main

##Backports
deb http://backports.ubuntuforums.org/backports/ hoary-backports main universe

#############################

SI INTENTO ELIMINAR EL PAQUETE php4 y demás me dice:
---------------------------------------------------
"no se pudieron aplicar los cambios. Arregle los paquetes rotos primero".

SI INTENTO REINSTALAR ME DA EL SIGUIENTE ERROR:
-----------------------------------------------
"E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: No se pueden corregir las dependencias
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: No se pueden corregir las dependencias
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: No se pueden corregir las dependencias
E: No se ha podido bloquear el directorio de descargas"

Agradecería cq tipo de ayuda pq por el trabajo me urge bastante y llevo todo el fin de semana rompiéndome la cabeza... pero no consigo arreglarlo.

Un saludo y gracias por anticipado.

Imagen de Anónimo
+1
0
-1

Hola, soy yo otra vez:

acabo de reiniciar el sistema y al arrancar synaptic me da dos errores consecurivos, los siguientes:

1) ============================================

W: GPG error: ftp://ftp.nerim.net stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
W: GPG error: ftp://ftp.nerim.net unstable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
W: GPG error: ftp://ftp.nerim.net testing Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907

2) ============================================

W: No se puede leer la lista de paquetes fuente http://es.archive.ubuntu.com hoary/main Packages (/var/lib/apt/lists/es.archive.ubuntu.com_ubuntu_dists_hoary_main_binary-amd64_Packages) - stat (2 No existe el fichero o el directorio)
W: No se puede leer la lista de paquetes fuente http://es.archive.ubuntu.com hoary/main Packages (/var/lib/apt/lists/es.archive.ubuntu.com_ubuntu_dists_hoary_main_binary-amd64_Packages) - stat (2 No existe el fichero o el directorio)

¿CUÁL PUEDE SER EL PROBLEMA?

Un saludo.

+1
0
-1
Imagen de ikikomori
+1
0
-1

Prueba a sustituir en tu fichero sources.list las líneas de los repositorios de Marillat por las siguientes:

deb ftp://ftp.nerim.net/debian-marillat sarge main
deb ftp://ftp.nerim.net/debian-marillat etch main
deb ftp://ftp.nerim.net/debian-marillat sid main

El cambio es en los nombres de los directorios de "stable", "testing" e "instable" a "sarge", "etch" y "sid".

Según se recoge en la página web del repositorio Marillat:

12/06/2005 : New directories names. Now stable is sarge, testing is etch and unstable is sid. Please update your sources.list

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola,

gracias por responder. Te cuento lo que me ocurre ahora:

PRIMER MENSAJE:
---------------
http://backports.ubuntuforums.org/backports/dists/hoary-backports/main/b... 401 Authorization Required
http://backports.ubuntuforums.org/backports/dists/hoary-backports/univer... 401 Authorization Required

SEGUNDO MENSAJE:
----------------
W: GPG error: ftp://ftp.nerim.net sarge Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
W: GPG error: ftp://ftp.nerim.net etch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
W: GPG error: ftp://ftp.nerim.net sid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907

-------------------------

Con esto, si intento desinstalar el paquete 'php4' me dice que: "no se pudieron aplicar los cambios. Arregle los paquetes rotos primero".

¿Por qué no funciona BACKPORTS?

¿Por qué me da ese error de GPG?

Saludos.

+1
0
-1
Imagen de coconut
+1
0
-1

Creo que el error que te da sobre "NO_PUBKEY 07DC563D1F41B907" en los repositorios nerim-marillat se solucionan tecleando esto en un terminal:

$ gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 1F41B907
$ gpg --armor --export 1F41B907 | sudo apt-key add -
$ sudo apt-get update

Con respecto a los errores de los backsports, yo tengo estos en mi sources.list y me van bien:

deb ftp://ftp2.caliu.info/backports/ hoary-backports main universe
deb ftp://ftp2.caliu.info/backports/ hoary-extras main universe multiverse restricted


Blog de coconut
+1
0
-1
Imagen de Anónimo
+1
0
-1

Lo dicho,

gracias. Voy a probarlo todo.

Un saludo.

+1
0
-1
Imagen de PureEvil
+1
0
-1

A mi me daba el mismo error, el del NO_PUBKEY, y cambiando el codigo por el mio propio he solucionado el problema que tenia con otro repositorio. Gracias tio.

Lo que me gustaria saber ademas, es pq exactamente pasa es te problema y que es exactamente este codigo.

+1
0
-1