problema de dependencia

Imagen de keldornl
0 puntos

Quiero instalar el proftp en kubuntu y me da el siguiente error. ¿Cómo me libro de la dependencia que me sale? Soy bastante novato :-(
sudo dpkg -i proftpd_1.3.0-19_i386.deb
Password:
(Leyendo la base de datos ...
84272 ficheros y directorios instalados actualmente.)
Preparando para reemplazar proftpd 1.3.0-19 (usando proftpd_1.3.0-19_i386.deb) ...
Desempaquetando el reemplazo de proftpd ...
dpkg: problemas de dependencias impiden la configuración de proftpd:
proftpd depende de libssl0.9.8 (>= 0.9.8c-1); sin embargo:
Version of libssl0.9.8 on system is 0.9.8b-2ubuntu2.
dpkg: error al procesar proftpd (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
proftpd

Imagen de furtaxi
+1
0
-1

 El problema es que tienes instalada una librería de versión posterior a la que te pide el programa. Así que quitas la instalada:

sudo apt-get remove libssl0.9.8

y luego repites el comando de instalación 

sudo dpkg -i proftpd_1.3.0-19_i386.deb 

Y ya debería instalarte todo correctamente. 

Pero yo te recomiendo que pruebes primero Kftpgrabber, es muy intuitivo, abres una ventana con tus archivos, y arrastras de ahí al programa y viceversa.

También tienes más opciones, teclea ftp en la caja de búsqueda de Synaptic . Si eliges gftp, acuerdate de anular la creación de copias de seguridad, te marea un poco con los archivos repetidos por su nombre, pero con una tilde al final.

Saludos,

Roberto.

Mi página: www.vigonews.es. E-Mail: rrsemail-ubuntu@yahoo.es

La Libertad es un magnífico deporte. Ponte en forma.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de keldornl
+1
0
-1

Muchas gracias por tu ayuda, pero tengo que usar el proftpd obligatoriamente

He seguido tus pasos, he desinstalado la librería, aunque no sé si se ha desinstalado correctamente. Me dice:

sudo apt-get remove libssl0.9.8
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo información de estado... Hecho
Tal vez quiera ejecutar `apt-get -f install' para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
bind9-host: Depende: libssl0.9.8 (>= 0.9.8b-1) pero no va a instalarse
dnsutils: Depende: libssl0.9.8 (>= 0.9.8b-1) pero no va a instalarse
hpijs: Depende: libssl0.9.8 (>= 0.9.8b-1) pero no va a instalarse
hplip: Depende: libssl0.9.8 (>= 0.9.8b-1) pero no va a instalarse
... etc

después me vuelve a dar el mismo problema de dependencia:

sudo dpkg -i proftpd_1.3.0-19_i386.deb
Seleccionando el paquete proftpd previamente no seleccionado.
(Leyendo la base de datos ...
84189 ficheros y directorios instalados actualmente.)
Desempaquetando proftpd (de proftpd_1.3.0-19_i386.deb) ...
dpkg: problemas de dependencias impiden la configuración de proftpd:
proftpd depende de libssl0.9.8 (>= 0.9.8c-1); sin embargo:
Version of libssl0.9.8 on system is 0.9.8b-2ubuntu2.
dpkg: error al procesar proftpd (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
proftpd

y al hacer el "apt-get -f install" no me instala la librería:

sudo apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo información de estado... Hecho
Corrigiendo dependencias... Listo
Los siguientes paquetes fueron instalados automáticamente y ya no son necesarios:
libnet-ssleay-perl libio-pty-perl proftpd
Use «apt-get autoremove» para desinstalarlos.
Los siguientes paquetes se ELIMINARÁN:
proftpd
0 actualizados, 0 se instalarán, 1 para eliminar y 149 no actualizados.
1 no instalados del todo o eliminados.
Necesito descargar 0B de archivos.
Se liberarán 2181kB después de desempaquetar.
¿Desea continuar [S/n]?

+1
0
-1
Imagen de furtaxi
+1
0
-1

¿Y después de decirle que sí a lo último?

De todas maneras, haz ésto:

sudo apt-get autoremove      (Borra lo que ya no se necesita)

sudo apt-get clean               (Limpia la caché de archivos bajados)

sudo apt-get update            (actualiza los paquetes)

Después, te vas a Synaptic, y lo instalas desde allí, está en los repositorios oficiales, y, seguramente, te resuelva todas las dependencias .

Saludos,

Roberto.

Mi página: www.vigonews.es. E-Mail: rrsemail-ubuntu@yahoo.es

La Libertad es un magnífico deporte. Ponte en forma.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.