Teclado sin acentos en Kubuntu

Hola:

Mi problema es que desde que hice un upgrade a la version KDE 3.4.1 he perdido los acentos en las aplicaciones de KDE y en OpenOffice. Cuando voy a escribir un acento y pulso la tecla y la vocal solo me sale la vocal sin acentuar. La ñ funciona sin problemas y la tecla del acento grave y circunflejo tampoco funciona de la forma habitual. En los cuadros de texto de KDM si pulso la tecla del acento sale directamente, sin esparar a la vocal. Sin embargo, en programas GNOME o en el Firefox sí puedo escribir acentos (lo estoy haciendo ahora).

He reconfigurado el xserver-xorg, los locale, he probado todas las combinaciones de teclado desde el Kcontrol, reinstalado KDE dos veces, sin conseguir ningún resultado.

Si se os ocurre algo os lo agradecería.

Albireo

Imagen de Anónimo
+1
0
-1

A mi, que no me habia pasado en el upgrade a 3.4.1, me ha pasado en el upgrade a 3.4.2 de Breeze.

Exactamente los mismos sintomas que describe el post al que respondo, con la configuracion de Xorg y opciones de teclado de KDE correctas. Lo mismo ejecutando kedit desde una sesion GNOME.

Pero puedo aportar un dato mas: OpenOffice2 sobre GNOME me deja escribir acentos, mientras que sobre KDE no. Tengo entendido que para ciertas cosas OpenOffice usa GTK o Qt dependiendo del escritorio que se este ejecutando. ¿Puede, pues, que el problema este en la libreria Qt?

Yo tengo estos paquetes :

ii  libqt3-compat-headers  3.3.4-8ubuntu5  Qt 1.x and 2.x compatibility includes
ii  libqt3-headers         3.3.4-8ubuntu5  Qt3 header files
ii  libqt3-mt              3.3.4-8ubuntu5  Qt GUI Library (Threaded runtime version), V
ii  libqt3-mt-mysql        3.3.4-8ubuntu5  MySQL database driver for Qt3 (Threaded)
ii  libqt3-mt-odbc         3.3.4-8ubuntu5  ODBC database driver for Qt3 (Threaded)
ii  libqt3-mt-psql         3.3.4-8ubuntu5  PostgreSQL database driver for Qt3 (Threaded
ii  libqt3-mt-sqlite       3.3.4-8ubuntu5  SQLite database driver for Qt3 (Threaded)
ii  qt3-designer           3.3.4-8ubuntu5  Qt3 Designer
ii  qt3-dev-tools          3.3.4-8ubuntu5  Qt3 development tools
ii  qt3-qtconfig           3.3.4-8ubuntu5  The Qt3 Configuration Application

A alguien se le ocurre que puede estar pasando?

+1
0
-1
Imagen de Anónimo
+1
0
-1

Saludos!
Sólo comentar que yo he tenido el mismo problema al actualizar mi Kubuntu a Breezy... así que algo tendrá que estar mal.
Comentar que, aunque mis configuraciones de idioma (Español) parecen correctas, no puedo escribir acentos ni diéresis (ahora escribo desde Windows :( ), aunque al abrir un documento que los contenga, puedo leerlos sin problema.
Espero que alguien nos pueda echar una mano

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo he probado otra cosita que parece hacer pensar que el fallo es de las Qt, aunque no tengo ni idea de cómo arreglarlo.
El caso es que el Synaptic y otras aplicaciones GTK sí que me permiten escribir acentos, aunque sea en KDE (ahora mismo estoy con Kubuntu y Firefox).
Alguna solución...

+1
0
-1
Imagen de Anónimo
+1
0
-1

Ya está arreglado: me dijo un amigo que reconfigurara las locales y pusiera "es_ES.UTF8" y listo (hay que reiniciar).

Para aquellos que, como yo, no sepan reconfigurarlo, hay que poner en el terminal:
sudo dpkg-reconfigure locales
y seleccionar "es_ES.UTF8"

Un saludo

+1
0
-1
Imagen de Anónimo
+1
0
-1

Lamentablemente solamente seleccionando es_ES.UTF8 no funciona, lo hice y sigue igual.

+1
0
-1
Imagen de tx2z
+1
0
-1

A mi me funcionan, aunque recuerdo que fue una locura conseguirlo y no se los pasos que seguí, asique pongo como lo tengo ahora (si se me pasa algo avisarme):

en el menu de kde en "system setings", "regional y accesibilidad", "disposición del teclado" y puse Spain (es) basic y mi teclado. Me parece que venia el inglés como predeterminado.
En "pais región e idioma" tengo España-Español

Haciendo en consola "sudo dpkg-reconfigure locales" tengo seleccionadas:

[*] es_ES@euro ISO-8859-15
[*] es_ES ISO-8859-1
[*] es_ES.UTF-8 UTF-8

junto con otras inglesas

y como predeterminada tenfo es_ES.UTF-8

espero que ayude...

+1
0
-1
Imagen de Luis José
+1
0
-1

Tengo Kubuntu 5.10 en un AMD64 y tengo el mismo problema que habéis comentado con las tildes.
Puedo escribir tildes en la mayoría de los programas y OpenOffice las reconoce en los documentos, pero no me deja escribirlas.
He probado todo lo que habéis comentado aquí pero, al final, el único apaño que he encontrado ha sido instalar el entorno Gnome. En una sesión de Gnome puedo escribir tildes perfectamente en OpenOffice. No me gusta nada este entorno pero peor sería tener que editar los documentos en Windows. ¿Alguna idea?

+1
0
-1

Luis José Sánchez

Imagen de opradi
+1
0
-1

lo he solucionado de una forma tan fácil.

Datos: Teclado de portatil en inglés.

1. Ubuntu en ingles
2. System>Preferences>keyboard>layouts
puse 2: a. U.S. English b. U.S. English Alternative International, seleccionen como default el U.S. English Alternative
3. Teclado: Generic 104KEY PC
4. luego de cerrar todo
5. Click derecho sobre la barra de estado superior
6. Add to panel
7. Utilities>Keyboard indicator
8. aparecerán las siglas USA en esta barra, al hacer click sobre la palabra aparece USA* lo que quiere decir que esta funcionando el US_int.
8. Resuelto el problema.

Espero que le sirva a alguien.

+1
0
-1
Imagen de docconde
+1
0
-1

Tenia el mismo problema, tengo ubuntu en una laptop toshiba satellite A70 y no podia poner tildes ni escribir la letra ñ. He seguido los pasos que da opradi y ahora todo funciona de maravilla (áäéëíïóöúüñÑ).Gracias.

+1
0
-1
Imagen de will824
+1
0
-1

Hola a todos.

Estuve mirando su problema y yo sufria el mismo...

Segui algunas indicaciones de los posts y logre que los acentos funcionaran de forma adecuada en casi todo el Sistema menos en open office.

Por lo tanto segui la siguiente guia y logre que por fin funcionara:

http://www.gentoo.org/doc/es/utf-8.xml

Las partes que me fueron útiles fueron mas que todo las de la sección 2.

Espero que les sirva, pues de todas formas es Linux, independiente de la distribución.

Will

+1
0
-1

Will

Imagen de Anónimo
+1
0
-1

La solución que a mi me a funcionado es:

sudo dpkg-reconfsudo dpkg-reconfigure localesigure locales

+1
0
-1
Imagen de rcbonil
+1
0
-1

Bueno yo en realidad soy nuevo en el mundo del linux y no tuve problemas con la instalación, pero encontre que cuando voy a colocar tildes y eñes no funciona de la forma correcte por ejemplo: acci'on o espa~nol y estado buscando por todos lados y no encontrado solución....

Yo estoy utilizando un teclado ingles y en windows me le coloco ingles internación y listo funciona pero en ubundu he estado realizando todas las combinaciones posibles y nada.

Les agradeceria si pueden darme una solución a este inconveniente para hacer más rapida mi transcición al linux y dejar ya este windows.

Muchas gracias...

Nota: este solicitud la he realizado desde windows

+1
0
-1
Imagen de rcbonil
+1
0
-1

Les cuento que mi teclado (el mio es ingles) funciona perfectamente ñÑóáéíúÉÁÓÚÍìòùèàÒÙÌÈÀôîûêâ y los demás caracteres que antes no funcinaban (se acuerdan que el anterior lo hice en windows,este lo estoy haciendo en mi ubuntu 5.10)

Bueno que hice para que funcionara, pues fueron muchas las cosas, probe todo lo que se dice aquí y hasta el momento no me funcionaba, entonces vi el último mensaje y prové siguiendo los siguientes pasos:

1. Ir a sistema>Preferencias>teclado e hice clic en la pestaña de distribuciones, y agrege spain y luego probe y nada no funcionaba.

Luego estuve buscando sobre algo que hablara regional y horario o algo parecido como en windows he hice lo siguiente:

2. ir a Sistema>Administración>Lenguage Selector y entonces me pidio si instalaba los lenguajes predeterminados o algo por el estilo y luego que se instalaron los paquetes, verefique que el español estuviera activo y también vi que el ingles estaba activo (o sea asignado) y Voilà empesarón a salir las tildes y simbolos que antes no funcinaban pero como si tuviera teclado en españo (acuerdense que tengo teclado de idioma ingles).

Pues luego de un gran sonrisa se satisfacción, cambie el idioma del teclado y listo comence hacer este mensaje para que si alguien que tenga este problema lo soluciones y disfrute al fin de Ubuntu 5.10

+1
0
-1
Imagen de Anónimo
+1
0
-1

hola me llamo julio cesar bueno yo solucione ese probleama con el siguiente comando dpkg-reconfigure locales ya que utilizas ubuntu y es un buen debian asegurate de tener activado lo siguiente a en_US, es_ES y es_PE, todos en iso8859-1 si tu teclado es EEUU la letra ñ te saldra con la tecla :; en tu teclado si no prueba con conbinaciones posibles saludos

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola a todos, llevo varias semanas con el problema, igual que vosotros, concretamente yo funciono con Kubuntu 5.10 bajo AMD64.

He resuelto el problema, que parece que esta muy relacionado con las QT. A pesar de instalar el paquete libqt3-i18n, me seguia dando el problema (yo creo que debe ser que al usar qt4 no hace bien el tema de la internacionalizacion en algunos casos o a saber que).

Para OpenOffice lo he solucionado eliminando el paquete de KDE para OpenOffice2:

apt-get remove --purge openoffice.org2-kde

Ahora ya puedo usar OpenOffice2 sin problemas. Por supuesto tienes que configurar bien los locales, en /etc/enviroment:

LANGUAGE="es_ES:es_ES@euro:es:en_GB:en"
LANG=es_ES
LC_ALL=es_ES
LC_TYPE=es_ES

Espero que os sirva de ayuda a todos los que como yo estabais con el problema.

Un saludo y suerte.

slerena arroba genterara punto com

+1
0
-1
Imagen de strusberg
+1
0
-1

Las versiones anteriores de KDE ofrecian dos tipos de teclados en Inglés: Uno estándar y otro US Internacional. En Kubuntu es posible usar un teclado en Inglés y que los acentos (y la ñ) funcionen activando la opción «intl» del campo «Variante del Diseño» del teclado en Inglés. Este campo se encuentra en la sección «Disposición del Teclado» del Panel de Control.

Los pasos son:
1.- Corra el Panel de Control
2.- Seleccione Regional y Accesibilidad
3.- Seleccione Disposición del Teclado
4.- Seleccione Inglés US en la sección de diseños activos;
5.- Seleccione «Intl» en variante del diseño;
6.- Aplique el cambio.

Ahora los acentos (y la ñ) deben funcionar en todas las aplicaciones de KDE.

Saludos

+1
0
-1