Ayuda configurando ADSL

Imagen de paracaidista
0 puntos

Wens!!

Soy novato en Linux, siempre he tenido Windows, desde aquel Windows 3.11 hasta ahora el Vista y quiero migrar a Linux porque me parece una mejor opción que Windows.

Hace unos meses instale Ubuntu 6.xx pero no conseguí hacer funcionar mi modem USB. Hace poco me enviaron el nuevo Ubuntu 7.04 que he instalado en una partición, mas otras dos… una donde esta el Windows Vista y otra de 40 Gigas para meter datos.

  1. Primer problema: Desde Windows no puedo acceder a la partición de 40 Gigas, desde Linux si… ¿Alguna solución? En cambio si me deja acceder a la partición donde esta Windows Vista.

Aunque eso es lo menos importante… Lo principal esque quiero acabar de configurar mi ADSL, para poder provar y bajarme, instalar paquetes, aplicaciones sin tener que ir de Linux a Windows y viceversa…

He conseguido hacer que Linux me reconozca el modem, siguiendo un tuto para instalar y configurar el ueagle… El problema ahora es Configurar mi ADSL.

Nota: Es un modem Zoom 5510b y un ADSL de medio mega que me proporciona ENIAC, en La Rioja por un precio de 16€/mes y tengo contratado Telefónica.

Para conectarme en Windows, una vez reconocido este mi modem, tengo que crear una nueva conexión de Internet por marcación, para así poder ingresar el número de teléfono que me dan (p8`32), el nombre y pass.
2. Eso como lo hago en Ubuntu?? Ese es mi problema… pues si hago el tuto solo puedo ingresar el nombre, pass y las DNS (que también tengo, aunque en Vista no las tengo puestas y va igual el ADSL).

He estado investigando, y e visto que un programa que podría servir es el Kppp aunque no lo tengo instalado, he intentado instalar el kdenetwork-3.5.7.tar.bz2 que se supone k trae el Kppp pero no lo he logrado. He leído algo sobre el WVDial aunque no lo he probado.

Alguna sugerencia?? Ahh… cuando configuro todo como me dicen en la guía, e inicio el ueagle aparece en el modem la lucecita parpadeando de que recibe y envía datos al PC… pero claro, no se conecta a internet porque tengo que marcar el número de teléfono.

  • Otra solución que intente probar, fue el instalar un emulador para Windows XP… Pero no lo logre instalar… Luego conseguí que Linux me reconociera el modem y espero conseguir configurarlo y olvidar esta segunda opción, que creo que es a la desesperada, es decir, emular XP e instalar y configurar desde ahí el modem.

Primero dar las gracias al que haya leido todo esto!! Y si me ayuda y consigo entrar a Internet en linux se las volvere a dar... siendo mi primer post en internet en linux jeje!!

Imagen de Javier M.
+1
0
-1

Hola paracaidista.

Vamos a ver si te sirve esto.

Entra en Sistema-Administracion-Red

En la pestaña de conexiones, tienes una opcion (la ultima) que es conexion con modem, si lo marcas y pulsas propiedades, puedes configurarlo.

No se si es eso lo que buscas, pero espero que te sirva.

Para la primera duda, tendrias que dar mas datos, pero claro si es win el que no lee la particion ya es un problema de win y no de ubuntu. De todos modos si no lee la particion puede que sea por que hayas creado esa particion en ext3. 

Un saludo y bienvenido.


 

+1
0
-1
Imagen de paracaidista
+1
0
-1

Ya mire esa opcion.... Pero al introducir numero telefonico no te deja Letras!! es decir, no puedo poner el mio k es p8,32

Eso solo esta limitado a conexion normal de poner tu nº de telfono y nombre, pass k te proporcionaria en mi caso telefonica... pero a 56Kbps.

 

Y a lo de la 1ª opcion... en principio tenia Windows Vista y con otra particion, pa meter todos ls instaladores d programas y cosas basicas y pa pelis, etc. 40 Gigas, asi si formateo no pierdo gran cosa.

Luego, meto el CD live de linux... Elijo la 1ª opcion, es decir, que del disco duro principal, donde sta W.Vista particione su 80% y lo libre para Linux... Todo bien, solo que ahora la particion de 40 Gigas desde Windows no puedo entrar y si en linux.. 

Jeje.. el problema es de Windows.. pero ocasionado x linux.

 

Gracias x contestar!!

Otras soluciones??

Seria muy bruta la ultima opcion? emular windows XP y entrar a internet desde la emulacion haciendolo funcionar en Vista??

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola:

 ADSL es un sistema que utiliza como protocolo básico el PPPoE el cual se
configura con la IP que tendremos hacia la Internet. El modem ADSL negocia una IP y demas datos (DNS, etc) cuando es cargado el
"adsl-start" si está instalado para conexión desde el momento en que se
enciende el PC. En esa negociación valida un usuario (fulano@servicio) y una
password para poder activarte el modem.
Hay modems ADSL que se activan bajo demanda de datos. Mas allá de esto sepuede activar/desactivar la conexión como cualquier modem si lo desea. Estoes con un programa discador (que no necesariamente va a discar).
Fisicamente la señal viaja en una frecuencia mucho mas alta que la audible,
por esto es que se puede mantener la linea telefónica libre mientras por el
par trenzado de cobre viajan los datos.
Por lo tanto, tienes instalado por default wvdial, este se configura con:

sudo wvdialconf /etc/wvdial.conf

Esta es una guias para su configuración,

En /etc/wvdial.conf se tendría algo como lo siguiente:

[Dialer Defaults]
Modem = /dev/ttyS3
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L3
; Phone =
; Username =
; Password =

Añadiremos una interfaz o Dialer. Es conveniente utilizar como nombre para este Dialer el mismo que corresponde a la primera interfaz PPP, es decir ppp0. También será necesario especificar el nombre de usuario, contraseña y número telefónico al cual se deberá marcar para acceder a Internet. Será conveniente también habilitar el modo Stupid, a fin de que pppd se encargue de hacer toda la negociación de comandos ATT necesarios:

[Dialer ppp0]
Username = nombre_de_usuario
Password = su_contraseña
Phone = teléfono_de_su_proveedor
Inherits = Dialer Defaults
Stupid mode = 1

Habiendo hecho lo anterior, /etc/wvdial.conf debe haber quedado del siguiente modo:

[Modem0]
Modem = /dev/modem
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L3

[Dialer Defaults]
Modem = /dev/modem
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L3

[Dialer ppp0]
Username = nombre_de_usuario
Password = su_contraseña
Phone = teléfono_de_su_proveedor
Inherits = Dialer Defaults
Stupid mode = 1

Debe crearse un fichero denominado /etc/sysconfig/network-scripts/ifcfg-ppp0, el cual deberá contener los siguientes elementos:

DEVICE=ppp0
NAME=ppp0
WVDIALSECT=ppp0
MODEMPORT=/dev/modem
LINESPEED=115200
PAPNAME=nombre_de_usuario
USERCTL=true
ONBOOT=no
PERSIST=yes
DNS1=200.33.213.66
DNS2=200.33.209.66

DEFROUTE=yes
BOOTPROTO=none
DEMAND=no
IDLETIMEOUT=3800
PEERDNS=yes

De los anteriores parámetros, debe editarse WVDIALSELECT, PAPNAME, DNS1 y DNS2 para que concuerden con la interfaz y el nombre de usuario especificado en /etc/wvdial.conf, así como los DNS, mismos que también deben coresponder con los especificados en /etc/resolv.conf

Note por favor que si desea poder iniciar y detener la interfaz ppp0, deberá está incluida el parémetro USERCTL con valor true. En caso contrario, solo podrá hacerse como root.

DEVICE=ppp0
NAME=ppp0
WVDIALSECT=ppp0
MODEMPORT=/dev/modem
LINESPEED=115200
PAPNAME=nombre_de_usuario
USERCTL=true
ONBOOT=no
PERSIST=yes
DNS1=200.33.213.66
DNS2=200.33.209.66
DEFROUTE=yes
BOOTPROTO=none
DEMAND=no
IDLETIMEOUT=3800
PEERDNS=yes

Asigne permiso 555 a /etc/sysconfig/network-scripts/ifcfg-ppp0 y copiese, con el mismo nombre y propiedades, dentro de el directorio /etc/sysconfig/networking/devices/

cd /etc/sysconfig/
chmod 555 network-scripts/ifcfg-ppp0
cp -p network-scripts/ifcfg-ppp0 networking/devices/

Debe editarse /etc/ppp/pap-secrets y /etc/ppp/chap-secrets a fin de especificar nuevamente el nombre de usuario y contraseña correspondientes, de acuerdo a como se hizo en /etc/wvdial.conf:

nombre_de_usuario	*	su_contraseña

Levantado y deteniendo la interfaz.

Para conectarte a Internet puede ejecutarse el siguiente comando:

/sbin/ifup ppp0

O bien puede hacerlo, como root, con wvdial del siguiente modo:

/usr/bin/wvdial ppp0

Para deconectarse, se puede utilizar este otro comando:

/sbin/ifdown ppp0

Si acaso pppd marca algún error al intentar iniciar la interfaz, significa que hay errores entre algunos de los ficheros antes mencionados, o bien /dev/modem apunta al dispositivo de moden incorrecto. Revise que TODOS los datos estén correctos y vuelva a intentarlo.

 

Gabriel

+1
0
-1
Imagen de paracaidista
+1
0
-1

Se agradece el manual!! Aunque de momento no me ha servido Empiezan los problemas...

 Cuando voy a editar el wdial.conf

 sudo wvdialconf /etc/wvdial.conf

 

No me reconoce el modem... O eso entiendo x lo que me aparece:


 paracaidista@paracaidista:~$ sudo wvdialconf /etc/wvdial.conf
Password:
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   

Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDial

If you still have problems, send mail to <wvdial-list@lists.nit.ca>.
paracaidista@paracaidista:~$


Mira haber si se te ocurre algo, gracias!!
+1
0
-1
Imagen de jajajavi
+1
0
-1

no sé si funciona en vista, pero desde winxp uso explore2fs para leer (no escribir) la partición gnu/linux, también te recomiendo que instales el programita (desde automatix) que permite leer/escribir particiones ntfs.

+1
0
-1
Imagen de lauchacba
+1
0
-1

"Para conectarme en Windows, una vez reconocido este mi modem, tengo que crear una nueva conexión de Internet por marcación, para así poder ingresar el número de teléfono que me dan (p8`32), el nombre y pass. "-------

bueno creo que el P8,32,,, serian los numeros que ves al clickear en "aceptar" cuando abris el icono de escritorio o el acceso directo....de conexión-adslo como se llame.

te dejo esta dos entradas de bitacora. como son entradas de bitacora segui tu consulta en este hilo que abriste para seguir "ayuda configuración adsl".

lectura guia:

 http://www.ubuntu-es.org/index.php?q=node/45097

lectura guia con posibles errores..( es mi bitacora,)

http://www.ubuntu-es.org/index.php?q=node/36369

te recomiendo que uses la primera, igual seria desde el paso de configuración del ISP, si ya te reconocio el modem, saltea la parte del firmware. a partir del octavo paso en el mio,,,laucha,

a partir del paso 4 en el de joaquindlz.

datos: las DNS primaria y secundaria preguntaselas a tu proveedor directamente,,el 8,32 creeria que son ,,curiosamente tu VPI y VCI...claro que esto es teoria pura, pero a mi me salia el p0,33 que serian: VPI 0, VCI 33 .

donde usas esto del vpi y vci?

sudo br2684ctl -c 0 -b -a 8.32

bueno ,,,hasta luego y espro te sirva.

 

==========lauchacba@hotmail============= http://ar.geocities.com/novatocba/doc/files/ubuntu-linux.pdf

http://www.ratonera.raton.net.ar primeros pasos...

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de paracaidista
+1
0
-1

Stoy siguiendo esa guia... Y ya tengo un error... Al instalar el rp-pppoe-3.8

Eso es lo que me muestra la terminal: 

 

paracaidista@paracaidista:~$ cd rp-pppoe-3.8
paracaidista@paracaidista:~/rp-pppoe-3.8$ sudo ./go
Running ./configure...
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
Oops!  It looks like ./configure failed.
paracaidista@paracaidista:~/rp-pppoe-3.8$

 

-------------

Haber si asi se entiende un poco mejor como va mi ADSL y eso del numero de telefono xD

Segun mi guia de instalacion, que no es mas que un folio imprimido xD Tengo que instalar el asistente de instalacion y elegir:

Kmet Comunicaciones PPPoE

VPI = 8, VCI=32 Encapsulado: PPPoE LLC

 

Una vez hecho esto reiniciar, conectando el modem. Y configurarlo de la siguiente manera para WinXP:

En propiedades de la conexion creada x el asistente, en Funciones de Red tenendo seleccionado TCP/IP activar las casillas de usar las siguientes DNS:

DNS1- 82.199.32.34

DNS2-  82.199.32.36

 Esto para WinXP, ya k se puede configurar de forma parecida para Win98, WME y W2000.

 

Y debajo... IMPORTANTE (Para todos los Sistemas Operativos)

El numero de teléfono a marcar es el que viene por defecto "p8,32" (sin las comillas).

Y luego nombre d usuario y mi pass.

 

----------------------

En cambio, en el Vista no se terminaba de instalar bien... solo cogia los drivers y me detectaba el modem, asi que simplemente le di a Crear nueva conexion de acceso Telefonico, elegir conectar a traves del modem, puse en nº de telefono, p8,32 , el nombre y pass. Y me conecte, sin haber usado lo de VPI, VCI, el Encapsulado y sin DNS... ¿?¿?
 

+1
0
-1
Imagen de paracaidista
+1
0
-1

A esto ya me respondo yo mismo, falataba de instalar el paqueta built-essential

Bueno, programa instalado y configurado... Le doy a iniciar adsl... se pone a conectar con el adsl.. Lo se porque parpadea la luz de la etiqueta "Data"... Y al cabo de unos 10 o 15 segundos pone:

Time out

 

En toda la configuracion no he puesto en ningun lugar el nº d telefono...  

He visto en softonic.com algo de un programa llamado eznet que igual puede servir... Pues en la configuracion tiene para introducir un numero telefonico...

Alguien tiene idea de lo que debo hacer o de como solucionarlo?? Quiero mi ADSL en Linux ya!! jeje!! 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola:

1) El rp-pppoe-3.8 te dice que: dentro del directorio donde queres configurarlo, en el archivo config.log te está informando sobre los errores encontrados.

2) Tu modem no requiere discado, de ahí que wvdial no lo encuentra.

3) Los números que das son los VPI y VCI que requiere la conexión de tu empresa.

4) Para configurarlo:

Configuración de pppd

Es necesario editar (o crear si no existe) 4 archivos:

/etc/ppp/options

/etc/ppp/peers/adsl

/etc/ppp/chap-secrets

/etc/modules.conf

/etc/ppp/options

Dejarlo como sigue comentando las lineas que sobren con # al inicio

    # Inicio de options
defaultroute
noauth
usepeerdns
lock
noipdefault

#fin de options

/etc/ppp/peers/adsl

Los parametros

VPI (Virtual Path Id) y VCI (Virtual Circuit ID) los ha de proveer el ISP donde tengamos contratada la conexión. Son los ya famosos 8 y 32

 

    #debug
kdebug 1
noipdefault
defaultroute
#
# edit the following line for your provider. examples follow
# France, wanadoo: -vpi 8 -vci 35
# UK, BTopenworld: -vpi 0 -vci 38
# you may use one of the following PPPoA methods:
# pppoa2: uses fork to create a read and write process
# pppoa2m: backported new atm-aal5 stack from pppoa3 in pppoa2m
# pppoa3: uses threads
pty "/bin/pppoe -vpi 8 -vci 32"
nodetach
sync
#
# put your username in the following line
user "miusuario"
noauth
kdebug 1
noaccomp
nopcomp
#nomagic
noccp
#passive
#lcp-echo-interval 5
#lcp-echo-failure 30
#persist

/etc/ppp/chap-secrets:

Este archivo nos permite especificar la password para la autentificación del usuario con el que nos conectaremos.

    # Secrets for authentication using CHAP
# client server secret IP addresses
miusuario * mipassword

/etc/modules.conf:

Las lineas añadidas para la configuración de adsl son las 8 últimas (en itálica).

    alias parport_lowlevel parport_pc
alias eth0 3c59x
alias usb-controller usb-uhci
alias sound-slot-0 sb
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :pre-remove sound-slot-0 /bin/aumix-minimal
-f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias synth0 awe_wave
alias char-major-108 ppp_generic
alias /dev/ppp ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-13 n_hdlc
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate

Arrancar el firmware

# modem_run -m -f /path/to/mgmt.o  (ava va el de tu modem)

arrancar pppd

#pppd call adsl

En teoría con esto debería andar y tener el enlace ppp0 abierto, para revisar esto basta escribir:

# ifconfig ppp0 

Espero que esto te ayude en algo.

Suerte.

Gabriel

+1
0
-1
Imagen de paracaidista
+1
0
-1

Gracias por contestar tan rapido!!

 

Haber si me sale con lo que dices... Pero ya hay un problemas:

 No tengo creados los archivos:

/etc/ppp/peers/adsl

/etc/modules.conf

 ¿Como los creo?

Hmm... luego copio todo lo que me pones directamente no? Los comentarios hace falta copiarlos, o daria igual? 

 

 --------------- 

Aparte:

En lo que pones en el Asunto: ADSL por Discado? No tengo ni idea de lo que es eso... jeje! Nose, simplemente en windows tengo que marcar un nº de telefono... Ni yo se porque tengo el ADSL asi... Antes tenia telefonica y era lo normal, user pass y DNS... Con Eniac ahora, de KNET Comunicaciones, me venia ademas el numero ese que me tene harto... Incluso he hecho mi teoria y todo xD Igual es para que telefonica detecte el numero especial ese y me lo desvia hacia la centralita de Eniac para conectarme... vete a saber... 

+1
0
-1
Imagen de lauchacba
+1
0
-1

bueno si ya tenes build-essential instalado... libatm1 y br2684ctl,,,los primeros dos los podes instalar con synaptix y al segundo con doble clik..con paquetes o gestor de paquetes gdebi si usas el click derecho.

los archivos el rp-pppoe te los crea solo....solo tenes que agregar el archivo ADSL,,, al hacer ./go o sudo ./go te sale una lista larga larguita...y queda en las opciones:

user:

(etho?)

no

dns's

pass

firewall

y/n

en este ultimo antes de poner yes  fijate que este bien los datos, si esta mal alguno de ellos  pones que no y vuelve a pedirte los datos.

si ejecutas $ ./go puede que te de error, ya que no estas como "ROOT"esto es diferente si haces # ./go el promp $ o # indica como estas...en todo caso hace $ sudo ./go

para conectarte podes cambiar el archivo rc.local en mi entrada de bitacora dejo una guia gráfica..para explicar mi experiencia. o de lo contrario en terminal:

sudo modprobe br2684

sudo br2684ctl -c o -b -a vpi.vci

sudo ifconfig nas0 up 

sudo pppoe-start

para desconectar sudo pppoe-stop

si haces un sudo pppoe-start sin los tres previos...es más seguro de que llegues a la luna primero a que se conecte.

espero te halla servido. 

==========lauchacba@hotmail============= http://ar.geocities.com/novatocba/doc/files/ubuntu-linux.pdf

http://www.ratonera.raton.net.ar 

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de paracaidista
+1
0
-1

Jeje, esto ya va por dos bandas diferentes...

En cuanto a lo del metodo de Gabriel Muñoz... que ya he puesto un problema antes, como crear los dos archivos que me faltan...

 

Y a tu metodo... que no me ha servido Configuro todo como se supone que debe ser... Y al dar a pppoe-start Me aparecen los puntitos .................. y al cabo de unos 15 segundos aparece  Time Out. Pero estoy seguro de que hay transferencias de datos con el modem... Pero este no logra conectarse a internet.

 

Mi opinion esque estamos mal encaminados... que estamos intentando conectar mi conexion como si fuera ADSL "normal"... con un nombre, una pass, dos DNS, y una vpi y vci.

Creo que habria que intentar que linux me reconociese el modem como si fuera para una conexion Dial-UP... y que en numero de telefono me admita p8,32 (la letra p y la coma)

De este modo no hce falta tener que poner las DNS ni vpi, vci... Solo tres cosas, tel, nombre, pass...

 

Haber que os parece... O si estoy haciendo algo mal... nose... Buff... que ganas d tener el Adsl para empezar a configuar la tarjeta NVIDIA, ya que bajandome el paquete.run no he logrado hacerlo... xD Reinicie y no cargo el modo grafico x nose que errores... que susto jaja! menos mal que lo arregle :P volviendo al controlador "nv" xD 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola:

Recorriendo la web encontré este chisme o tip o truck como quieras:

Para evitar que luego de los los puntitos te diga Time Out, inicia Ubuntu con el modem deconectado y conectalo luego de que se haya cargado todo el escritorio (led del hd se apaga).

No se si funciona pues yo tengo solo dial up, pero no es complicado de probar.

Suerte 

Gabriel

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola paracaidista:

Espero que se te abra el paracaidas y te conectes a internet:

Este es un resumen de todos los post recorridos:

Configuración ADSL Modem USB en Ubuntu Feisty Fawn

Se requieren los siguientes paquetes:

rp-pppoe-3.8.tar.gz

desde:  http://www.roaringpenguin.com/penguin/open_source_rp-pppoe.php

br2684ctl.deb

libatm1xxx.deb

desde: http://packages.ubuntulinux.org/feisty/net/br2684ctl

 

ueagle-data-1.1.tar.gz

desde: http://eagle-usb.org/ueagle-atm/non-free/ )

build-essential

$ sudo apt-get install build-essential

 

Instalar el firmware del módem

$ tar xzf ueagle-data-1.1.tar.gz

$ cd ueagle-data-1.1

Crear el directorio ueagle-atm para alojar los firmwares

$ sudo mkdir /lib/firmware/ueagle-atm

Copiar los archivos del directorio “ueagle-data-1.1” al directorio

$ sudo cp -a *.* /lib/firmware/ueagle-atm

Activar el driver:

$ sudo modprobe ueagle-atm

Si está todo bien en el modem la luz de link principio parpadea y luego queda encendida, si no queda encendida, reiniciar la PC y al terminar la carga de Ubuntu enchufar el modem

Confirmar su funcionamiento

$ dmesg | grep ueagle

Informa al go similar a esto:

usb 1-1: [ueagle-atm] (re)booting started

usb 1-1: [ueagle-atm] ATU-R firmware version : 44e2ea17

usb 1-1: [ueagle-atm] Modem started, waiting synchronization

usb 1-1: [ueagle-atm] modem operational

Crear una interface de red

$ sudo apt-get install libatm1

$ sudo dpkg -i br2684ctl_20040226-1_i386.deb

$ sudo modprobe br2684

$ sudo br2684ctl -c 0 -b -a 8.32

(Aclaración acá están colocados tus números de VPI y VCI de tu ISP)

Teóricamente tendrías una salida parecida a esto:

RFC1483/2684 bridge: Interface "nas0" created sucessfully

RFC1483/2684 bridge: Communicating over ATM 0.0.33, encapsulation: LLC

RFC1483/2684 bridge: Interface configured

Ahora para terminar;

$ sudo ifconfig nas0 up

Instalar y configurar rp-pppoe

$ tar -zxvf rp-pppoe-3.8.tar.gz

$ cd rp-pppoe-3.8

$ sudo ./go

Se inicia el asistente, requiere tener instalados previamente build-essential

1.Enter your PPPoE user name:

(tu nombre de usuario)

2.Enter the Ethernet interface connected to the DSL modem:

(nas0)

3.Enter the demand value:

(no)

4.Enter the DNS information here: DNS primario

(tu numero de DNS formato xxx.xxx.xxx.xxx)

5.Enter the secondary DNS server address here: DNS secundario

(tu numero de DNS formato xxx.xxx.xxx.xxx)

6.Please enter your PPPoE password:

(tu password)

7.Please re-enter your PPPoE password:

(tu password)

8.Choose a type of firewall (0-2):

(1)

9.Accept these settings and adjust configuration files (y/n)?

(y)

 

Completar archivos de configuración:

$ sudo gedit /etc/resolv.conf

search (nombre de tu proveedor)

nameserver (formato xxx.xxx.xxx.xxx)

nameserver (formato xxx.xxx.xxx.xxx)

Guardar

Cuando se conecta, generalmente los servidores escriben los números correctos

$ sudo gedit /etc/ppp/peers/adsl

# example configuration for the kernel space PPP over Ethernet driver

# See the manual page pppd( for information on all the options.

# MUST CHANGE: replace myusername@realm with the PPP login name given to

# your by your provider.

# There should be a matching entry with the password in /etc/ppp/pap-secrets

# and/or /etc/ppp/chap-secrets.

user "tu nombre de usuario"

# Load the PPPoE plugin.

plugin rp-pppoe.so

# Ethernet interface to which the modem is connected.

nas0

# Assumes that your IP address is allocated dynamically by the ISP.

noipdefault

# Try to get the name server addresses from the ISP.

usepeerdns

# Use this connection as the default route.

defaultroute

# Makes pppd "dial again" when the connection is lost.

persist

# Do not ask the remote to authenticate.

noauth

Guardar

$ sudo gedit /etc/ppp/pap-secrets

Saldrá algo así al final:

"tu nombre de usuario" * "password"

Guardar

$ sudo gedit /etc/ppp/chap-secrets

# Secrets for authentication using CHAP

# client server secret IP addresses

"tu nombre de usuario" * "password"

Conectarse a internet

$ sudo pppoe-start

 Deben aparecer puntos .... y luego de un tiempo CONNECTED!

 También es posible conectarse con

 $ sudo pppd call adsl

 Este no da ningún mensaje

 Cada vez que se inicia Ubuntu es necesario hacer

 $ sudo modprobe br2684

$ sudo br2684ctl -c 0 -b -a 0.33

$ sudo ifconfig nas0 up

$ sudo pppoe-start

 Conectarse al inicio

 Es necesario editar /etc/rc.local

 $ sudo gedit /etc/rc.local

 Al final y previo a “exit 0” agregar

 modprobe br2684

br2684ctl -c 0 -b -a 0.33

ifconfig nas0 up

pppoe-start

 Al iniciar a partir de ahora Ubuntu estaría conectado

 Para comprobarlo:

 $ sudo pppoe-status

 Espero que funcione, sino insistiremos!!!

 Gabriel

+1
0
-1
Imagen de paracaidista
+1
0
-1

Provare haber lo del truco ese... Sino volvere a seguir la guia tuya Gabriel paso por paso que no me haya dejado nada y lo volvere a intentar...

Esta tarde os comento que tal.

Gracias x la ayuda!! 

+1
0
-1
Imagen de paracaidista
+1
0
-1

Reviso todo el manual y reviso la configuracion por si algo he hecho mal... creo que esta todo bien... Le doy a conectar y me aparece Time Out... Por si sirve de algo he hecho un pppoe-status que me muestra esto:

 

paracaidista@paracaidista:~$ sudo pppoe-status
pppoe-status: Link is attached to ppp0, but ppp0 is down
paracaidista@paracaidista:~$

 sabeis que puede pasar??

saludos!! 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola:

Por lo que lei en la web hay un problema de paquetes entre tu servidor y tu pc al establecer comunicación, lo demás está todo bien.

Prueba con

sudo gedit etc/modules.conf:

y agrega o descomenta;

    
alias tty-ldisc-3 ppp_async
alias tty-ldisc-13 n_hdlc
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate

Esto es porque algunos ISP necesitan async y sinctty habilitados.

Saludos 

Gabriel

+1
0
-1
Imagen de paracaidista
+1
0
-1

Igual el error esta ahí... Para empezar no tengo el archivo ese.

Pues digo.. perfecto, vamos a hacerlo... Y no se me ha ocurrido nada mas que cojer otro archivo con la extension .conf y borrarle todo y meter esos parametros que me has indicado... Voy a la terminal y pongo   mv modules.conf /etc/

y compruebo que se ha movido... meto desde terminal otra vez sudo gedit etc/modules.conf y no se me abre.. m dice qe no esta cuando lo acabo de poner!!

Sabes que puede pasar? O hay alguna forma de indicar en terminal la creacion de ese archivo??

Saludos!! 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola:

Instala el mc

y navega con este.

Si el archivo se movió y se copió lo encuentra.

sino se crea con

sudo update-modules

También te faltan:

resolv.conf ubicado en: /etc/resolv.conf

nameserver (tu dns)

nameserver (tu dns)

search (nombre de tu ISP)

y adsl en el directorio /etc/ppp/peers/

 

# example configuration for the kernel space PPP over Ethernet driver

# See the manual page pppd( for information on all the options.

# MUST CHANGE: replace myusername@realm with the PPP login name given to

# your by your provider.

# There should be a matching entry with the password in /etc/ppp/pap-secrets

# and/or /etc/ppp/chap-secrets.

user "tu nombre deusuario"

# Load the PPPoE plugin.

plugin rp-pppoe.so

# Ethernet interface to which the modem is connected.

nas0

# Assumes that your IP address is allocated dynamically by the ISP.

noipdefault

# Try to get the name server addresses from the ISP.

usepeerdns

# Use this connection as the default route.

defaultroute

# Makes pppd "dial again" when the connection is lost.

persist

# Do not ask the remote to authenticate.

noauth

Crealos de a uno y andá probando.

PD: también encontré que en Argentina algunos servidores piden la edición de:

/etc/network/interfaces
  Al final del archivo habría que agregar:

auto nas0
iface nas0 inet static
   pre-up br2684ctl -c 0 -b -a 0.33 || true
   address [IP]
   netmask [máscada de red]
   broadcast [broadcast]
   gateway [IP del servidor]
   pointopoint [IP del servidor]

Reemplazando  lo que está entre corchetes por los datos que nos tiene que proporcionar el proveedor del servicio.

Saludos y suerte 

Gabriel

+1
0
-1
Imagen de paracaidista
+1
0
-1

Voy a prbar a crear esos archivos...

Yo soy de españa xD Asi qe no creo k eso ultimo sea el error... ademas de que no me hn proporcionado nada mas que el nombre, la contraseña, las DNS, el vci y vpi y el numero de telefono.

Ya te contare como me ha ido.. Gracias de nuevo! 

+1
0
-1