Error synaptic al actualizar kernel

Imagen de tinsax
0 puntos

Hola a todos!

Lo primero de todo daros gracias a todas las personas que responden en este foro porque asi es como hacemos grande a linux(ubuntu), y lo segundo queria comentaros un error que me aparece a ver si alguien puede ayudarme. Todo funcionaba a la perfeccion en mi ubuntu feist hasta que esta semana la utilidad de actualizaciones automaticas me pidio que actualizase mi kernel. Ahora cada vez que intento instalar algo con synaptic baja los paquetes necesarios y al intentar instalarlos me devuelve el siguiente mensaje de error: 

E: linux-image-2.6.20-16-generic: el subproceso post-installation script devolvió el código de salida de error 2
E: linux-image-generic: problemas de dependencias - se deja sin configurar
E: linux-restricted-modules-2.6.20-16-generic: problemas de dependencias - se deja sin configurar
E: linux-restricted-modules-generic: problemas de dependencias - se deja sin configurar
E: linux-generic: problemas de dependencias - se deja sin configurar

Os agradeceria muchisimo si alguien me pudiese ayudar.

Muchas gracias a todos! 

Imagen de ArdiIIa
+1
0
-1

Saludos a todos; mi primer mensaje...

Te ocurre igual que a mi. Añadir que la versión es esta.

Linux UBUNTU 2.6.20-15-generic #2 SMP Sun Apr 15 06:17:24 UTC 2007 x86_64

+1
0
-1
Imagen de robertopl
+1
0
-1

A mi me pasó igual los "corregí" (luego explico la comillas) editando la shell script que provocaba el fallo (ahora estoy en el curro y no puedo dar detalles porque lo hice con el odenador de casa, está relacionada con grub).

El cambio a realziar es en la primera línea. La shell script empieza por:

#!/bin/sh

Y debería ser

#!/bin/bash

Da error porque el interprete sh no entiende la sintaxis de bash.

Un vez hecho eso puedes reinstalarlo o reconfigurarlo con dpkg.

 

Dije "corregir" con comillas porque cuando lo selecciono en el arranque me falla. Aún no investigado porqué.

+1
0
-1
Imagen de tinsax
+1
0
-1

Hola me podrias explicar mejor que modificar, es que he busca por todos los sitios para modificar eso y no lo encuentro, muchas gracias a los 2 que habeis respondido.

Francisco Herrero Pérez

+1
0
-1

Francisco Herrero Pérez

Imagen de robertopl
+1
0
-1

Creo que era /usr/sbin/grub-set-default

Donde pone

#!/bin/sh

Puse

#!/bin/bash 

Con esto acabó bien las configuración, pero ya te digo, después de esto el nuevo kernel estaba instalado pero no arrancaba bien.

Para que realice la configuración prueba a instalar el paquete desde adept y mientras se está instalando dale a "mostrar detalles" y fijate en el último comando dpkg lanzado.  Lo tienes que repetir (con su "sudo" correspondiente).

Debo advertirte que soy nuevo en esto de Ubuntu (la última vez que había usado Linux en serio fue una Slackware de disquetes) así que no es que sea una gran referencia.

 

+1
0
-1
Imagen de mondozombie
+1
0
-1

A mí me ocurrió lo mismo cuando actualicé la última vez, pero lo solucioné desinstalando el "glxgrub" ( un grub con algunos arreglos gráficos q usaba en aquél momento ) y reinstalando el Grub original vía synaptic.

+1
0
-1
Imagen de ArdiIIa
+1
0
-1

Exacto... Ví que el problema estaba en el glxgrub, lo desinstalé y volví a instalar el grub normal.

Desde entonces, se acabó el problema, lo que ocurre es que al instalar el grub normal, que ha tocado el MBR y ahora la partición de windows no funciona...

Así que voy a volver a instalar el m$, y veremos si podemos luego reconstruir el grub... 

+1
0
-1
Imagen de juanman
+1
0
-1

No necesitas instalar windows de nuevo!!! Solo arranca con el cd de windows, y tienes q presionar en reparar o algo asi para arrancar desde consola y alli depende del sistema d archivo d tu particion windows. Si es FAT32 escribe fdisk /mbr y si es ntfs escribe fixboot o fixmbr bien no m acuerdo... Googlea un poco q vas a encontrar info a rolete... Pero no es necesario instalar win d nuevo!!! Despues arrancar con un live cd e instalar el grub d nuevo....

 

Saludos 

+1
0
-1
Imagen de mondozombie
+1
0
-1

Joe qué mala suerte, a ver si consigues arreglarlo sin pasar por la reinstalación del windows, q sí q se puede recuperar como te comentan jejeje

+1
0
-1
Imagen de abranha
+1
0
-1

y lo he resuelto desisntalando grub-gfxboot que era el que yo tenia, e instalando grub. Sin embargo yo no he tenido problemas con la instalacion de windows (a lo mejor es porque me hubiera gustado tener una excusa para formatear esa particion... ;-) )

Gracias a todos por la ayuda. 

+1
0
-1
Imagen de Elkan76
+1
0
-1

 Yo tengo Feisty en mi portatil y mi PC de escritorio, y en el primero me dí muchos golpes en la cabeza buscando pistas sobre el error, pero hasta ahora nada, así que prefiero dejarlos a los dos sin actualizar hasta que no salga la proxima revisión, en todo caso el error es por los modulos restringidos, ya que ellos tienen algun error al configurar y por dependencias, crean una cadena, de configuraciones hacia arriba.

Gran AMD que estás en el Server
Indescifrable sea tu password
Venga a nosotros tu actualización
Hágase tu Update en CD como en PenDrive
Danos el Boot de cada día<
+1
0
-1
Gran AMD que estás en el Server
Indescifrable sea tu password
Venga a nosotros tu actualización
Hágase tu Update en CD como en PenDrive
Danos el Boot de cada día<
Imagen de eduardog2005
+1
0
-1

En algunos casos errores en Synaptic. Yo uso aptitude y trato en la medida de lo posible de no usar apt. Aptitude permite desinstalar mas fácil que apt.

+1
0
-1
Imagen de regepete
+1
0
-1

Hola a todos.

Intento actualizar synaptic y lo único que consigo es

W: GPG error: http://ppa.launchpad.net intrepid Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 60D11217247D1CFF

No soy precisamente un experto, pero busco y busco y no tengo ni idea de porqué surge este mensaje ni porqué no puedo actualizar.

Un saludo a todos.

+1
0
-1