Problemas con el sonido de Neverwinter Nights

Imagen de Arafinwë
0 puntos

Hola, os pongo en situación, tengo neverwinter nights y las dos expansiones originales, las instalé según dice en la página oficial, puse las claves y todo genial, pero cuando inicio, el sonido se oye entre cortado a pesar de que el juego funciona fluido y sin problemas... El sonido fuera del juego funciona perfectamente en  todas las aplicaciones, pero lo más raro es que un día me dió por copiar de nuevo la carpeta music de la última expansión y ya se escuchaba bien, pero al reiniciar, !ya  no! Tengo la última versión de Ubuntu, una geoforce go 7300 y la tarjeta de sonido viene integrada en el portátil.

 Gracias por adelantado y espero que me contesten, ya que sólo me han contestado una vez de cuatro temas que he puesto...

Imagen de Arafinwë
+1
0
-1

Por favor, ¿alguien me puede dar alguna idea? y una cosa más, ¿alguien sabe crear un lanzador para neverwinter? Yo lo he probado de mil formas y nada.

 

Mil gracias

+1
0
-1

--
Fuerza y honor

Imagen de Arafinwë
+1
0
-1

Ruego que alguien me ayude, que es que no sé como solucionarlo, y tiene que ser alguna librería de música necesaria o algo, alguna pista, que hay gente con el mismo problema por la web y nadie contesta...

+1
0
-1

--
Fuerza y honor

Imagen de Bas
+1
0
-1

Sefiroth, entiendo que puedas desesperarte por no obtener respuestas a tu problema, pero si nadie te ha contestado todavía probablemente sea porque ninguno de los que hemos leido tu post sabemos la solución.

Según las normas del foro, no se permite la publicación de comentarios del tipo "¿nadie contesta?" para que tu consulta vuelva a aparecer entre las primeras. Por favor lee las normas del foro, en especial el punto 2.8.2 que es el que te comento.

Espero que des con la solución a tu problema.

Saludos.

 


 

+1
0
-1
Imagen de Arafinwë
+1
0
-1

Ok Bas, sé que está mal, pero es que seguro que tiene que haber alguien... y lo que me temo es que caiga en el olvido como otros temas que puse... yo intento contestar lo que sé...

 Saludos

+1
0
-1

--
Fuerza y honor

Imagen de Arafinwë
+1
0
-1

Acabo de instalar ubuntu de 64 bits, y ahora directamente no me va el sonido xD porque no detecta la tarjeta de sonido al parecer... cabe decir que fuera del juego el sonido va perfectamente en cualquier aplicación.

 Saludos

+1
0
-1

--
Fuerza y honor

Imagen de Arafinwë
+1
0
-1

Bueno he instalado dos librerías lib sound que no sé ni para qué son xD pero ya sale el sonido entrecortado otra vez jaja, lo malo es que ahora cada vez que salgo de nwn se cuelga ubuntu, ¿ideas?

+1
0
-1

--
Fuerza y honor

Imagen de Arafinwë
+1
0
-1

Bueno borré esas librerías, ya que no tenía base ninguna para instalarla, y el sonido sigue funcionando xD, sólo que mal claro, pero al menos ya no se cuelga al salir, y ya es que no sé que más hacer... ¿alguien dice algo?

+1
0
-1

--
Fuerza y honor

Imagen de messthetic
+1
0
-1

Tuve el mismo problema, y me costo 5 minutos encontrar la solución en los foros de bioware. (http://nwn.bioware.com/forums/viewtopic.html?topic=559606&forum=72)

Primero instalas los plugins SDL:

sudo apt-get install libsdl1.2debian-all

Luego editas el script nwn (el lanzador del juego) para que se vea algo asi:

-------------------------

#!/bin/sh
# change to the nwn directory
cd $(dirname $0)
# set enviroment variables
export SDL_MOUSE_RELATIVE=0
export SDL_VIDEO_X11_DGAMOUSE=0
export SDL_AUDIODRIVER=esd
# set library search path
export LD_LIBRARY_PATH=./miles:$LD_LIBRARY_PATH
# fire up the game
./nwmain $@

-------------------------

Con esta edición del script tampoco deberías tener problemas para crear un lanzador como se hace normalmente con cualquier aplicación.

 

Saludos.

+1
0
-1
Imagen de Arafinwë
+1
0
-1

 Ok, pero no funciona... puse el mismo script que el tuyo e instalé eso y nada, modifiqué el mío en algunas líneas y tampoco...

Gracias

-------------------------------------------------------------------------------------------------------------

Fuerza y honor

+1
0
-1

--
Fuerza y honor

Imagen de Arafinwë
+1
0
-1

 Si añado las líneas como dice en el link, al añadi:

    export SDL_AUDIODRIVER=esd

ya no hay sonido... ni entrecortado ni nada. 

-------------------------------------------------------------------------------------------------------------

Fuerza y honor

+1
0
-1

--
Fuerza y honor

Imagen de Arafinwë
+1
0
-1

He conseguido poner casi todo el script pero cuando borro el "./lib:" de la línea:

export LD_LIBRARY_PATH=./lib:./miles:$LD_LIBRARY_PATH

que se supone que se tiene que eliminar si utilizas las librerías sdl, no se ejecuta y cuando lo pongo sí... pero no va el sonido, ¿qué hago?

 

Mil gracias

-------------------------------------------------------------------------------------------------------------

Fuerza y honor

+1
0
-1

--
Fuerza y honor

Imagen de hardlock
+1
0
-1

prueba cambiando esd por alsa
export SDL_AUDIODRIVER=alsa
y remove ./lib

asi

#export LD_LIBRARY_PATH=./lib:./miles:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH=./miles:$LD_LIBRARY_PATH
 

saludos 

otro dia inventare una firma aceptable :)

+1
0
-1

otro dia inventare una firma aceptable :)

Imagen de Arafinwë
+1
0
-1

 Te lo agradezo mucho, pero eso ya lo intenté, y con oss, pero al parecer gnome utiliza esd, y yo utilizo gnome xD, en el momento que quito ./lib: no va, y si va, ya ni tiene sonido...

Saludos 

--

Fuerza y honor

+1
0
-1

--
Fuerza y honor

Imagen de Arafinwë
+1
0
-1

 Bueno señores eso queda sin resolver, pero ahora tengo un dato más, he instalado el supertux, y ¿sabeis que pasa? tachán, el sonido está entrecortado, yo creo que me falta algún tipo de librería que utilicen los juegos, y que me falte en nwn también, por eso no inicia cuando borro esas dos líneas... ¿alguien lo sabe?

Saludos amigos 

--

Fuerza y honor

+1
0
-1

--
Fuerza y honor

Imagen de CyberMoon
+1
0
-1

Gnome utiliza el que le indiques que utilize. Si el juego viene con Alsa, en gnome pon alsa tambien porque si no tendrás problemas con el sonido. Consejo aparte.. usa alsa xD que esd da problemas en muchas ocaciones.

Para cambiar la salida de gnome a Alsa sencillamente navega en el menú Sistema -> Preferencias y busca la opción "Selección de Sistemas Multimedias" y ahí cambias esd por Alsa. 

---------------------------
Recopilación de Tips sobre Ubuntu: http://ubuntu.elorbe.net

Think different, think Linux.
NO SEAS UN PRINGAO, No al soporte gratuito de productos de Microsoft!

+1
0
-1

---------------------------
Recopilación de Tips sobre Ubuntu: http://ubuntu.elorbe.net

Think different, think Linux.
NO SEAS UN PRINGAO, No al soporte gratuito de productos de Microsoft!

Imagen de Arafinwë
+1
0
-1

 Pues gracias, pero tenia puesto alsa xD, pero lo más desconcertante es que le doy a probar y no se oye nada xD, pero la música si la puedo escuchar... ¿qué está pasando?

Mil gracias 

--

Fuerza y honor

+1
0
-1

--
Fuerza y honor