Imagen de takitaki
0 puntos

intentando actualizar opera el famoso i util navegador
me da este error
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
si desde el terminal lo intento me dice que solo puede el superusuario como lo arreglo???

saludos a todos de un novato en estos mundos

taki

Imagen de MarianoC
+1
0
-1

Lo arreglas con:

$ sudo dpkg --configure -a

Saludos!!

+1
0
-1
Imagen de letex
+1
0
-1

 Ejecuta:

sudo dpkg --configure -a 

   Si instalaste un paquete, desinstálalo, con dpkg o con synaptic (opcion buscar) y para actualizar el navegador usa synaptic, suele ser ma? seguro!!

    Un saludo,espero que te sirva

Ubuntu user number # 12793

Linux user number # 444511

+1
0
-1
Imagen de Goyo
+1
0
-1

Para hacerte pasar por el superusuario tienes que usar sudo:

$ sudo dpkg --configure -a

Cuando te pida la contraseña pon la misma que utilizas para iniciar sesión y pulsa enter. No te preocupes aunque al escribir la contraseña no se vea nada en la pantalla. 

+1
0
-1
Imagen de gadi
+1
0
-1

Eso que te dice de superusuario quiere decir que solo root puede acerlo. Entonces, basta con poner "sudo" delante de la orden.

Es decir, en cosola pon "sudo dpkg --configure -a". Entonces seguramente sí te dejará y podras actualizar Opera.

Ese problema es debido a que el PC se te reinició o Synaptic o algún otro programa de instalación se te interrumpió mientras instalabas algo. 

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Bueno, creo que ha quedado cristalino como el agua que has de usar el comado SUDO, ¿verdad? ;)

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."
¿Por dónde empiezo? - Guía Ubuntu
¿Un aliado? - Automatix

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."