Problema desinstalando paquete y error en Synaptic

Imagen de Marcianisto
0 puntos

Me explico bien,....

Estaba instalando un paquete xmpm-java y despues me di cuenta que no funciona ninguna instalacion, el synaptic me lanza un error cada vez que quiero meterme a el, diciendo que reinstale el archivo.

cuando intento reinstalar el archivo, el GDebi me dice que esta dañado... y no puedo hacer nada.

 

Necesito porlomenos desistalar el paquete, AYUDA POR FAVOR!!

Imagen de zetatron
+1
0
-1

Intenta introducir este comando en consola:

sudo apt-get install -f 

y cuéntanos si has conseguido algo. Saludos ;)


Tener información es el primer paso a la sabiduría. Compartirla es el primero para formar comunidad.

+1
0
-1

Comentario patrocinado por Merchandlinux.com.
Hoycriticamos.com, porque siempre hay algo que criticar.

Imagen de slavebender
+1
0
-1

pudes intentar deisntalar el paquete que te esta dando problema

sudo apt-get autoremove (nombre del paquete a desintalar)

espero sea de ayuda  

+1
0
-1

descubriendo las ventajas del software libre

Imagen de Marcianisto
+1
0
-1

No... me lanza muchos errores, inicié el recovery mode, e igual.

Aviso que el gestor de actualizaciones 2 días antes me había actualizado el kernel.

El error es este:

"E: el paquete xmpm-java necesita ser reinstalado, pero no se encuentra un archivo para éste."

Creo que debe ser porque los archivos no los descargué de ningún repositorio que esté en sources.list ...

 

(Por lo del título... Está OK lo que hicieron.) 

+1
0
-1
Imagen de Marcianisto
+1
0
-1

Aquí está el error detallado desde consola:

(con apt-get install -f)

marcianisto@marcianisto-laptop:~$ sudo apt-get install -f
Password:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo información de estado... Hecho
E: El paquete xmpm-java necesita ser reinstalado, pero no se encuentra un archivo para éste.
marcianisto@marcianisto-laptop:~$

(con apt-get autoremove xmpm-java)

marcianisto@marcianisto-laptop:~$ sudo apt-get autoremove xmpm-java
Password:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo información de estado... Hecho
E: El paquete xmpm-java necesita ser reinstalado, pero no se encuentra un archivo para éste.
marcianisto@marcianisto-laptop:~$

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

 

¿Y de dónde sacaste ese paquete? En Internet solo he visto UNA referencia. :(

Puedes darnos más info de este paquete? 

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."
¿Por dónde empiezo? - Guía Ubuntu
¿Un aliado? - Automatix

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de Marcianisto
+1
0
-1

BenQ·Siemens daba esos paquetillos, eso si, lo tenía guardados de antes en mi antiguo Ubuntu 6.06.

+1
0
-1
Imagen de Javier M.
+1
0
-1

Hola marcianisto.

Permiteme que siguiendo las normas del foro te cambie el titulo por uno un poco mas descriptivo. Es mucho mejor para todos, ya que mantiene el foro un poco más ordenado y mucho mejor para ti porque con un titulo descriptivo es probable que mucha mas gente se interese por tu consulta.

Un saludo.


 

+1
0
-1
Imagen de curroX
+1
0
-1

En consola:

sudo dpkg --remove --force-remove-reinstreq xmpm-java

 

Saludos 

+1
0
-1
Imagen de Marcianisto
+1
0
-1

dpkg - aviso, no se tendrá en cuenta el problema por estar activa
 una opción --force:
 El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
 antes de intentar desinstalarlo.
(Leyendo la base de datos ...  
123372 ficheros y directorios instalados actualmente.)
Desinstalando xmpm-java ...
/var/lib/dpkg/info/xmpm-java.postrm: 20: Syntax error: "(" unexpected
dpkg: error al procesar xmpm-java (--remove):
 el subproceso post-removal script devolvió el código de salida de error 2
Se encontraron errores al procesar:
 xmpm-java

+1
0
-1
Imagen de Nacho
+1
0
-1

Veamos: primero haz lo siguiente y ¡todo con poderes de root claro está!:

sudo dpkg --pending --configure (termina de configurar paquetes que queden pendientes, posiblemente te de algún error, pero no está de más).

Luego:

sudo aptitude update

sudo aptitude purge xmpm-java

 ¿Por qué aptitude? Porque gestiona mejor las dependencias y los errores y te sugerirá soluciones (que no tienen porque ser buenas del todo pero seguramente funcionen) ante tu problema. 

Prueba con esto y luego cuenta si ha servido o no y que te dice la consola. 

Chaito. 

+1
0
-1
Imagen de Marcianisto
+1
0
-1

Los siguientes paquetes han sido retenidos automáticamente:
  linux-libc-dev
Se ELIMINARÁN automáticamente los siguientes paquetes:
  xmpm-java{p}
Se han retenido los siguientes paquetes:
  linux-headers-2.6.20-16 linux-headers-2.6.20-16-generic
  linux-image-2.6.20-16-generic
Se ELIMINARÁN los siguientes paquetes:
  xmpm-java{p}
0 paquetes actualizados, 0 nuevos instalados, 143 para eliminar y 4 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 420MB.
¿Quiere continuar? [Y/n/?] y
Escribiendo información de estado extendido... Hecho
dpkg: error al procesar xmpm-java (--purge):
 El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
 antes de intentar desinstalarlo.
Se encontraron errores al procesar:
 xmpm-java
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:

+1
0
-1
Imagen de Marcianisto
+1
0
-1

Me huele que si no hago nada voy a tener que formatear e reinstalar el sistema... y tanto que lloré para que me funcionara el beryl y el kiba-dock sin problemas

+1
0
-1
Imagen de Marcianisto
+1
0
-1

Tonteando y revisando el Synaptic, pensé en hacer un repositorio propio, en Google busqué y me apareció una web para pasar nuestros paquetes a CD, y que synaptic descubra el archivo.

Lo primero que hacemos es crear una carpeta en nuestro home, que se llame mis_paquetes

nos vamos a una consola y escribimos (<usuario> es tu nombre de usuario):

# cp -R /var/cache/apt/archives /home/<usuario>/mis_paquetes

OJO: ANTES DE LO QUE HAREMOS DESPUÉS, COPIA EL ARCHIVO QUE TE DA PROBLEMAS (EN MI CASO xmpm-java_2006.deb) A LA CARPETA ./mis_paquetes/archives.

volviendo a la consola,  escribe esto:

# cd mis_paquetes

# dpkg-scanpackages . /dev/null | gzip > Packages.gz  

Después nos salimos de la consola, y copiamos el contenido de nuestra carpeta a un CD.

Después nos vamos a "Añadir y Quitar" y después a preferencias, ahi le decimos que nos agregue el CD que tenemos metido.

Despue? nos vamos al Synaptics y revisamos que todo esté bien y podamos agregar paquetes.

En mi caso, no puedo ni quitar ni reinstalar el paquete xmpm-java, pero puedo seguir usando Synaptic ahora.

Gracias por todos los aportes. 

+1
0
-1
Imagen de jmbargar
+1
0
-1

Por lo que describes tu paquete parece estar marcado como reinst-req. Para desinstalarlo sólo tienes que hacer un:

sudo dpkg -r --force-remove-reinstreq nombre_de_la_aplicación

en tu caso algo como: 

sudo dpkg -r --force-remove-reinstreq xmpm-java

Un saludo 

J. Manuel Barrios - http://jmbargar.freehostia.com/

+1
0
-1

J. Manuel Barrios - http://jmbargar.freehostia.com/

Imagen de Marcianisto
+1
0
-1

aquí está, recién hechito desde la consola:

 una opción --force:
 El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
 antes de intentar desinstalarlo.
(Leyendo la base de datos ... 
139601 ficheros y directorios instalados actualmente.)
Desinstalando xmpm-java ...
/var/lib/dpkg/info/xmpm-java.postrm: 20: Syntax error: "(" unexpected
dpkg: error al procesar xmpm-java (--remove):
 el subproceso post-removal script devolvió el código de salida de error 2
Se encontraron errores al procesar:
 xmpm-java
 

+1
0
-1
Imagen de jmbargar
+1
0
-1

Pues está chunga la cosa tio, al menos como lo veo yo. Si tuvieras el repositorio del paquete en el /etc/sources.list o el .deb correspondiente en /var/cache/apt/archives podrías probar a hacer lo que te dice el mensajito, es decir, algo como:

sudo apt-get install --reinstall xmpm-java

y después intentar eliminarlo con:

sudo apt-get remove --purge xmpm-java

sino no sé.

Un saludo 

J. Manuel Barrios - http://jmbargar.freehostia.com/

+1
0
-1

J. Manuel Barrios - http://jmbargar.freehostia.com/

Imagen de Marcianisto
+1
0
-1

si poh, ta chunga la lesera, y eso k soy chileno pue!

PD: Tan chunga, que todavía no se soluciona... 

+1
0
-1
Imagen de cdp
+1
0
-1

Yo tube exactamente el mismo problema, aunque con otro paquete.

Lo solucione con sudo dpkg -r --force-remove-reinstreq <aplicacion>


necesitas ayuda? dudas? insultos?

mail, jabber, msn, gtalk: checho289@gmail.com

+1
0
-1

necesitas ayuda? dudas? insultos?

mail, jabber, msn, gtalk: checho289@gmail.com

Imagen de Marcianisto
+1
0
-1

marcianisto@marcianisto-laptop:~$ sudo dpkg -r --force-remove-reinstreq xmpm-java
Password:
dpkg - aviso, no se tendrá en cuenta el problema por estar activa
 una opción --force:
 El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
 antes de intentar desinstalarlo.
(Leyendo la base de datos ...  
196035 ficheros y directorios instalados actualmente.)
Desinstalando xmpm-java ...
/var/lib/dpkg/info/xmpm-java.postrm: 20: Syntax error: "(" unexpected
dpkg: error al procesar xmpm-java (--remove):
 el subproceso post-removal script devolvió el código de salida de error 2
Se encontraron errores al procesar:
 xmpm-java
marcianisto@marcianisto-laptop:~$

+1
0
-1