Adiós al xorg.conf si reinicio (GForce 8400)

Imagen de chencho
0 puntos

He comprado un portatil LG (E500) y estoy teniendo más problemas de los debidos con él.

 Para empezar he tenido que instalar ubuntu desde el USB (el cd lo pierde al intentar montarlo), hay que instalarlo en modo VESA (sin ver los botones de adelante, atrás, bendito tabulador), sin tener WIFI y lo que peor llevo, con gráfcos tercermundistas.

 El caso es que instalo el último driver para LINUX de nvidia (bajado de nvidia.com) el cual promete compatibilidad con las nuevas tarjetas, incluida la que tengo, la 8400.

 Todo funciona como toca al instalarlo, y si nada más instalarlo inicio el gdm  las ventanas ya no van a tirones y tengo una buena resolución.

 

El problema es que cuando reinicio el xorg se me va de paseo, y me explica muy amablemente que el kernel y el módulo no coinciden (las versiones), cuando la instalación la hago con el famoso 'uname -r' (vamos, que no me he equivocado de numeración).

 ¿Alguien tiene una idea de como solucionar este "pequeño" problemita?

Imagen de chencho
+1
0
-1

Después de mil y una vuelta parece que lo he solucionado.

 Para todo aquel que ande como yo, esto es lo que he hecho:

 sudo dpkg-query -l | grep nvidia

sudo aptitude remove TODO LO QUE TENGAMOS RELACIONADO CON NVIDIA

Después reinstalar el driver y a correr :) 

+1
0
-1

Si siempre haces lo que has hecho nunca llegarás más lejos de lo que has llegado

Imagen de Gaudeamus
+1
0
-1

Yo aún sigo pegándome con mi 8500, pero te indico (para tu solaz conocimiento) que hay una forma más corta:

 

sudo apt-get --purge remove nvidia* 

Y también funciona :)

+1
0
-1