Ubuntu versus nVidia GeForce4 440 Go 64M

Imagen de axilipu
0 puntos

hola a todos

llevo como cosa de una semana intentando activar la aceleracion 3D de mi tarjeta grafica y lo unico q consigo es consola o una linda pantalla negra.

he probado ya algunos consejos q me han dado, pero al parecer nadie tropezo con un modelo de tarjeta como la mia.

si alguien a conseguido activar la aceleracion con mi mismo modelo o tiene alguna idea de lo q me puede pasar le agradeceria su ayuda.

lo unico q he podido conseguir fue aceleracion 3D, pero me salia un modelo de tarjeta inferior a la mia y los bordes y barra de titulo se los comia...ah, y algunos efectos de beryl tampoco me los hacia (gotas de agua, por ejemplo)

Imagen de ponisho
+1
0
-1

Yo tengo mi tarjeta NVIDIA igual que la tuya y tengo casi todo lo que beryl puede dar, excepto la lluvia, que aun no he dado como hacerle para hacer que funcione, pero si tengo nieve que es lo mas gracioso del asunto.

te pongo mi xorg para que veas como lo tengo

 Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28.0 - 64.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation NV [GeForce4 MX 440 AGP 8x]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV [GeForce4 MX 440 AGP 8x]"
Monitor "Generic Monitor"
DefaultDepth 24
Option "AddARGBGLXVisuals" "true"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

y en cuanto al beryl las opciones avanzadas las tengo así:

Rendering Path: automatic

Composite Overlay Window: use cow

Rendering Platform: force aiglx (aqui probé "force xgl" y nomás no jaló ni el xserver asi que no te recomiendo que lo pruebes)

Binding: xgl binding

Rendering: xgl rendering

Esto me ha funcionado hasta el momento, aunque haciendo una buena combinación de estos elementos he logrado un buen performance del video "200fps" que no considero malos.

 

Para activar las funciones de la tarjeta en consola puse:

sudo nvidia-xconfig enable 

Puede ser que te marque error y que te indique que tienes que cambiar el "nv" por "nvidia" o visceversa, pero yo lo ignoré y cuando reinicié el X me salió una megapantallota con el logo de nvidia.

Espero que te sirva mi info que a mi me costó sin encontrar a nadie como te pasó a tí.

+1
0
-1

Ponisho

Imagen de axilipu
+1
0
-1

tienes un sobremesa o un portatil?

he estado mirando tu archivo y creo q tu tarjeta es de un pc de sobremesa, y las resoluciones y tal creo q no van a ir con mi pantalla de resolucion max 1024x768 y 60fps (creo) como max...no me acuerdo muy bien.

dime si sabes q cambios puedo hacer.

ah, gracias por tu ayuda tio. 

+1
0
-1
Imagen de ponisho
+1
0
-1

Mi PC es de Escritorio y por lo de las resoluciones quitando las resoluciones que no acepte tu monitor debe funcionar.

Si tu resolución maxima es de 1024x768 solo quita las de 1280x1024, si tu monitor es widescreen p.e. 1280x800 solo agrega esa resolución al principio para que sea la predeterminada.

Es cierto lo de que en 3D no es muy bueno el rendimiento, los fps caen por los suelos cuando giras el escritorio pero nada mas es en eso de ahi en fuera lo demás funciona descentemente. 

+1
0
-1

Ponisho

Imagen de axilipu
+1
0
-1

asi quedo mi archivo despues hacer lo q m dijistes, solo añadi la ultima seccion, lo demas pense q seria mejor dejarlo como estaba. y volvi a lo de siempre... pantalla azul y un mensaje diciendo q nanai de la xina, q con la linea de comandos iba a triunfar jejeje

por cierto, cuando puse 'sudo nvidia-xconfig enable' me dijo q el comando no era valido...

seguro q algo hice mal (pa variar. a ver si o alguien mas le echa un vistacito a mi xorg a ver donde la pifié.

gracias de todas formas tio, de veras. 

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Nov  9 17:55:20 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
    InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"

    # path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "es"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"        # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "Monitor genérico"
    HorizSync       28.0 - 51.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "nVidia Corporation NV17 [GeForce4 420 Go 32M]"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV17 [GeForce4 420 Go 32M]"
    Monitor        "Monitor genérico"
    DefaultDepth    16
    SubSection     "Display"
        Depth       1
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1024x768"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

+1
0
-1
Imagen de ponisho
+1
0
-1

Como te sale la pantalla azul de que no puede iniciar el xserver y que si deseas ver el log, lo que puedes ver es lo siguiente:

Inicia sesión con el usuario que desees, al fin y al cabo vas a acabar trabajando como root 

Trata de iniciar X (startx), luego en el momento que no inicie y te vuelva a botar a terminal, ve cual es el error, lo mas seguro es que te marque que el driver "nvidia" no se encontró, por lo que habrá que editar el xorg y cambiar en la seccion "device" el driver de "nvidia" a "nv".

Supongo que eso deberá solucionar tu problema, prueba iniciando otra vez el X si funciona, reinicia y ya debería funcionar... pregunta ¿que kernel tienes?

+1
0
-1

Ponisho

Imagen de axilipu
+1
0
-1

2.6.20-16-generic

esa es la version q tengo...creo jejeje

ahora mismo voy a probar a cambiar lo q me has dicho a ver si me da otro error... y a apuntar el error en el caso de q me lo de jejeje

gracias tio, de veras!

EDITADO

 

asi es como a quedado mi xorg despues de poner los ultimos drivers q tenia de nvidia...ahora dice q mi hardware no necesita controladores restringidos...y al instalar no me dijo q tenia q reiniciar ni nada...esto es mas raro cada vez jejeje

 

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
    FontPath    "/usr/share/fonts/X11/misc"
    FontPath    "/usr/share/fonts/X11/cyrillic"
    FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/Type1"
    FontPath    "/usr/share/fonts/X11/100dpi"
    FontPath    "/usr/share/fonts/X11/75dpi"
    # path to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load    "i2c"
    Load    "bitmap"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "es"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "ZAxisMapping"        "4 5"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "auto-dev"
    Option        "HorizScrollDelta"    "0"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "stylus"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "eraser"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "cursor"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "Device"
    Identifier    "nVidia Corporation NV17 [GeForce4 420 Go 32M]"
    Driver        "nv"
    BusID        "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier    "Monitor genérico"
    Option        "DPMS"
    HorizSync    28-51
    VertRefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "nVidia Corporation NV17 [GeForce4 420 Go 32M]"
    Monitor        "Monitor genérico"
    DefaultDepth    16
    SubSection "Display"
        Depth        1
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice     "stylus"    "SendCoreEvents"
    InputDevice     "cursor"    "SendCoreEvents"
    InputDevice     "eraser"    "SendCoreEvents"
    InputDevice    "Synaptics Touchpad"
EndSection

Section "DRI"
    Mode    0666
EndSection

 

+1
0
-1
Imagen de carloscv-207
+1
0
-1

Los drivers de la tarjeta Nvidia a mi me funciona instalarlos por terminal y comandos:

$ sudo aptitude install nvidia-glx nvidia-kernel-common
$ sudo nvidia-xconfi

Luego se reinicia.

Debe considerarse que es una tarjeta de 64 Mb y que es probable que no pueda dar una buena aceleración gráfica. Hace tiempos leí sobre una evaluación de tarjetas y aún con una Nvidia de 128 Mb el rendimiento de la aceleración no es bueno. Yo utilizo la Nvidia Geforce fx 5200 de 128 Mb y para los escritorios en 3d no es muy buena, por eso no los utilizo.

En cuanto a la tarjeta mencionada aquí hay una lista de compatibles de Nvidia.

+1
0
-1
Imagen de axilipu
+1
0
-1

supongo q dependera de otras cosas...

la unica vez q me funciono la informacion q me daba de mi tarjeta era q se trataba de una nVidia GeForce4 420 Go 32Mb, o sea, un modelo anterior a la mia y con la mitad de memoria, y el escritorio en 3D me lo movia muy bien, y casi todas las cositas q hace el beryl. mi pantalla del portatil solo tiene 1024x768 y la profundidad de color me la habia dejado en 16 (creo)... asi q calculo q si pudiera aprovechar mis 64Mb y mi 440 a pleno rendimiento con 1024x768 y 60fps me ira bastante bien en el portatil ¿no? igual me equivoco, pero no quisiera jejeje aunq tambien tengo q reconocer q acabo de empezar con esto y es muy probable q me equivoque en algo.

 

+1
0
-1
Imagen de dilak
+1
0
-1

No se como hallas instalado tu tarjeta pero definitivamente eso de que para los escritorios 3d no funciona... chale!

 Yo tengo una tarjeta igual que la que aqui se menciona... e instale Kubuntu... luego instale el Ubuntu-Desktop o Gnome, vaya... y se cargo el Entorno Grafico por los drivers nVidia... tuve que formatear por que no supe como mas hacerle...

 Resintale... pero ahora Ubuntu... y mi cubo 3D funciona... y excelente... se que si tuviera una mejor tarjeta... funcionaria mejor... pero el 3D funciona de tal manera que si me sorprendio, por que sinceramente no crei que el cubo o el resto de los efectos llegasen a funcionar en mi maquina... aunq asi... funciono... y estoy emocionado hasta la fecha... 

 Saludos...

+1
0
-1

Si avanzo... Sigueme
Si me detengo... Empujame; pero...
Si me quedo... Olvidame

Imagen de ferrangar
+1
0
-1

cayo en mis manos un portatil, que al instalar el driver de nvidia, zas pantalla negra tambien, modelo de la targeta nvidia 4 420 go, toma, no soy el unico... (monitor negro de apagado!)

 Habeis intentado ver que pasa si le conectais un monitor externo??? jejeje

 Bien,  Ahora supongo q habra que ver como activar el dual view o alguien que sepa nos explique, pq lo hice con gentoo mas a manivela que otra cosa, seguro que con ff es mas facilito.

+1
0
-1
Imagen de Hach Winik
+1
0
-1

Section "Device"
Identifier "nVidia Corporation NV17 [GeForce4 440 Go]"
Driver "nvidia"
Busid "PCI:1:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "UseDisplayDevice" "DFP-0"
Option "CustomEDID" "DFP-0:/etc/X11/nvnew.raw"
Option "NoLogo" "True"
EndSection

 

y reinicia las X's 

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos 

Imagen de Bend3r
+1
0
-1

Yo conseguí activar la aceleración 3d con la Geforce 440 MMX Go (la de portátiles) en Gutsy.

Lo conseguí instalando los drivers que te pondré al final de este post. Siguiendo estos pasos:

Pulsar Ctrl + Alt + F1. (Irás a la terminal). 

Sudo /etc/init.d/gdm stop. (Pararás la sesión de gnome)

Sudo sh (ruta a los drivers)/NVIDIA-Linux-x86-1.0-9631-pkg1.run (Entrarás en un instalador basado en consola)

Sudo /etc/init.d/gdm start (Vuelta a gnome)

*Si usas kubuntu pon kdm stop/start en vez de gdm stop/start

El problema es que con hardy me da un error de que no encuentra un kernel compatible en NVidia. Me acuerdo de que con gutsy tuve que pelearme bastante. Ya tengo mi versión del núcleo compilada, pero pienso que a lo mejor pide el núcleo de los drivers de la gráfica, no lo sé.

Después de eso, sólo tuve que activar los drivers en el gestor de controladores restringidos. Seguiré peleándome con hardy hasta que consiga la aceleración 3d y te informaré si lo consigo. Lo siguiente que probaré serán los últimos drivers de nvidia que acabo de descargar de http://www.nvidia.es/content/license/driver_license.aspx?language=es&url...

Son los que ponen para geforce 4  MX series para linux 32-bits.

Los antiguos (que me funcionaron en gutsy) los he subido a rapidshare http://rapidshare.com/files/112003041/NVIDIA-Linux-x86-1.0-9631-pkg1.run puedes probar a ver.

Ya te contaré.

+1
0
-1
Imagen de Bend3r
+1
0
-1

El driver que funciona es el 96.43.05 que podéis descargar en http://www.nvidia.com/object/linux_display_x86_96.43.05.html y es el puñetero driver que te instala el gestor de controladores restringidos en modo gráfico. Y si es ése, ¿por qué coño se ve mi pantalla negra? Muy sencillo (dolorosamente sencillo para los que hemos dedicado horas a activar la aceleración 3d) falta una línea en el /etc/X11/xorg.conf, una vez instalados los controladores en modo grafico (antes de reiniciar) hacemos sudo gedit /etc/X11/xorg.conf en la terminal y buscamos la sección "device" y añadimos la siguiente línea:

Option "UseDisplayDevice" "DFP"

Reiniciamos y listo. Si pasáis del modo gráfico pues os descargáis los drivers de la dirección que os he puesto y hacéis lo que dije en mi anterior post:

Pulsar Ctrl + Alt + F1. (Irás a la terminal). 

Sudo /etc/init.d/gdm stop. (Pararás la sesión de gnome)

Sudo sh (ruta a los drivers)/NVIDIA-Linux-x86-96.43.05-pkg1.run (Entrarás en un instalador basado en consola)

Sudo /etc/init.d/gdm start (Vuelta a gnome)

*Si usas kubuntu pon kdm stop/start en vez de gdm stop/start

Pero ya os digo que es el mismo driver que se instala en modo gráfico. El único problema es la puñetera línea esa. Tan simple como eso y adiós a la pantalla negra. De todos modos os posteo mi xorg.conf.

 

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard" "CoreKeyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "es"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Device"
    Identifier     "nVidia Corporation NV [GeForce4 MX 440 AGP 8x]"
    Driver         "nvidia"
    Option         "UseDisplayDevice" "DFP"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV [GeForce4 MX 440 AGP 8x]"
    Monitor        "Configured Monitor"
    Option         "AddARGBGLXVisuals" "true"
    Option         "RenderAccel" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

 

Espero que os haya servido de ayuda. Saludos.

+1
0
-1
Imagen de tukushumi
+1
0
-1

Hola. Bueno, gracias a la explicación de Bend3r he podido solucionar el tema de la aceleración 3d. Lo único es que el metodo de instalación de los drivers no me funcionó, me daba un error, así que lo instalé desde Sistema>Administración>Gestión de controladores restringidos, y una vez esto, antes de reiniciar, edité el Xorg.conf como decías.
Pero tengo varias dudas. Primero, que lo tengo instalado en Ubuntu 7.10. ¿Esto mismo funcionaría con versiones más recientes?. Segundo. Lo de haberlo hecho desde Sistema>Administración>Gestión de controladores restringidos y que haya funcionado no se si es pura chiripa o no. ¿Se podría haber dado el caso de que se hubiera instalado otra versión del controlador y no haber funcionado?
Gracias.

+1
0
-1
Imagen de hugolino
+1
0
-1

En la 8.04 seguro te anda. En la 8.10 no creo a menos que ya hayan arreglado las cosas, porque yo tengo otra placa así viejita (no es la tuya, pero también entra en la categoría legacy) y no pude hacer andar las cosas con el kernel de la versión 8.10.

No lo usé mucho eso de controladores restringidos, pero las veces que lo intenté con placas nvidia funcionó bien, si el driver va a andar te dice "recomendado" y si no es seguro te dejan hacerlo si querés. Tampoco tiene muchos drivers para elegir como para equivocarse :P.

Con una ati me instaló los drivers correctos, pero la placa esa justo andaba con problemas con los drivers oficiales restringidos.

+1
0
-1