realtime-preempt

Necesito ayuda para instalar el parche realtime-preempt en el kernel 2.6.12 de ubuntu.

He encontrado el parche en http://people.redhat.com/mingo/realtime-preempt/ pero tras aplicarlo y encontrar varios errores al hacerlo, evidentemente, no compila. ¿Hay alguna versión del parche para Ubuntu? ¿Se puede aplicar *ese* parche?