No puedo instalar g++; lío de dependencias

Imagen de Valentín
0 puntos

Pues eso, que quiero instalar g++ y no hay manera. Utilizo Ubuntu GNU/Linux 7.04

 

Os pongo los pasos que sigo a ver si me podéis ayudar:

apt-get install g++

Los siguientes paquetes tienen dependencias incumplidas:
g++: Depende: g++-4.1 (>= 4.1.2) pero no va a instalarse
E: Paquetes rotos

apt-get install g++-4.1

Los siguientes paquetes tienen dependencias incumplidas:
g++-4.1: Depende: libstdc++6-4.1-dev (= 4.1.2-0ubuntu4) pero no va a instalarse
E: Paquetes rotos

apt-get install libstdc++6-4.1-dev

Los siguientes paquetes tienen dependencias incumplidas:
libstdc++6-4.1-dev: Depende: libc6-dev (>= 2.3.6-7) pero no va a instalarse
E: Paquetes rotos

apt-get install libc6-dev

Los siguientes paquetes tienen dependencias incumplidas:
libc6-dev: Depende: libc6 (= 2.5-0ubuntu14) pero 2.5-8ubuntu1 va a ser instalado
E: Paquetes rotos

 apt-get install libc6

libc6 ya está en su versión más reciente.

Hasta ahí llego y ya no se qué puedo hacer...

Este es el contenido de mi sources.list:

deb http://es.archive.ubuntu.com/ubuntu/ feisty main restricted universe multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ feisty main restricted universe multiverse

## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ feisty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu feisty-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu feisty-security main restricted universe multiverse

 

He probado con aptitude y me ofrece la siguiente solución:

No se satisfacen las dependencias de los siguientes paquetes:
libc6-dev: Depende: libc6 (= 2.5-0ubuntu14) pero está instalado 2.5-8ubuntu1.
Resolving dependencies...
Las acciones siguientes resolverán estas dependencias

Desactualizar los paquetes siguientes:
libc6 [2.5-8ubuntu1 (now) -> 2.5-0ubuntu14 (feisty)]

La puntuación es -40

Era lo que iba a hacer... pero me han dicho que libc6 es un paquete muy importante del sistema y que no conviene desactualizarlo...

¿Qué me sugerís?

 

 

 

 

 

Imagen de wodano
+1
0
-1

Actualiza, es cierto que libc es importantisima y que hace, ofre la interfax minima de comunicación entre l kernel y todo lo que lo rodea, pero como te vas quedar en la misma version (2.5), y lo unico que va a cambiar es la version de compilacion no tendría que haber ningun problema.

+1
0
-1
Imagen de Valentín
+1
0
-1

Bueno, pues ya lo hice y no ha explotado nada... xDDDD

 Problema resuelto, ya tengo gcc y g++

 Gracias

+1
0
-1