Problema con mysql

Imagen de r1chd
0 puntos

hola soy nuevo en Linux tengo el siguiente problema y no puedo resolverlo :(

instale mysql-server y mysql-client  estaba todo muy bien asta un
apagon en el cual ya no pudo correr  me marcaba un error  que no podia
encontrar un mysql.socket  y trate de corregirlo con info del foro de
ubuntu pero no resulto despues de algunas horas sin resultados decidi
desinstalarlo y volverlo a instalar  y entonces me aparecio esto.

dpkg: syntax error: unknown group `postdrop' in statoverride file
E: Sub-process /usr/bin/dpkg returned an error code (2)

ahora no puedo instalarlo y no se que mas hacer
agradesco su ayuda

Imagen de zirconio
+1
0
-1

Hola r1chd,

              pufff..    pues va ser dificil recordar este nick.

A ver, por la información que das, tal vez lo que ocurre es que cuando desinstalate la aplicación, algunos enlaces quedaron rotos, seguramente sobre algunas librerías que aun estan en el sistema, pero los enlaces que apuntan a los ficheros de la aplicación no concuerdan con la marca sobre el fichero apuntado.

Es decir, tienes que desinstalarlo completamente .

Para saber si tienes paquetes rotos, mira en Synaptic y repáralos o quitalos completamente.

Otra opción es desde la consola:

sudo apt-get remove --auto-remove package-NOMBRE DEL PROGRAMA

No estará demás, que antes de hacer nada, leas la información sobre apt-get en man, es decir: man apt-get

Un saludo

Z. 

Linux User Reg. #441216

Machine Reg #348016

+1
0
-1

Linux User Reg. #441216

Machine Reg     #348016

Imagen de r1chd
+1
0
-1

lo hice asi
sudo apt-get remove --auto-remove package-mysql-server

y me respondio lo siguinete
E: El sentido de auto no se entiende, pruebe verdadero o falso.

y no paso nada  :( 

+1
0
-1
Imagen de gotxa
+1
0
-1

Hola,
si no te pita lo que te dice zirconio, es que la cosa es un poco más seria. Prueba su solución primero y si no llegas a ninguna solución te metes en otras camisas:

Leo en
http://ubuntuforums.org/archive/index.php/t-82484.html
que el error es achacable a synaptic y ahí intentan reinstalar synaptic con ese error y para arreglar el error lee al final del hilo.

Mucha suerte... tira de la manta buscando los errores que te de en tu buscador favorito (¿gusgles o algo así? :-))
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de r1chd
+1
0
-1

hola GoTxa
gracias por las sugerencias probe todo lo que  viene  en el link y nada resulto marca los errores de postdrop y postfix

peor eso no se que es :(

+1
0
-1
Imagen de gotxa
+1
0
-1

A ver...
vamos a borrar todos los paquetes que tiene tu sistema en la caché.
$ sudo apt-get clean

Ahora recargamos info de repositorios y actualizamos
$ sudo apt-get update
$ sudo apt-get upgrade

Por este orden, si hay errores los posteas (no es necesario que postees lo que te diga OK, lo comento porque el listado del update será largo). Si no hay errores, seguimos.

Hay que saber si a tu synaptic/apt-get le pasa algo o es sólo a un paquete

GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de r1chd
+1
0
-1

Hola GoTXa
no puedo mira hice lo que posteaste en ese  orden muy especifico  como dice  tu post
y al final salio esto:

Descargados 222MB en 17m53s (207kB/s)
Imposible obtener http://mx.archive.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base0.10/gst...  Error leyendo del servidor - read (104 Conexión reiniciada por el par) [IP: 91.189.89.8 80]
E: No se pudieron obtener algunos archivos, ¿quizás deba ejecutar
apt-get update o deba intentarlo de nuevo con --fix-missing?
 
no tengo la menor idea de lo que sea  :( 

+1
0
-1
Imagen de gotxa
+1
0
-1

lo que te sale no es preocupante... te viene a decir que ha descargado 222MB de paquetes pero que hay uno que no ha podido (gstreamer...blablabla.deb).

Puede ser debido a varias cuestiones, todas tienen que ver con la conectividad con http://mx.archive.ubuntu.com (p.ej. el repositorio no está disponible).

¿Cómo resolverlo? pues reintenta, suelen ser problemas momentáneos, he ido con el navegador a esa dirección y llego al archivo. Si vuelves a hacer la primera instrucción te borrará los 222MB, a lo mejor no quieres eso... supongo que basta con que repitas el update y el upgrade.

Si no pita, te abres synaptic, recargas info de repositorios (es lo mismo que el update) y antes de decirle "actualizate" deschequeas el paquete ese que no se puede descargar. En synaptic debe haber una lista o un report de qué va a actualizar/instalar antes de que lo haga... busca y lo encontrarás.  

Otra cosa: sólo tu ves tu pantalla, cuando digas me da el error "patatín" di quien te lo dice. Lo mejor es un copia+pega de la instrucción y las lineas implicadas (las que te dicen OK no interesan en este caso) 

Ánimo... no dudes en chequear que tienes espacio libre en / no sea que esto esté fastidiándolo todo, a veces pasa. 

GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de gotxa
+1
0
-1

Info adicional:

Si tu pingüino te dice algo, lo mejor es hacerle caso, siempre. Para eso hay que leer. Antes te decía: "¿quizá deba ejecutar apt-get update o deba intentarlo de nuevo con --fix-missing?"

Pues eso, que pongas
$ sudo apt-get update --fix-missing
y posiblemente (que no lo se, ojo) tenga el mismo efecto que lo que te he dicho antes con el des-chequear el paquete ese que no se baja, pero además de modo automático (¿y si hay 50 paquetes más que no encuentra?, ¿vamos a estar hasta el lunes?)... por probar no pierdes nada, --fix-missing no parece querer decir "formatea y quemalo todo que me estoy suicidando" ¿no crees?

GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de r1chd
+1
0
-1

mil gracias por la ayuda

pero nada funciona
 hice lo siguiente
sudo apt-get clean
despues
sudo apt-get update
luego
sudo apt-get upgrade

marco un error 

y  hice esto
sudo apt-get update --fix-missing

sudo apt-get upgrade marco el mismo error y dijo que usara  --fix-missing ya lo hice y trate otra ves con

sudo apt-get install mysql-server  lo descarga y cuando esta por instalar dice

dpkg: syntax error: unknown group `postdrop' in statoverride file
E: Sub-process /usr/bin/dpkg returned an error code (2)

imposible para mi soy muy ignorante o muy torpe para seguir sus explicasiones.

gracias  por la ayuda

 

+1
0
-1
Imagen de zirconio
+1
0
-1

 hola r1chd,

                         ¿Has podido solucionarlo?

Un saludo

Z .

Linux User Reg. #441216

Machine Reg #348016

+1
0
-1

Linux User Reg. #441216

Machine Reg     #348016

Imagen de r1chd
+1
0
-1

no zirconio
lo ultimo que hice fue
sudo apt-get update --fix-missing
y cuando trato de  instalar algo me saca este error  y no se que pueda ser.
dpkg: syntax error: unknown group `postdrop' in statoverride file
E: Sub-process /usr/bin/dpkg returned an error code (2)

ya no se que mas hacer 

+1
0
-1
Imagen de redick
+1
0
-1

hola gente no soy nuevo en ubuntu pero se me han olvidado algunas cosas ya que no tenia pc ahora kiero instalar mysql por un .deb luego me dice que hay una version mas estable me inmagino que en algun repositorio pero sigo adelante y al final me dice que hay conflicto de paquetes y no se instala.
buske y encontre esto
sudo apt-get install mysql-server mysql-client mysql-admin mysql-doc-5.0
mysql -u root -p
entonces me dicen ke durante la instalacion me pedira un pass ke debo poner, pero no me lo pide, se instala y boy a programacion y esta el programa pero me pide la contraseña que nunca he metido.
me meto en esta conversacion porke como si soy nuevo aki en ubuntu.es y la verdad no se como entrar a un foro espero alguin me de algun tipo de respuesta que me pueda ayudar.
gracias

+1
0
-1

red

Imagen de zirconio
+1
0
-1

Hola r1chd;

                 siento no haber podido ponerme antes, pero es que mi tiempo libre es como la amabilidad, escasea bastante.

He podido ver que has tenido problemas con este asunto aún habiendo intentado muchas cosas.

Creo que el problema está centrado en el mismo punto, tienes un problema con paquetes que han quedado a medio desinstalar y ocasionan conflicto con las marcas en los inodos de la nueva lista de directorios. Esto es algo bastante puñetero porque es dificil localizarlos manualmente. Claro, que también tiene su lógica que el sistema esté diseñado así  y este problema no ocurre con frecuencia, afortunadamente. Si esto te ocurre en Windows, supondría un cuelgue seguro.

                 Vamos a probar a desinstalar todo el paquete y las dependencias apuntadas haciendo

sudo apt-get remove --purge NOMBRE DEL PAQUETE.

Si esto diera errores en salida, puedes comprobar el directorio

$ ls -a /var/cache/apt/archives/partial

para ver si aun continúas teniendo el puntero del directorio sobre el paquete original. Es decir, el archivo estará vacio pero existe un enlace que apunta a él y por eso no puede borrarse

Otro método para conocer los paquetes y enlaces rotos es la opción  --fix-broken de apt-get 

o también apt-get -f check        donde -f   fuerza la continuidad si la integridad es fallida.

Prueba esto y cuéntanos el resultado.

Un saludo.  Suerte y paciencia. En el peor de los casos aprenderás mucho sobre el manejo de archivos y por supuesto todo esto tiene solución, aunque en un primer momento nos parezca que no. 

 

Linux User Reg. #441216

Machine Reg #348016

+1
0
-1

Linux User Reg. #441216

Machine Reg     #348016

Imagen de dasht
+1
0
-1

Dash Alejandro Sandín Vargas

DMC Mella

Stgo -Cuba

Configurando mysql-server-5.0 (5.0.45-1ubuntu3.3) ...
* Stopping MySQL database server mysqld [ OK ]
* Starting MySQL database server mysqld [fail]
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error al procesar mysql-server-5.0 (--configure):
el subproceso post-installation script devolvió el código de salida de error 1
dpkg: problemas de dependencias impiden la configuración de mysql-server:
mysql-server depende de mysql-server-5.0; sin embargo:
El paquete `mysql-server-5.0' no está configurado todavía.
dpkg: error al procesar mysql-server (--configure):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
mysql-server-5.0
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

+1
0
-1

Dasht Alejandro Sandín Vargas

DMC Mella

Stgo -Cuba 

--
No le presto mucha atención a lo que se hace con otros sistemas operativos.
No compito, sólo me preocupa hacer que Linux se supere a sí mismo, no a los otros.
Linus Torvalds