Como Desinstalar OpenGL mesa3D en feisty con ati

Imagen de ldcl289
0 puntos

Tengo una ati radeon x200m, instalo los drivers, una y otra vez, pero al darle glxinfo, simpre me sale:

OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

en vez de salirme lo respectivo a mi targeta!!

que puedo hacer para deshacerme de eso y que mi targeta funcione correctamente!!

Imagen de eltigrefernandez
+1
0
-1

Comentario moderado.

Motivos:

hola, has puesto tu pregunta dentro de la de otro compañero. De esta manera se confunden las posibles respuestas a los dos. Abre tú una nueva en el foro correspondiente. Échale una ojeada a las normas

+1
0
-1

Gracias..

Imagen de Hach Winik
+1
0
-1

Tranquilo amigo, primero, nos has dicho tu problema pero no lo más básico para poder ayudarte, Que tarjeta tienes??? has probado con la nueva versión Feisty??? ya checaste los foros de ayuda?

Es más fácil ayudarte cuando has agotado las respuestas de los foros y dandonos a conocer más a detalle tu problema y las características de tu hardware.

y más si pones tu pregunta en el foro adecuado y en un nuevo mensaje. 

Saludos.

Ing. José Leopoldo Sánchez Ramos

Nuevo León, México

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos 

Imagen de Hach Winik
+1
0
-1

Y que drivers instalas? que versión de ubuntu y de xorg tienes??

 

Saludos.

Ing. José Leopoldo Sánchez Ramos

Nuevo León, México

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos 

Imagen de ldcl289
+1
0
-1

los de la GPU el nombre de archivo ati-driver-installer-8.38.6-x86.x86_64.run que lo bajo directamente de de la página de ati.

mi ubuntu es feasty y con respecto al xorg, soy nuevo en ubuntu y no se que es xorg!!

como me fijo en esto??? 

+1
0
-1
Imagen de Hach Winik
+1
0
-1

para ver la version has en consola

sudo aptitude show xorg

 te mostrará los datos, si está instalado o no y que versión

si es la 7.2 la que tienes instalada tienes que pasarle ciertos parámetros al instalador del driver para que lo instale "pensando" que es un xorg 7.1, ya he puesto esa respuesta anteriormente.

y para saber que es el xorg, nada como un:

man xorg

para salir del manual presionas q

Saludos.

Ing. José Leopoldo Sánchez Ramos

Nuevo León, México

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos 

Imagen de ldcl289
+1
0
-1

la versión que me dice es:

"Versión: 1:7.2-0ubuntu11"

y con respecto a lo de esos parámetros, y que es lo que hace exsactamente y como se hace??

+1
0
-1
Imagen de Hach Winik
+1
0
-1

Haces esto:

X_VERSION=x710 ./ati-driver-installer-8.38.6-x86.x86_64.run

 

Saludos.

Ing. José Leopoldo Sánchez Ramos

Nuevo León, México

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos 

Imagen de ldcl289
+1
0
-1

ya lo hice y no pasa nada, instala, reinicio y nada.

le doy al ati catalyst control center en el menu y no abre!! enotnces le doy el comando  amdcccle y me da este mensage

Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Fallo de segmentación (core dumped)
 

le doy el aptittude show xorg y me sigue dando lo mismo, que será??

que pasa si en vez de:

X_VERSION=x710 ./ati-driver-installer-8.38.6-x86.x86_64.run

le doy:

X_VERSION=x720 ./ati-driver-installer-8.38.6-x86.x86_64.run

 

+1
0
-1
Imagen de Hach Winik
+1
0
-1

y cambiaste el xorg.conf donde dice driver??? de ati a fglrx?? 

 

Saludos.

Ing. José Leopoldo Sánchez Ramos

Nuevo León, México

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos 

Imagen de ldcl289
+1
0
-1

si lo cambié y no pasa nada!!

+1
0
-1
Imagen de Hach Winik
+1
0
-1

Que onda ldcl289, ya viste que hay un nuevo driver en ati? no lo has probado, ese funciona con el xorg 7.2, nada más desinstala lo del fglrx y drivers anteriores.   Ahorita estoy usando debian lenny, y tenía problemas con la 200m, pero era por la versión del kernel y broncas con la GPL...   pero cuando tenía ubuntu feisty, logre el renderizado con los drivers propietarios que trae default... en otra ocasión no me funcionó, no sé por que, pero instalando el driver de la página de ati, hice más o menos lo siguiente:

$sudo apt-get install module-assistant

#m-a a-i fglrx  ## instalamos el modulo fglrx

#./ati.xxxxxxxx  ## instalas el driver

# luego modificas el xorg.conf con las opciones>

    Driver      "fglrx"
    Option        "VideoOverlay" "on"
    Option        "OpenGLOverlay" "off"

 no es necesario hacer el aticonfig, después de configurar a mano el xorg, o si no quieres configurarlo manual, has el aticonfig --initial y el aticonfig --overlay-type=xV

reinicias y listo....    en una ocasión, tuve que agregar el load fglrx en el xorg, y también en el /etc/modules, por que no se cargaba al inicio el modulo.

Espero te sirva de algo.    

Saludos.

Ing. José Leopoldo Sánchez Ramos

Nuevo León, México

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos 

Imagen de ldcl289
+1
0
-1

desinstalo el driver propietario que estaba instalado, pero al darle en terminal "m-a a-i fglrx" me da el siguiente error, una y otra vez:

 

Installation of the fglrx-kernel-src source failed.                    
Ignoring this package. Maybe you need to add something to               
sources.list, maybe the contrib and non-free archives.   

 

que podrá ser y como se arregla?? 

+1
0
-1
Imagen de Hach Winik
+1
0
-1

checa esto...  

http://blogmanuelmeza.wordpress.com/2007/01/17/aceleracion-grafica-ati-r... 

 el error te lo marca por que no tienes el kernel source del fglrx, lo puedes crear siguendo lo que mencionan en el enlace anterior, en la parte de instalar el driver.

Saludos.

Ing. José Leopoldo Sánchez Ramos

Nuevo León, México

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos