Fallo con el teclado

Imagen de sereuca
0 puntos

Tengo un error que no me permite poner el teclado en castellano.
Intento instalar el paquete xkeyboard-config pero siempre me da el mismo error:

Preconfiguring packages ...
(Leyendo la base de datos ...
102380 ficheros y directorios instalados actualmente.)
Desempaquetando xkeyboard-config (de .../xkeyboard-config_0.5-1_all.deb) ...
dpkg: xkeyboard-config: atención - el conffile `etc/X11/xkb/symbols/pc' no es un fichero normal o un enlace
simbólico (= `/etc/X11/xkb/symbols/pc')
dpkg: error al procesar /var/cache/apt/archives/xkeyboard-config_0.5-1_all.deb (--unpack):
intentando sobreescribir `/etc/X11/xkb/compiled', que está también en el paquete xbase-clients
Se encontraron errores al procesar:
/var/cache/apt/archives/xkeyboard-config_0.5-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

He probado a cambiar los permisos de ese fichero y ponerlos 777, he movido el fichero para que pudiese crear uno nuevo pero siempre obtengo el mimso error.
Alguien sabe como resolverlo, por favor?

Imagen de sereuca
+1
0
-1

Si voy a
Sistema -> Preferencias -> Teclado

cuando intento cambiar algo me sale un cuadro con un mensaje de error:

Error al activar la configuración XKB.
Podría deberse a varias circunstancias:
- un fallo en la biblioteca libxklavier.
- un fallo en el servidor X (utilidades xkbcomp, xmodmap)
- Un servidor X con una implementación incompatible con libxkbfile

Datos de la versión del servidor X:
The X.Org Foundation
60802000

Si informa de esta situación como un fallo, por favor incluya:
- El resultado de xprop -root | grep XKB
- El resultado de gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Alguien sabria alguna solucion aunque sea provisional?

- El resultado de xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "base", "pc101", "us", "", ""

- El resultado de gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd es que no tengo ese directorio en desktop, lo tengo en /home/gnome pero tampoco tengo peripherals

+1
0
-1
Imagen de sereuca
+1
0
-1

Como podeis observar por estos preciosos caracteres:

á é í ó ú me falta la enhe

Vaya, al menos los - / están en su sitio.

Pues nada si podis echarme una mano para encontrar la enhe nuestra.

Por cierto, al iniciar nuevamente gnome me sigue saliendo el cuadro alusivo al error de XKB. y si trato de acceder a Sistema->Preferencias->Teclado sigue ocurriendo lo mismo de antes.

+1
0
-1