Ncesito actualiza el Kernel

Imagen de KREMLIM
0 puntos

Hola amigos, tengo una pregunta que me esta matando
quisiera saber como actualizar el KERNEL 2.4.20-6 a uno posterior
actualmente uso RED HAT 9, y donde puedo conseguir un KERNEL mas actualizado.

Gracias.....esperando.....

Imagen de Anónimo
+1
0
-1

Mira, éste es el link de la última versión estable (2.6.12.3), te lo bajas y lo compilas.

http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.3.tar.gz

Si no sabes compilarlo no te preocupes, no es muy complicado, hay muchos tutoriales en Internet.

Yo no he utilizado nunca Red Hat, pero si no quieres compilar el kernel, supongo que como todas debe tener una herramienta para actualizar y desde allí podrás actualizar el kernel a una versión más moderna que la que tú tienes.

1 saludo y suerte

+1
0
-1
Imagen de Gael
+1
0
-1

Si no aplicas ningún parche al kernel de www.kernel.org recuerda compilar como <*> y no como módulo TODO lo que pueda necesitar tu kernel para empezar a leer de tu disco duro y cargar modulos, así como mostrar esa información por pantalla, pero sin pasarte.

Realmente no se qué es necesario, esto va por prueba y error, pero en mu humilde experiencia no te dejes sin marcar como interno:
-Gestión de energía, ACPI
-El PCI (a secas, el express tb si tu gráfica es de ese tipo)
-Plug & PLay
-SCSI si toca
-"ATA/ATAPI/MFM/RLL support" no te dejes nada importante sin cargar como módulo, para que pueda leer de tu disco duro.
-Drivers gráficos, lo mismo que el anterior
-Sistemas de archivos, si usas ext3 pues ese, además de todos los importantes como /proc, soporte de tipos de particiones, lenguaje nativo, etc.

Y te preguntarás... "¿por qué no lo meto todo?" Pues ahora viene lo bueno, tu kernel no puede ocupar más de un mega (creo) comprimido en bz2, 2 megas sin comprimir aproximadamente... Para eso sirve el cramfs (creo), para meter a destajo cosas en el nucleo, y luego crear un sistema de archivos en ram para poder cargarlo todo. Y aun con este no es recomendable meter más que lo necesario. Pero no me hagas mucho caso, que soy nuevo en esto.

También recuerda que el driver de tu gráfica de X11, si es propietario como pasa con Ati y nVidia, probablemente no soporte el último nucleo, y tengas que usar el 2.6.12 o 2.6.11.

+1
0
-1