como instalo programas bajado de intertet

Imagen de jano2007
0 puntos

Hola, soy absolutamente nuevo en esto de ubuntu , pero la verdad me encanta.

me gustaria comenzar a saber como instalar los programas uno mismo

por ejemplo baje el pando

y bajo el pandodl-0.9.1.0.tar.bz2 y se abre un gestor de paquetes

hasta ahi llego

si alguen me puede ayudar

gracias

 

Imagen de william_s
+1
0
-1

Hola primero q nada generalmente los archivos que estan en tar.bz tar.gz con codigo fuente por lo tanto lo primero descomprimirlos con

tar zjvf archivo.tar.bz2

tar zxvj archivo.tar.gz

 

luego de eso obtendras un directorio e ingresas ahi  y generalmente haces

./configure

si todo esta ok

make

y despues

make install

ahora bien el problema con este tipo de instalaciones es que a veces se necesita muchas dependencias por lo tanto se tiene que buscar los archivo q te piden descargar instalar y volver a probar seria bueno q leas el archivo README o INSTALL q se encuentra dentro de la carpeta q descomprimiste.

saludos

 

willi@ms 

+1
0
-1

saludos

willi@ms 

La clave de un linuxero es la investigacion y si no investigas mejor borrate y vete por la "ventana"

Imagen de polloypan
+1
0
-1

y q puedo hacer cuando el comando configure no me funciona?

+1
0
-1
Imagen de elgatogordo
+1
0
-1

no sé si tienes en claro las formas de instalar programas en ubuntu, si lo sabes tenme un poco de paciencia porque le puede servir a alguien

Existen tres formas de instalar programas

GESTORES DE PAQUETES

En APLICACIONES AÑADIR Y QUITAR PROGRAMAS tienes un instalador de una serie de aplicaciones.

En SISTEMA ADMINISTRACIÓN GESTOR DE PAQUETES SYNAPTIC tienes una completisima lista de programas para todos los gustos

Otro gestor de paquetes que tiene tantos seguidores como detractores es AUTOMATIX www.getautomatix.com  que simplifica la instalación de codecs y plugins.

PAQUETES DEB es un sistema muy similar al de windows,  haces doble click y el sistema te lo instalas.

Si te descargas paquetes RPM por medio de una aplicación llamada alien lo puedes convertir a .deb

Primero hay que instalar alien

Escribe en el terminal

sudo aptitude install alien

Convertir de deb a rpm (el archivo debe estar en tu carpeta personal)

sudo alien nombre archivo.rpm

esto te generara un paquete deb que instalaras como te dije más arriba

COMPILACIÓN DE PROGRAMAS

Tienes que tener instalado los siguientes paquetes

sudo aptitude install build-essential

sudo aptitude install make

luego descomprimes el archivo y haces

cd directorio del archivo

./configure

aqui puede que el configure te diga que faltan paquetes en este caso debes buscar en el synaptic, en general los paquetes que tienes que instalar son los terminados en -dev. Ejemplo: si te dicen que te falta el paquete elgatogordo 2.5 tienes que instalar el paquete elgatogordo2.5-dev

una vez que el configure te da el ok haces

sudo make

sudo make install 

su pregunta no molesta gatogordo@ubbi.com

+1
0
-1
Imagen de elgatogordo
+1
0
-1

ejecuta los pasos siguientes 

su pregunta no molesta gatogordo@ubbi.com

+1
0
-1
Imagen de polloypan
+1
0
-1

a ver siguiendo tus pasos, instalo los paquetes build-essential y make correctamente.

Una vez en la caperta donde he descomprimido el archivo tar.gz , el programa me crea varias carpetas y tres archivos (make,Tuxguitar y Tuxguitar.jar)

Cuando hago el comando ./configure , me dice:

bash: ./configure no existe el fichero o directorio

y en el caso de make pone:

make: *** No se especifico ningun objetivo y no se encontro ningun makefile. Alto

Que paso es el que me estoy saltando? o como lo puedo solucionar?

+1
0
-1
Imagen de Festor
+1
0
-1

 polloypan el programa que buscas, el TuxGuitar está disponible en formato .deb (paquete instalador). Te recomiendo que lo instales desde este paquete .deb de la web oficial:

http://prdownloads.sourceforge.net/tuxguitar/tuxguitar-0.9.1-ubuntu-7.04-1.deb?download 

Y el plugin para el soporte ALSA (recomendado) tambien en paquete .deb:

http://prdownloads.sourceforge.net/tuxguitar/tuxguitar-alsa-0.9.1-ubuntu-7.04-1.deb?download 

Intenta evitar cualquier proceso de compilación a no ser que sea estrictamente necesario ya que te ahorraras posibles problemas inecesarios además que los paquetes .deb permite instalar el programa y desinstalarlo de una forma tremendamente facil.

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de polloypan
+1
0
-1

al principio es un bache tras otro...

bueno a lo q voy, me baje los 2 archivos deb ,q me recomendasteis, pero al instalar el Tuxguitar, me dice:

error: dependency is not satisfiable: sun-java 6-jre|sun-java 5-jre

buscando por ahí ,intente lo de

sudo aptitude install sun-java6-jre

pero tb me decia q no podia encontrar los paquetes. Rebuscando mas, encontre la pagina de java para bajarmelos (http://java.sun.com/javase/downloads/index.jsp) pero es q hay tantos downloads q nose cuales son los q me interesan.

Si me pudieseis echar otra ayudita, os lo agradeceria.

 

PD:gracias de antemano por vuestra paciencia

PD2:tb intente lo de aptitude search java ,pero nasty tb porq no encuentraba los malditos paquetes jejeje

+1
0
-1
Imagen de Festor
+1
0
-1

 ¿Has activado los repositorios universe y multiverse?

Ve a Sistema > Administración > Orígenes de software 

Y activa todas las casillas de la sección  "Descargable de Internet", luego ve a la pestaña "Actualizaciones" y activa las casillas "Actualizaciones importantes de seguridad" y "Actualizaciones recomendadas"

Ahora instala el paquete sun-java6-bin 

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de polloypan
+1
0
-1

Parece q hera eso por lo q fallaba, ya me funciona "casi" perfectamente.

Digo "casi" porq el problema lo tengo ahora porq no suena el sonido en el programa; bueno supongo q esta cuestion la tengo q preguntar en otro hilo..

De nuevo muchas gracias

 PD:en el caso de q puedas saber la respuesta, solo decirte q el sonido en otros programas, si funciona. Usease q es evidente q el problema lo tiene el tuxguitar

+1
0
-1
Imagen de Festor
+1
0
-1

 ¿Has instalado esto?

Y el plugin para el soporte ALSA (recomendado) tambien en paquete .deb:

http://prdownloads.sourceforge.net/tuxguitar/tuxguitar-alsa-0.9.1-ubuntu-7.04-1.deb?download

 Es el soporte de audio para ALSA del programa. En otras palabras instalando esto te debería funcionar el audio. Eso si si tienes configurado el sistema para que use ALSA y no OSS (Sistema > Preferencias > Sonido)

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de polloypan
+1
0
-1

En la configuracion del sistema (Sistema > Preferencias > Sonido) tenia seleccionado alsa, aunque he probado todas las opciones, menos la de silencio claro. Todas las opciones de prueba en las preferencias suenan menos claro esta, la de (conferencia de sonido > captura de sonido) que tengo seleccionado alsa...

El plugin de alsa ya lo habia instalado, incluso he probado a reinstalarlo varias veces a ver si colaba.

Tambien he probado a actualizar los drivers de alsa y tampoco.

 

Nose alguna idea mas? ... yo creo q se nos estan acabando las balas

 

+1
0
-1
Imagen de Festor
+1
0
-1

En la web del programa... ¿tienen un foro? ¿Comentan algo relacionado con problemas con el sonido?

¿Has configurado el control de volumen?

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de Festor
+1
0
-1

Es aconsejable que instales el paquete .deb del programa y no lo compiles ya que luego evitaras posibles problemas si quieres desinstalarlo, bajate el .deb de aquí:

http://www.getdeb.net/release.php?id=971 

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de hellboy
+1
0
-1

Tal vez no tienes instalados los paquetes: make y linux-headers

si no fuera asi te recomiendo que primero instales estos paquetes.

 O tal vez no exista un archivo "makefile" en la carpeta (comprimida .tar) que descargaste

http://hellboy.110mb.com

+1
0
-1

---------------------------------
| http://iloo.wordpress.com |
---------------------------------