Prelación de dos placas de sonido

Imagen de Nadifo
0 puntos

Llevo prácticamente un mes tratando de activar en exclusiva mi segunda placa de sonido. He intentado todas las combinaciones que me son posibles. Si lo consigo casi totalmente, es por poco tiempo, pues al encender nuevamente el ordenador puede salirme otra vez activada la tarjeta de la placa base. Si escucho sonido por la Delta 66 (la que quiero mantener activa en exclusiva), tengo que cambiar los cables pues el sonido en el navegador o el reproductor salen por la otra. Con Nvidia como cero, escucho Totem por la salidad de la Delta 66 y por la salida de la Nvidia XMMS seleccionando Alsa. Si cambio a Jack, entonces tengo que cambiar a la salida Delta 66 en el momento más inesperado. Francamente, estoy hasta las narices. Me resulta sorprendente que en una distribución pensada para música esto no pueda tener una solución fácil y definitiva. ¿Es que soy el único que tiene una segunda placa de sonido?

 He leído que se puede activar la segunda placa con: 

o@u:~$ asoundconf set-default-card 1

Pero no es una solución definitiva. Reiniciar el ordenador es una lotería que vete a saber qué puede salir. Además, tengo entendido que, por defecto, con Jack, siempre coge la 0, aunque en su configuración selecciones la 1.

También he leído que de esta manera se puede hacer definitivo: 

o@u:~$ cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 18
 1 [M66            ]: ICE1712 - M Audio Delta 66
                      M Audio Delta 66 at 0x9c00, irq 21

Entonces, escribo al finar de este archivo /etc/modprobe.d/alsabase
estas dos líneas-

options snd-M66 index=0           
options snd-NVidia index=1

¿Es ésta una buena solución y simplemente he escrito mal la identificación de las placas, porque todo sigue igual?

En Sistema/Sistema/Sonidos
Por más que cambies de autoseleccionar a Alsa o a ICE712, y seleccionar en el campo final (Pistas predeterminadas del control de volumente) la Delta 66, no pasa absolutamente nada.

 También he leído esto:

Como a veces cambia de orden, no me vale con porner el indice en el rc.local  directamente, así que he añadido esta linea:# Sets default sound card
asoundconf set-default-card $(cat /proc/asound/cards | grep V8237 | sed -e"s/\[V8237.*$//")

 Esto no le he intentado pues no me quedaba clara su redacción, además de que ignoro como escribir la barra vertical... (¡¡¡)

Agradezco una ayuda.

Salud. 

PD.- Entre los afortunados que contesten a este mensaje pienso sortear un jamón virtual. Ánimo. 

Imagen de orionce
+1
0
-1

Amigo te comprendo.

YO tengo dos placas y me pasa exactamente lo mismo. Por mas que configure la placa cuando reinicio suena la otra.

Si tienes planeado usar solo la que instalaste por último. prueba deshabilitar la integrada desde la bios de tu pc para que tu sistema operativo no la reconozca. 

+1
0
-1
Imagen de Nadifo
+1
0
-1

Hola a todos: 

Intenté deconectar en la Bios la placa integrada. Entré en

Advanced/Onboard Device Configuration

Desactivé: "Onboard nVidia LAN

Automáticamente se desactivó: "Onboard LAN boot ROM

También desactivé, según leí en otro sitio, la opción:

Game port address, que estaba en "201".

¿Es correcto así? 

El resultado, no sólo no desactivó la tarjeta integrada, sino que se fue el sonido en casi todos los programas hacia esa tarjeta, además de que en el navegador los videos no los oía en ninguna de los dos placas. En fin, un desastre. He vuelto a poner la Bios como estaba, y así estoy: quemado y viendo que tendré que cambiar de distribución, o abandonar linux para música hasta que, de verdad, esté esto en condiciones. Así, desde luego, no me atrevo a recomendar a nadie que se pase a estas distribuciones con problemas básicos irresolubles y que en Ventanuco son implanteables. En suma, una gran decepción.  

Según he leido en más de un sitio, esto con alsaconf es coser y cantar. Pero no viene con esta distribución ni está en sus repositorios. ¿Es efectivo este programa? ¿Hay forma fácil de conseguirlo e instalarlo de forma realmente compatible a esta distribución?

Un saludo, y gracias por contestar.

 

+1
0
-1
Imagen de orionce
+1
0
-1

Me suena que "Onboard nVidia LAN" es el puerto de red.

Tu Placa vase es nVidia? no se el orden de las opciones en una nvidia.

Pero, talvez lo que tengas que desactivar es algo aso como "Onboard nVidia audio" y no lo que desactivaste.

en mi caso lo que desactivo es "Onboard integral Audio" ...creo, tendría que entrar en la bios.

+1
0
-1
Imagen de Nadifo
+1
0
-1

Hola a todos, (especialmente a Orionce).

 

Si, la placa base es una nVidia. 

En "Advanced/Onboard Device Configuration" de la Bios encuentro estas opciones:

Onboard nVidia LAN   [Enabled]

Onboard LAN boot ROM   [Enabled]

Onboard IEEE 1394    [Enabled]

HD Audio      [Enabled]

Serial Port1 Address   [3F8/IRQ4]

Serial Port2 Address  [2F8/IRQ3]

Paralell Port Address   [3F8/IRQ7]

Paralell Port Mode   [Bi-directional]

ECP Mode Use DMA    [3]

Game port address    [201]

Midi Port Address    [Disabled]

 

El IEEE 1394 creo, no estoy seguro, que ya probé desactivarlo, sin gran resultado. Así que creo que la opción más probable sería la de "HD Audio", ¿no? Tengo miedo de ponerme a hacer pruebas con la Bios, algo que nunca hecho por no estar preparado, pero podría probar con esas dos opciones (HD Audio y IEEE 1394) como intento desesperado. ¿Os parece que merece la pena?

 

Un saludo cordial. 

 

+1
0
-1
Imagen de orionce
+1
0
-1

Nadifo.

No le tengas miedo a ti Bios, si bien es cierto una mala manipulación podría hacer que no arranque el Pc no es algo que no tenga solución, lo único que no recomiendo es actualizarla. De todos modos si cambias algo siempre existe la posibilidad de cargar los valores por de fault que trae la Pc.

Es bueno que pariendas a conocer la bios de tu Pc.

Todo apunta a que HD Audio es la solución, de todos modos si no te sirve la vuelves a activar y ya.

Yo no logré estabilidad hasta que descativé la mía.

espero que lo soluciones. 

+1
0
-1
Imagen de josmen
+1
0
-1

Grcias en verdad soy bien nuevo con ubuntu, y me gusto, luego de recibir un curso en la Universidad, me cambie, pero tengo la pc, dual, más hice todo los paso con respecto al sonido, realize; esto que tú digiste, y resuleto, son pana utedes

+1
0
-1

josmen