Xlib: extension "XFree86-DRI" missing on display ":1.0" . XGL sin Aceleracion 3D ( ATI)

Imagen de zeqk
0 puntos

Primero qiero decir q es totalmente posible hacer andar la aceleracion 3D, XGL y Beryl tanto con los drivers libres como con los propietarios en ATI.

Tengo una ATI Radeon 9600 y Ubuntu Feisty Fawn 

Lo he logrado. Pero ahora me surgio otro problema.

 Luego de instalar Compiz Fusion y actualizar unas cosas, la sesion con XGL pierde la aceleracion 3D. Al poner glxinfo | grep direct me devuelve:
Xlib:  extension "XFree86-DRI" missing on display ":1.0".
direct rendering: No

 

 Como no pude solucionarlo reinstale el sistema (xD solucion muy windowsera). Pero sigo teniendo el mismo problema (xD xD).

Es decir con los dirvers propietarios...

Cuando inicio la sesion Gnome sin XGL ,  glxinfo | grep direct me devuelve:

direct rendering: Yes

Cuando inicio la Gnome con XGL, glxinfo | grep direct me devuelve:

Xlib:  extension "XFree86-DRI" missing on display ":1.0".
direct rendering: No

 

Debo mencionar q aun no he instalado ni Beryl ni Compiz, primero qiero hacr andar el XGL 

Alguien mas ha tenido este problema ? 

Xlib:  extension "XFree86-DRI" missing on display ":1.0".

 

Imagen de abena
+1
0
-1

A mi me pasaba lo mismo, justo de una actualizacion del beryl-core, pero me fui a la sesion sin el xgl, me vole la sesion con el xgl y reinstale todo nuevamente y listo, todo funcionando perfectamente de nuevo

 

Andrea Benavides

+1
0
-1

 

 

 

---------------------------------

Ubuntu 7.04

----------------------------------

 

 

 

Andrea Benavides Vargas