¿Reinstalar Ubuntu o grub?

Imagen de juanfra_rc
0 puntos

Hola!, llevo intentando bastante tiempo conseguir arrancar de nuevo mi Kubuntu 7.04. Trás la instalación de Windows se me borró el gestor de arranque grub. He probado las siguientes cosas sin resultado:

1. Arranqué desde mi cd de instalación de kubuntu y abrí un terminal de consola. Lo que puse fue:

grub> find /boot/grub/stage1
(hd0,1)

grub> root (hd0,1)

grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/e2fs_stage1_5" exists... yes
Running "embed /boot/grub/e2fs_stage1_5 (hd0)"... 17 sectors are embedded.
succeeded
Running "install /boot/grub/stage1 (hd0) (hd0)1+17 p (hd0,1)/boot/grub/stage2
/boot/grub/menu.lst"... succeeded
Done.

Conseguí que de nuevo me apareciera al iniciar el ordenador la pantalla de grub, pero cuando selecciono el kubuntu me sale un error:

Error 17: Cannot mount selected partition

Sin embargo, si selecciono windows, éste va bien.

 

2. Volví a arrancar desde el cd de instalación de kubuntu, abrí un terminal y en esta ocasión escribí:

sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Ésta es la información de las particiones de mi disco:

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3912 31423108+ c W95 FAT32 (LBA)
/dev/sda2 8375 9698 10635030 83 Linux
/dev/sda3 9699 9729 249007+ 82 Linux swap / Solaris
/dev/sda4 3913 8374 35841015 7 HPFS/NTFS

Monté la partición de kubuntu que no puedo arrancar, con los comandos de abajo. Puedo ver todos mis archivos que tenía y he accedido al archivo menu.lst y la información de éste la muestro más abajo:

sudo mkdir /mnt/linux
sudo mount /dev/sda2 /mnt/linux

Información del archivo menu.lst estraído de /mnt/linux/boot/grub:

title Ubuntu, kernel 2.6.20-15-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=5fbb0245-8ae6-4847-9faf-2996f99f700b ro quiet splash
initrd /boot/initrd.img-2.6.20-15-generic
quiet
savedefault

title Ubuntu, kernel 2.6.20-15-generic (recovery mode)
root (hd0,2)
kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=5fbb0245-8ae6-4847-9faf-2996f99f700b ro single
initrd /boot/initrd.img-2.6.20-15-generic

title Ubuntu, memtest86+
root (hd0,2)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Home Edition
root (hd0,0)
savedefault
makeactive
chainloader +1

3. Me he descargado el Super Grub Disk, y lo he quemado con UltraIso. Sin embargo, el pc no me arranca con ese cd. [Tengo puesto en la bios el arranque desde cd]

 

Si alguien supiera cómo volver a arrancar mi ubuntu, agradecería que me lo comunicara.

La última opción que veo es volver a reinstalar kubuntu, pero quiero agotar antes todas las posibilidades.

 

Saludos.

 

 

 

 

Imagen de carloscv-207
+1
0
-1

Super Grub disk, favor buscarlo con Google.

+1
0
-1
Imagen de juanfra_rc
+1
0
-1

Hola carloscv-207!

Me he descargado SGD de http://sgd.howto-linux.de/download/ , concretamente el archivo sgd_current.is, lo he quemado y lo he arrancado.

Los pasos que he seguido han sido:

1. Selecciono Castellan Super Disco Grub

2. Gnu/Linux

3. Arreglas Arranque de Gnu/linux

4. Selecciono la partición donde tengo el menu.lst (la única que aparece)

Después de ésto, aparece que SGD lo ha conseguido

 

Reinicio mi ordenador, sale el menu de grub pero cuando le doy a arrancar el kubuntu me vuelve a salir:

Error 17: No puede ser montada la partición

¿Hay alguna otra opción en el SGD que arregle ésto?

 

+1
0
-1
Imagen de EnriqueK
+1
0
-1

El siguiente método mas parece como cazar moscas con cañones, pero es el que una vez empleé y me dió muy buenos resultados.
Primero debes conseguirte el Acronis True Image o tal vaez el Norton Ghost y crear una imagen de la partición EXT3 que contiene a tu Ubuntu, seguidamente con el partition Magic o similares, borra la partición que contiene a Ubuntu, luego usa el CD de instalación del XP, entra a la consola de recuperación y haces un fixmbr , esto regenera el sector de arranque dejándolo solo para Xp, a continuación haz una instalación nueva de Ubuntu en la partición borrada y sin alterar el tamaño de la misma, si todo sale bien hasta ahora, debe de haberse generado un Grub nuevo y correcto, finalmente con el clonador de particiones que usaste reinstala la imagen recién creada matando la nueva instalación del Ubuntu.
Solo unas consideraciones finales, el tamaño de la partición sobre la que se reinstala la imagen de Ubuntu, nunca puede ser menor a la original, puede ser mayor, pero nunca menor. Si bien este método puede resultar largo y tedioso, obtienes como premio una imagen de restauración de tu instalación de Ubuntu que puedes usar en otro momento y a esos archivos que componen la imagen los puedes grabar en DVD en calidad de respaldo extra.
Personalmente el clonador que uso es el "PQ Drive Image 2002", producto ya discontinuado por hace mas de 5 años, así que con clonadores mas modernos como el Acronis, no vas a tener problemas.

+1
0
-1
Imagen de The Biker
+1
0
-1

Que...¿¿¿??? No mi hermano..! como le vas a mandar hacer eso al pobre compañero, lo unico que tiene es un problema en el "grub", nada mas....!

No se si lo dijiste encerio o por cargoso, pero es absurdo hacer solo por que tiene un numero mal en el menu.lst del grub...! me parece...no?

Pongamos cuidado a lo que recomendamos...!

Saludos,

The Biker

PD: Todo sin animo de ofender mi estimado ubuntero.... :) 

+1
0
-1
Imagen de trykenter
+1
0
-1

Trykenter tiene el mismo problema practicamente y, de verdad, si no lo dices tú, lo digo yo. ¡Los hay bestias!

Yo para andarme con todo ese follón de del Norton Ghost y la consola de recuperación de Güindon, me reinstalo directamente todo el SO. Aparte de ser mas sencillo, es también mucho más rápido.

A propósito, perdona la intromisión, pero esque andaba googleando para solucionar mi problema con menu.lst y quería decirte que tus consejos me han servido de mucha ayuda. No se si podré solucionar el problema, pero ya se bastante más que antes.  Y por supuesto no tengo pensamientos de arreglar el problema formateando y todo lo demás. Como se suele decir en estos casos: muerto el perro, se acabó la rabia.

 

Gracias por tu ayuda involuntaria y que tengas una feliz y próspera jornada.

¡¡Ah!! , quiero reivindicar desde mi humilde opinión, los post pedagógicos. Hay que pensar que cuando se hace o se responde a una pregunta no se debe actuar egoistamente con el lema de problema resuelto, cada cual que se busque la vida. Hay que pensar en que otros foreros pueden tener el mismo problema que tú, y con un buscador encontrar la solución en tu post. Y esto va tanto para los usuarios como para los administradores de los foros.

Bueno... sólo es mi opinión. Saludos de la chica mala Trykenter. 

+1
0
-1
Imagen de The Biker
+1
0
-1

Cambia (hd0,2) por (hd0,1) en el menu.lst del grub.....

Quedaria asi:

title Ubuntu, kernel 2.6.20-15-generic
root (hd0,1)
kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=5fbb0245-8ae6-4847-9faf-2996f99f700b ro quiet splash
initrd /boot/initrd.img-2.6.20-15-generic
quiet
savedefault

Saludos,

The biker

+1
0
-1
Imagen de juanfra_rc
+1
0
-1

Gracias amigo!!

Por fín arranca mi kubuntu.

Reemplazé la línea que escribistes en negrita y todo vuelve a estar normal 

+1
0
-1
Imagen de trykenter
+1
0
-1

Amigo Juanfra: yo reclamo tu atención no para reponderte sino para todo lo contrario. Soy usuario de Kubuntu 7.04 desde hace exactamente un mes. Anteriormente estube jugando con él unos tres meses más. Tengo un problema muy parecido al tuyo, y me gustaría que me resolvieras algunas dudas o al menos que me des algún enlace o cualquier tipo de información.

Verás, mi problema viene simplemente de que tenía seis particiones en mi hd y he fusionado dos en una. Automáticamente han cambiado las numeraciones de cada una y por tanto, el grub no encuentra las cosas donde se supone que debieran.

He llevado a cabo una serie de reformas, como volver a instalar el arranque grub en el mbr, y cambiar en el menu.lst el root (hda4) por root (hda5). Este no es el problema.

El problema lo tengo en la tira de números y letras que aparecen en:

- kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=7a8ab896-5bf0-49ea-9b3a-166790a79cc3 ro quiet splash

El problema está el la pila de números y letras que aparecen después de UUID=.............. y que son la causa de que mi sistema arranque, pero a mitad seme pare anunciándome algún problema con los citadas cifras. Si aprieto ctr+alt+sup el proceso de carga sigue y acaba con éxito.

Me gustaría si no es abusar de tu altruismo, que me facilitaras la dirección o que me explicaras el proceso para generar estas cifras que son las que necesito para que mi sistema marche como una moto. He visto al principio que has introducido una serie de comandos, y has montado directorios y todo un portento de conocimientos técnicos que yo no tengo. Como ya te he contado, soy nueva y desconozco todavía toda la terminología. Y claro, tampoco me atrebo a hacer cosas sin saber pues no vaya a ser que lo que ahora es una tontería de cambiar un nùmero lo conviesta en un fiasco y tenga que reinstalar todo el SO entero.

 Pues eso era todo. Te pido nuevamente disculpas por la intromisión, pero es que google me ha llevado a tí. Muchas gracias anticipadas por todo y sólo me queda despedirme.

No se si las normas del foro permiten dejar las direcciones de email de los usuarios. Yo voy a poner la mía y si hago mal, pues ruego a los administradores que me perdonen. Seguro que en caso negativo la censurarán.

trykenter@yahoo.es 

+1
0
-1
Imagen de rpgmaker
+1
0
-1

El primer paso te debió funcionar perfectamente. Revisaste si la particion de tu instalacion de kubuntu estaba montada o reconocida?

+1
0
-1