"La extensión de Composite no está disponible"

Imagen de ehubu
0 puntos

Me instalé Ubuntu 7.04 hace pocos días, me ocurre un error con los efectos de Escritorio. Cada vez que yo abro los efectos de escritorio [Sistema>Preferencias>Efectos de Escritorio] me aparece un mensaje que dice: "la extensión de Composite no está disponible". Leí por los foros, pero lo explican de una forma muy compeja para mi nivel informatico, me gustaría que me explicaran como solucionar este problema lo mas entendible posible (por algo lo posteé en este foro para principiantes), nunca me metí en "Terminal", asi que porfavor, si las condiciones exigen meterse en el, expliquenme como va todo.

Gracias de antemano!

Imagen de shagrath
+1
0
-1

Tienes tarjeta de video con su respectivo driver instalado??

+1
0
-1
Imagen de Festor
+1
0
-1

 En el escritorio pulsa ALT + F2 , luego escribe:

gedit /etc/X11/xorg.conf

copia y pega el contenido del archivo aquí. 

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de ehubu
+1
0
-1

alli va

 

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
    Fontpath    "/usr/share/fonts/X11/misc"
    Fontpath    "/usr/share/fonts/X11/cyrillic"
    Fontpath    "/usr/share/fonts/X11/100dpi/:unscaled"
    Fontpath    "/usr/share/fonts/X11/75dpi/:unscaled"
    Fontpath    "/usr/share/fonts/X11/Type1"
    Fontpath    "/usr/share/fonts/X11/100dpi"
    Fontpath    "/usr/share/fonts/X11/75dpi"
    # path to defoma fonts
    Fontpath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load        "i2c"
    Load        "bitmap"
    Load        "ddc"
    Load        "dri"
    Load        "extmod"
    Load        "freetype"
    Load        "glx"
    Load        "int10"
    Load        "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "es"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"    "/dev/input/mice"
    Option        "Protocol"    "ImPS/2"
    Option        "ZAxisMapping"    "4 5"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "stylus"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "eraser"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "cursor"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
    Identifier    "ATI Technologies Inc RV380 [Radeon X600 (PCIE)]"
    Driver        "fglrx"
    Busid        "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier    "Monitor genérico"
    Option        "DPMS"
    Horizsync    28-51
    Vertrefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies Inc RV380 [Radeon X600 (PCIE)]"
    Monitor        "Monitor genérico"
    Defaultdepth    24
    SubSection "Display"
        Depth    1
        Modes        "1024x768"    "800x600"    "640x480"
    EndSubSection
    SubSection "Display"
        Depth    4
        Modes        "1024x768"    "800x600"    "640x480"
    EndSubSection
    SubSection "Display"
        Depth    8
        Modes        "1024x768"    "800x600"    "640x480"
    EndSubSection
    SubSection "Display"
        Depth    15
        Modes        "1024x768"    "800x600"    "640x480"
    EndSubSection
    SubSection "Display"
        Depth    16
        Modes        "1024x768"    "800x600"    "640x480"
    EndSubSection
    SubSection "Display"
        Depth    24
        Modes        "1024x768"    "800x600"    "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
  screen "Default Screen"
    Inputdevice    "Generic Keyboard"
    Inputdevice    "Configured Mouse"
    Inputdevice    "stylus"    "SendCoreEvents"
    Inputdevice    "cursor"    "SendCoreEvents"
    Inputdevice    "eraser"    "SendCoreEvents"
EndSection

Section "DRI"
    Mode    0666
EndSection
Section "Extensions"
    Option        "Composite"    "0"
EndSection

+1
0
-1
Imagen de ehubu
+1
0
-1

Estoy intentando cambiar este "0" de al final de todo donde pone composite pero al salir lo guardo i no me deja. me dice ke es un archivo solo de lectura...

 

gracias de antemano! 

+1
0
-1
Imagen de mayckol
+1
0
-1

sudo gedit /etc/X11/xorg.conf

Eso te pedirá una clave, al escribirla no aparecerá nada. Pero SI está escribiendo

 

+1
0
-1

Antes de cambiarte-->¿Es Ubuntu Para ti?
Si ya cambiaste bienvenido!

Imagen de Festor
+1
0
-1

Has instalado los controladores propietarios de ATI, no?

Pues bien con los controladores propietarios no te funcionaran los efectos de Escritorio ya que los controladores propietarios no los soportan.

La unica forma de usar los efectos de Escritorio, compiz o beryl sería probar con el XGL, pulsa en el enlace para más información:

http://www.google.es/search?hl=es&safe=off&client=firefox-a&rls=com.ubuntu%3Aen-US%3Aofficial&hs=hZL&q=xgl+ati+propietario+compiz+fusion&btnG=Buscar&meta=

No puedes editar el archivo  xorg.conf ya que es un archivo importante del sistema. Si quieres editarlo (aunque ya  te digo que  la mejor forma es lo de antes) escribe esto en la ventana que te sale con el ALT + F2

gksu gedit /etc/X11/xorg.conf 

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de ehubu
+1
0
-1

empeze a instalar todo lo del XGL, pero al poco rato los comandos no se activaban y no podia seguir el tutorial. Reinicie y al entrar en ubuntu salio el mensaje en forma de terminal. Se me deshabilitó el X window manager o algo asi en un plis i me quede sin poder entrar a ubuntu. Simplemente me pedia mi cuenta i mi contraseña en modo terminal i despues no se iniciaba. Que he hecho? me e cargado ubuntu? estoy desesperado!

+1
0
-1
Imagen de ehubu
+1
0
-1

por favor ayudenme

+1
0
-1
Imagen de neosng
+1
0
-1

Como no sé qué has hecho exactamente vamos a reinstalar el servidor gráfico por defecto y el driver que tenías según el archivo xorg.conf que nos has mostrado.

Entra con tu usuario y ejecuta:

sudo apt-get install --reinstall xserver-xorg-core xorg-driver-fglrx

Una vez instalado reinicia y nos cuentas:

sudo reboot

Un saludo.

+1
0
-1
Imagen de Festor
+1
0
-1

 ehubu, ¿Qué tarjeta gráfica usas? Marca y modelo por favor.

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de ehubu
+1
0
-1

Gracias, el problema del escritorio esta solucionado con eso de reiniciar.  Pero sigo sin tener el Composite, me gustaria saber si hay mas formas a parte de instalarse el compiz fusion, cosa que no haré ya que ha sido el causante de todos estos problemas.

 

Gracias por la ayuda 

+1
0
-1
Imagen de ehubu
+1
0
-1

Por cierto, uso una ATI x600

+1
0
-1
Imagen de neosng
+1
0
-1

Bueno, yo no uso ATI y veo que las soluciones que dan para hacer funcionar los efectos son un poco fuertes para un usuario nuevo, eso de ir creando archivos me parece una aberración por fácil que sea, si nadie se ha currado un paquete que haga la instalación sencilla recomiendo no tocar cosas a ese nivel, aunque ya sabes cómo volver atrás.

La única cosa que recomiendo es actualizar a Gutsy, que trae el último Compiz Fusion de serie y si hay suerte ya funciona directamente con los drivers propietarios de ATI:

sudo update-manager -c -d

+1
0
-1