Instalacion de ubuntu en dos HD, los dos con windows xp

Imagen de chincheta
0 puntos

Hola, antes de nada presentarme, me llamo Manu, y este foro me gusta bastante, espero que me podais ayudar. Tengo dos HDs uno SATA y otro ATA aunque eso no creo que importe pero asi me referire cuando hable de cada uno. En el SATA(lo tengo como principal y siempre inicio desde aqui) tengo el xp y en ATA tambien. El ubuntu lo quiero instalar en el ATA, de hecho ya lo tengo instalado. Lo instale utilizando el partition magic y creando las dos particiones necesarias y luego instale ahi el ubunto, hasta aqui perfecto. Si pongo como HD principal el ATA(win+ubuntu) me aparece el menu de elegir SO y arrancan los dos a la perfeccion. En cambio si pongo como principal el SATA(solo win), en un primer momento crei que no hacia nada, pero en realidad si que lo hacia pero como si tuviese unos kbs de RAM. LLego incluso a iniciar hasta el escritorio y todo(tardo unos 5 minutos y esta recien formateao y sin programas)pero era insoportable y lo apague, reinicie y como es logico el mismo problema. Supongo que todavia tengo que hacer algo mas para terminar de perfilar el ordenador y por eso os escribo(este tochazo sorry)a ver como seguro que muchos sabreis la respuesta. Decir que es mi primera vez jeje, si teneis que darme instrucciones hacedlas para un inutil xDD
Gracias por vuestro tiempo
Saludos

Imagen de Capa
+1
0
-1

Tienes instalado XP en dos HDD de la misma máquina ? Para qué ?

Has pensado en utilizar máquinas virtuales ? Seguro que te irán mejor.

En cuanto a tu problema ( advierto que soy novato en Linux ) parece ser que el GRUB lo tienes en el ATA y cuando arrancas de él arranca GRUB sin problemas.

Pero cuando arrancas del SATA al no tener el GRUB ( lo tenemos en el ATA ) pues no te da la oportunidad de arrancar Ubuntu.

 

Puede ser ? 

 

--

Antes de imprimir este comentario piensa en el medio ambiente.

www.sergiocaparros.es

+1
0
-1
Imagen de chincheta
+1
0
-1

Si supongo que el grub esta en el ATA. Cuando instale el linux, el SATA no lo tenia conectado. Puede que el grub no haya visto el SATA y de ahi que si inicio desde el SATA no vaya del todo bien, supongo que este es el problema, a ver si alguien sabe como hacer para sin tener que formatear que todo se inicie bien, gracias por responder
Saludos

+1
0
-1
Imagen de wachiman
+1
0
-1

Lo que tienes que hacer es instalar xp en el ata en una particion y despues en otra instalas ubuntu. Si quieres puedes desconectarlo e instalar xp en el sata con su propio mbr. Despues pones como primer disco de arranque el ata y le añades el sata al grub con algo parecido a esto:

title Microsoft Windows XP Home Edition
root (hd1,0)
savedefault
makeactive
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

yo lo tengo asi pero con Ubuntu solo en el ata, asi el grub te da la opción de arrancar el sata con xp y si eliges como primer disco de arranque el sata con xp no te borra el mbr.

+1
0
-1
Imagen de chincheta
+1
0
-1

Hola gracias por responder parece que la solucion esta cerca jeje. Ahora que leo el titulo veo que no me he explicado bien. Yo tengo dos discos como sabes uno ATA y otro SATA he instale en los dos el xp, despues desenchufe el SATA(no recuerdo porque lo hice), e instale el ubuntu solo en el ATA, es decir, los sitemas operativos los tengo instalados todos y como quiero, no quiero dos ubuntus como parece poner en el titulo, tan solo falta que me aparezca en el menu del grub el xp del SATA(y ademas que sea el predefinido en vez de ubuntu). Segun leo veo que tu lo tienes preparado como yo lo quiero(Sata con xp y ATA con xp y ubuntu), me da exactamente lo mismo poner como principal el ATA ya que si desde este se puede iniciar el SATA me es indiferente. Como es logico el grub esta en el ATA asi que si desconecto el ATA e intento iniciar desde el SATA la pantalla se queda en negro claro. Por favor esas lineas de codigo donde las pongo?, perdoname pero es que soy bastante novato, desde el grub en ubuntu?, muchisimas gracias
Saludos

+1
0
-1
Imagen de wachiman
+1
0
-1

sudo gedit boot/grub/menu.lst las pones al final de todo y puedes modificar los segundos de arranque y sacas # a hiddenmenu para que te aparezca en el menu de arranque.Hay una aplicacion que se llama administrador de arranque que la puedes instalar y te ayuda de forma gráfica a modificar algunos parametros.

+1
0
-1
Imagen de chincheta
+1
0
-1

Hola gracias por responder de nuevo, podrias explicarme paso a paso lo que tengo que hacer para tenerlo asi desde ubuntu, soy novato del todo, muchas gracias
Saludos

+1
0
-1