¿Porqué no sirve el comando MAKE?

Holas a todos, lo que pasa y sucede es que por fin pude bajarme el Feisty fawn (está muy bacano) pero por desgracias económicas mi computador no tiene acceso a internet, así que todo toca bajarlo de otro lado. Descargué inkscape y audacity (como que no se consiguen paquetes en .deb para estos programas), los descomprimí, en la terminal escribí "./configure" y luego "make" pero sale un error (algo así que como que faltan argumentos). Por aquí vi que tal vez falta el paquete build-essential, pero como les digo no tengo internet y supuestamente para descargarlo completo es un embrollo de los infiernos. ¡¡¡Que alguien me ayude y se le da cerveza gratis!!! Mentiras.

Imagen de JT Kirk
+1
0
-1

El tal build-essential viene en el disco de instalación, así que lo que tienes que hacer es añadirlo (el disco) como repositorio al synaptic, no te puedo explicar paso a paso porque no me acuerdo, pero si no te sale, lo miro.

+1
0
-1
Imagen de MarianoC
+1
0
-1

Es que por mas build-essential que tengas, sino tenes las librerias de desarrollo necesarias para compilar los programas te va a hacer imposible seguir...Seguramente cuando le pasas el configure te da errores, aunque puede ser que no los hayas visto...
Las librerias de desarrollo son las que termian en -dev...pero es bastante dificil saber con seguridad que libreria es necesaria para cada programa...
Ademas tanto audacity como inkscape estan en los repositorios de ubuntu, asi que si te das una vuelta por packages.ubuntu.com los vas a encontrar sin muchos problemas, y ademas tambien te indica cuales son las dependencias necesarias, por lo que obviamente tenes que bajarte tambien las dependencias...

Saludos!!

+1
0
-1
Imagen de Festor
+1
0
-1

 (como que no se consiguen paquetes en .deb para estos programas)

¿?

Audacity 

http://www.getdeb.net/release.php?id=796 

Inkscape 

http://ftp.osuosl.org/pub/ubuntu/pool/main/i/inkscape/inkscape_0.45-0ubuntu4_i386.deb 

Respecto a lo de tu error con el "make" es muy probable a que se deba por no tener los paquetes necesarios instalados. 

l****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de lauchacba
+1
0
-1

abris synaptic,,menu editar,, se despliega y elejis añadir cd.. o bien  pones buscar y en la ventanita que aparece escribis build-essential .

esta es una de las páginas de mi humilde sitio...jeje,, no es la gran cosa pero si te sirve ...

me/primero.htm 

suerte. 

==========lauchacba@hotmail============= http://ar.geocities.com/novatocba/doc/files/ubuntu-linux.pdf

redireccionado con: http://www.ratonera.raton.net.ar

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de azoth
+1
0
-1

Claro que si existen paquetes deb para audacity e inkscape, seguramente es que no tenias todos los repositorios activados y actualizados.

El problema de bajar en un computador e instalar en otro es que tienes que bajarte tambien todas las dependencias e instalarlas a mano:

si bajas audacity, necesitas bajar tambien los siguientes .deb:

libasound2, libc6, libexpat1, libflac++5c2, libflac7, libgcc1, libglib2.0-0, libgtk2.0-0, libid3tag0, libjack0.100.0-0, libmad0, libogg0, libsndfile1, libstdc++6, libvorbis0a, libvorbisenc2, libvorbisfile3, libwxbase2.8-0, libwxgtk2.8-0

para inkscape necesitas:

libatk1.0-0 , libc6, libcairo2, libcairomm-1.0-1, libfontconfig1 , libfreetype6, libgc1c2, libgcc1, libgconf2-4, libglib2.0-0, libglibmm-2.4-1c2a, libgnomevfs2-0 , libgtk2.0-0, libgtkmm-2.4-1c2a, liblcms1, liborbit2, libpango1.0-0, libpng12-0, libpopt0, libsigc++-2.0-0c2a, libssl0.9.8, libstdc++6, libx11-6, libxcursor1, libxext6, libxfixes3, libxft2, libxi6, libxinerama1, libxml2, libxrandr2, libxrender1, libxslt1.1, zlib1g

Bajatelos en otro ubuntu y luego copialos desde /var/cache/apt/archives junto a todas sus dependencias.

el build essential es indispensable para compilar cualquier cosa, pero para instalarlo tienes que instalar sus dependencias que son:

libc6-dev o libc-dev, gcc, g++, make, dpkg-dev

Como puedes observar, make es un paquete en si mismo:

Descripción: The GNU version of the "make" utility.
GNU Make is a program that determines which pieces of a large program need to
be recompiled and issues the commands to recompile them, when necessary. More
information about GNU Make can be found in the `make' Info page. The upstream
sources for this package are available at the location
ftp://ftp.gnu.org/gnu/make/. The documentation for this package does not meet
the Debian Free Software Guidelines, and has been removed from this package.

 

Hace tiempo vi en algun lado... tal vez guia-ubuntu.org... (mejor preguntale a google) una forma para crear un CD de repositorios en base a los .deb que ya te habias bajado en un computador y asi poder llevartelos a otro. ESA SERIA LA MEJOR OPCION .

instalar a mano puede llevarte a un "dependency hell" que es cuando necesitas descargar un paquete para instalar otro, pero ese otro necesita otro, que a su vez necesita otro y en algun punto de la cadena esta se vuelve un circulo... normalmente uno se ha enloquecido antes de llegar a ese punto

Cuando dijiste "bacano" significa que tambien sos de colombia?

 

+1
0
-1
Imagen de acidrums
+1
0
-1

Si, soy colombianito, BOGOTANO pa' más piedra, y estudio en la trístemente célebre Universidad Nacional de Colombia.

Gracias a todos por su ayuda y que pena la ignorancia; como que me va a tocar esculcar mas en los repositorios de Ubuntu. Bueno, y no se pongan de mal genio; toca que le tengan paciencia a los novatos como yo. :)

+1
0
-1