Mal funcionamiento de Compiz Fusion

Imagen de oroneta
0 puntos

Hola a todos.

He instalado con ayuda Compiz Fusion, pero me pasa como con beryl, no me funcionan bien.

Tengo una nvidia Geforce 7600 GT con 256 MB, en un Intel Core 2 6600 y una placa base ASUS P5K Deluxe.

Usé la siguiente guía para instalarlo: http://ubuntu-lat.org/?opt=1&bopt=ma&b=81

También reconfiguré el xorg.conf porque al instalar compiz dejó de funcionar la tecla Alt Gr. El problema de Altr Gr lo pude arreglar con ayuda, pero no así compiz. Si lo pongo me desaparece la barra de títulos de las ventanas y en vez de 4 escritorios en el área de trabajo, me aparece uno solo en forma de barra, no 4 cuadrados.

Mi xorg.conf es:

http://paste.ubuntu-nl.org/32582/ 

He buscado y he visto muchos post con gente con el mismo problema o parecidos, pero ninguna solución satisfactoria al respecto. A ver si alguien, por favor, tiene más suerte y encuentra el problema.

Muchas gracias a todos. 

 

Imagen de arraclan
+1
0
-1

tienes el driver propietario instalado?

 salu2
--
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422
Ubuntu 7.04/CompizFusion

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de oroneta
+1
0
-1

Instalé el driver mediante el gestor de controladores restringidos que trae Feisty, luego también con envy 0.9.7. En ambas formas me da aceleración grafica como Yes y el PC va bien, salvo que no van bien ni beryl ni ahora compiz fusion.

Al cargar sale el logo de nvidia, o sea que sí está instalado y funcionando ya que sí me da aceleración 3D y con Sysinfo y nvidia settings no veo nada raro.

Si alguien tiene alguna idea o ve algo raro en mi xorg.conf o necesita más datos, por favor, una ayudita. 

+1
0
-1
Imagen de arraclan
+1
0
-1

¿como inicias compiz?

de todos modos inicialo desde una consola y copia aqui el resultado.  Alli deveria cantarte un error.

 

salu2 

--
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422
Ubuntu 7.04/CompizFusion

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de oroneta
+1
0
-1

En consola, si pongo compiz (no sé si es eso lo que tengo que poner) sale lo siguiente:

compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0

 

+1
0
-1
Imagen de arraclan
+1
0
-1

usa esto:

compiz --replace --indirect-rendering -c emerald

o

fusion-icon

prueba con los dos, pero seria mejor el fusion-icon, es parecido al icono que salia en beryl.

 

salu2 

 


--
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422
Ubuntu 7.04/CompizFusion

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de oroneta
+1
0
-1

he probado con lo de fusion icon pero tampoco sale la barra de titulo de las ventanas y además se ha bloqueado el PC y ni con Ctrl + Alt + backspace, he tenido que reiniciar desde la torre.

luego he probado con emerald y sigue sin la barra de título, aunque no ha bloqueado el PC, menos mal. Lo que sale en la consola es:

compiz --replace --indirect-rendering -c emerald
compiz (core) - Warn: Unknown option '-c'

compiz (core) - Error: Couldn't load plugin 'emerald'
 

+1
0
-1
Imagen de arraclan
+1
0
-1

si que es raro:

a ver prueba a ejecutar compiz en consola con:

compiz --replace --indirect-rendering

te saldran las ventanas sin borde, abrete otra consola y ejecuta emerald con:

emerald 

a ver si asi te funciona....

--
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422
Ubuntu 7.04/CompizFusion

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de oroneta
+1
0
-1

Tampoco :-(

hice lo que has dicho y sí, desaparece la barra y al poner emerald sale la siguiente línea muchísimas veces:

(emerald:6578): Wnck-WARNING **: Unhandled action type (nil)

Si ya decía yo que estoy gafada jejejejeje

De todas formas te agradezco mucho que trates de ayudarme. 

+1
0
-1
Imagen de arraclan
+1
0
-1

vamos a compilar de nuevo emerald:

vete al directorio donde tienes fusion y ejecuta:

./makefusion clone

busca el directorio emerald dentro de fusion, entra y ejecuta:

sudo ./autogen.sh

sudo make 

sudo make install

puede que te de error en algún sitio...

 

salu2 

 

 

--
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422
Ubuntu 7.04/CompizFusion

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de oroneta
+1
0
-1

Bueno, he hecho todo eso y lo único que da muchos mensajes de que no ha podido hacer nada con distintas librerías o lo que sean. He intentado correr compiz de nuevo y sigue igual. En fin, tal vez la próxima versión de Ubuntu...

De todas formas compiz no es imprescindible, sólo que estoy en arresto domiciliario por baja laboral jejejejeje y me aburro muchísimo. 

En fin, muchas gracias por todo. 

+1
0
-1
Imagen de arraclan
+1
0
-1

porque no me pegas aqui esos errores? asi estas entretenida......jajajaja

en serio ponme los errores

salu2
 

--
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422
Ubuntu 7.04/CompizFusion

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de oroneta
+1
0
-1

Uff entonces el que no se va a aburrir serás tu jejejeje.

Cuando llego a sudo make, dentro de emerald sale:

http://paste.ubuntu-nl.org/32599/

Si tienes que leerlo todo mejor te envío aspirinas por mail jajajajaja.

Déjalo, te agradezco mucho tu esfuerzo y lamento haberte molestado tanto.

Ya encontraré algo para distraerme que aún tengo más cosas por probar además de compiz. Además, siempre puedo hacerle alguna foto a mi perra y retocarla... ;-) 

Muchas gracias por todo :-) 

+1
0
-1
Imagen de arraclan
+1
0
-1

como gustes pero esos no son errores, me haria falta lo que te da al ejecutar emerald...  cuando quieras retomarlo claro...

 

salu2 

--
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422
Ubuntu 7.04/CompizFusion

+1
0
-1

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de David_Eduardo
+1
0
-1

Hola lo que pasa es que yo configure el x-org pero despues no me aparecieron las barras de titulo, la terminal sale blanca pero no veo lo que escribo, al iniciar sale el logo de nvidia que antes no salia pero hasta el teclado se desconfiguro. No tengo Compiz pues no se que es xD, soy nuevo con linux.

Porfavor ayudenme se los agradezco de antemano. 

Adios 

+1
0
-1

------------------------------
Si alguien sabe como instalar una impresora Lexmark X2470 PM porfavor...
Estoy cansado de buscar y nada...

Imagen de Bend3r
+1
0
-1