compiz fusion y...pantalla negra!!

Imagen de gakna
0 puntos

Soy absolutamente nuevo en Ubuntu. Acabo de instalar Ubuntu 7.04 y un amigo que entiende algo instaló Compiz Fusion. Lo unico que hice mientras bajaban las 118 actualizaciones del sistema es ir a Sistema > Preferencias > Sesiones > Programas de inicio y puse "compiz --replace -c emerald" como decia un tutorial. Cuando termino de actualizarce y reinicié la computadora lo unico que veo es una pantalla negra en la que solo se ven los menùs de arriba. El mouse se mueve pero no me deja ejecutar nada y tengo que reiniciar nuevamente en forma manual.Ayuda!!!!!!!!!!!!!!!!!!!!  

Imagen de lorddeus
+1
0
-1

Yo lo que haria seria lo siguiente:

1)Abre una consola pulsando Control+Alt+F1

2)Identificate con tu usuario y contraseña 

3)escribe: cd .config/autostart

4)escribe: ls -l (Esto te mostrara una lista de los programas que se ejecutan al inicio en tu sesion)

5) una vez hayas localizado la entrada al compiz eliminala con el comando: rm (por ejemplo: rm compiz.desktop)

6) por ultimo vuelve al entorno grafico si aun no te logeaste pulsando control+alt+F7 o sino reinicia

Un saludo 

+1
0
-1
Imagen de oscarm
+1
0
-1

Suena a la configuración de la tarjeta gráfica. Seguramente en la actualización que comentas se ha instalado un nuevo kernel o un nuevo xserver-xorg. Puede que entonces hayas perdido la aceleración 3D. Escribe en una terminal "glxinfo". Si en la sección Direct rendering pone "No", toca reconfigurar la tarjeta gráfica. Espero serte de ayuda.

Un saludo. 

+1
0
-1
Imagen de gakna
+1
0
-1

Gracias por las respuestas! el tema es que:

-no me deja abrir una consola, es decir que pulso Control+Alt+F1 y no sucede nada, está totalmente congelado. Volví a reiniciar manualmente, entré en modo recovery e intenté poner los comandos que me diste ya que ahí aparece algo parecido a una consola y no los reconoce.

-y puse  el comando "glxinfo" en el mismo lugar y dice: unable to recognize o algo similar  

Alguna otra idea??

Gracias!!!

+1
0
-1
Imagen de oscarm
+1
0
-1

¿Tienes instalado otro gestor de ventanas mediante el que puedas entrar en una sesión sin cargar compiz fusion y probar lo que te comentamos?

 Saludos.

+1
0
-1
Imagen de gakna
+1
0
-1

Ahora logré entrar, desinstalé compiz fusion (me voy a abstener mientras sea tan nuevo en esto) y  puse beryl  de nuevo (igual  cuando activo Beryl la pantalla se pone blanca, pero en el icon del rubi puedo elegir que esté Metacity como gestor de ventanas y con eso funciona bien, el tema es que cuando se inicia ubuntu y abro una ventana, esta no tiene bordes, tengo que clickear en beryl y luego elegir metacity y funciona). La cuestión es que hice lo que me dijiste: puse glxinfo en la terminal y apareció esto:

 

X Error of failed request:  GLXBadContext
  Major opcode of failed request:  142 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  17
  Current serial number in output stream:  17

 

alguna idea?? y de como hacer que el gestor de ventanas funcione bien desde el inicio?? Te agradezco mucho tu ayuda!!! 

 

+1
0
-1
Imagen de lorddeus
+1
0
-1

No entiendo porque tienes puesto que se ejecute beryl si despues lo cambias a metacity, elimina las entradas que ejecutan beryl al inicio, sino otra solucion rapida es crear un usuario nuevo (con permisos de administrador) y volver a empezar

Yo al principio cuando empece a jugar con compiz y beryl creaba un usuario limpio para cuando llegara el momento en que todo reventaba.

Quizas tu tarjeta no soporta xgl, un saludo...

 

+1
0
-1
Imagen de oscarm
+1
0
-1

Sigo pensando que me parece que es de la configuración de la tarjeta gráfica. Al iniciar beryl y luego elegir metacity realmente no haces nada, ya que desactivas los efectos 3D, por eso funciona. ¿Funcionaba beryl antes? Si es así, vuelve a configurar la gráfica como lo hiciste al principio. Y si quieres instalar compiz fusion de nuevo ten en cuenta que has de actualizar emerald, pues si no vas a tener problemas. Por cierto, puedes tener beryl y compiz fusion instalados juntos sin ningún problema, sólo que al inicio de sesión no se deben ejecutar ambos, sino uno de ellos sólamente.

Insisto, sin tener demasiados datos, en que revises la configuración de la tarjeta, que por cierto, ¿cual es?

Saludos. 

+1
0
-1
Imagen de gakna
+1
0
-1

Perdón que sea tan inexperto, pero...como se revisa la configuración de la tarjeta???

+1
0
-1
Imagen de oscarm
+1
0
-1

No te preocupes, absolutamente todo el mundo la primera vez que lo hizo no sabía.

¿Tienes tarjeta ATI, Nvidia...? ¿Has seguido algún tutorial de Beryl, me refiero a si has descargado e instalado el driver de la tarjeta gráfica?  En la web de Compiz Fusion tienes tutoriales según tu tarjeta:

Nvdia: http://compiz.org/NVidia

ATI: http://compiz.org/ATI

Intel: http://compiz.org/Intel

Instalación de Compiz en Ubuntu: http://compiz.org/Ubuntu_Installation_Guide 

Sigue las instrucciones, y si tienes problemas ya sabes... siempre habrá alguien por aquí...

Saludos. 

+1
0
-1
Imagen de gakna
+1
0
-1

Aparentemente, mi tarjeta que es una ATI radeon 9250 128mb, usa los drivers libres. Tengo compiz instalado pero los efectos no funcionan.

Cuando pongo:

glxinfo | grep direct

 

Aparece: 

X Error of failed request:  GLXBadContext
  Major opcode of failed request:  142 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  17
  Current serial number in output stream:  17
 

Como se soluciona eso?? Alguna idea?? Gracias!! 

+1
0
-1
Imagen de gakna
+1
0
-1

Leyendo en el foro sobre el problema de la aceleracion 3D con la ATI Radeon 9250 en Ubuntu, llegue a una guia que habla de un bug en relacion a esta placa. Estoy intentando solucionarlo siguiendo ese tutorial pero no entiendo lo siguiente:

Instruction

In a new empty directory (our build directory) run:

$ apt-get source xserver-xorg-driver-ati

This downloads three files and unpacks the sources into the directory xserver-xorg-driver-ati-version. In this directory is the file src/radeon_bios.c, that we need to edit. Towards the end of this file is a comment saying:

        /* revision 4 has some problem as it appears in RV280,
comment it off for now, use default instead */

And after this comment follows a code block that has been commented out. We need to re-enable this code by removind the commenting-out. In my case deleting lines 574 and 561 did the job.

Lo que no se es como ir al directorio xserver-xorg-driver-ati-version para luego modificar el file que mencionan (src/radeon_bios.c.). Que comandos tengo que ejecutar en la consola para llevar a cabo lo que dice el tutorial??

Gracias!! 

+1
0
-1
Imagen de oscarm
+1
0
-1

Todo lo que estás diciendo es referente a los drivers libres, ¿verdad?.

¿Has probado los drivers propietarios de la página de ATI? Te dejo el enlace y si quieres baja el de la Radeon 9250 e instálalo.

http://ati.de/support/driver-sp.html

Saludos. 

+1
0
-1
Imagen de pemeru
+1
0
-1

Hola, yo también soy nuevo y hoy precisamente me ha pasado lo mismo, tengo el Ubuntu 7.04 y al intentar instalar el compiz y reiniciar el sistema se me ha quedado la pantalla en negro, pero sin mas, ni iconos ni menus…completamente negra, y también he pensado en reinstalar el ubuntu, pero no se como hacerlo, tengo un arranque dual con Vista, alguna sugerencia?? Gracias y un saludo.

+1
0
-1
Imagen de gakna
+1
0
-1

Mirá, no se demasiado, pero yo lo que hice es entrar en recovery mode (la segunda opción cuando te ofrece elegir) y ahí te aparece una terminal y anotás:

sudo dpkg-reconfigure -phigh xserver-xorg (acá si te da opciones poné todo como te va saliendo)

y luego:

sudo reboot

y fijate si entrás de nuevo al escritorio.

El tema con el compiz es que necesitas una buena aceleración 3D para que funcione y esta a veces está desactivada, o no tenés el driver adecuado, etc, depende de la tarjeta que tengas. En todo caso, una vez que entres, abrí una terminal y poné:

glxinfo

si en la parte que dice: direct rendering dice YES es que lo tenés activado, si dice otra cosa es que no está activada la aceleración 3D, entonces buscá como hacerlo según que placa tengas y LUEGO, cuando tengas la acelaración activada (direct rendering YES!!), pensá recién en poner Compiz :) saludos y avisame como te funcionó.

 

+1
0
-1
Imagen de gakna
+1
0
-1

Mirá, no se demasiado, pero yo lo que hice es entrar en recovery mode (la segunda opción cuando te ofrece elegir) y ahí te aparece una terminal donde ingresar un comando y anotás:

sudo dpkg-reconfigure -phigh xserver-xorg

(acá si te da opciones poné todo como te va saliendo)

y luego:

sudo reboot

y fijate si entrás de nuevo al escritorio.

El tema con el compiz es que necesitas una buena aceleración 3D para que funcione y esta a veces está desactivada, o no tenés el driver adecuado, etc, depende de la tarjeta que tengas. En todo caso, una vez que entres, abrí una terminal y poné:

glxinfo

si en la parte que dice: direct rendering dice YES es que lo tenés activado, si dice otra cosa es que no está activada la aceleración 3D, entonces buscá como hacerlo según que placa tengas y LUEGO, cuando tengas la acelaración activada (direct rendering YES!!), pensá recién en poner Compiz :) saludos y avisame como te funcionó.

 

+1
0
-1
Imagen de pemeru
+1
0
-1

Gracias por tu interés, pero lo he intentado de esa forma y sigue igual, pero alguien sabe como puedo reinstalar el ubuntu en esa partición sin perder el vista en la otra partición ni el arranque dual??, gracias

+1
0
-1
Imagen de oscarm
+1
0
-1

Antes de reinstalar nada, ¿por qué no pruebas a desinstalar compiz?.  En un terminal escribe: "sudo apt-get remove compiz".

Saludos. 

+1
0
-1
Imagen de gakna
+1
0
-1

Una pregunta oscarm, como se actualiza emerald??

Gracias! 

+1
0
-1
Imagen de oscarm
+1
0
-1

Depende de la versión que tengas instalada y de los repositorios. Yo tengo la 0.5.2 y con el repositorio de Treviño. Para ello añadí las siguientes líneas al archivo /etc/apt/sources.list:

# Repositorio de Treviño para Feisty Fawn (GPG key: 81836EBF - DD800CD9)
# Para mas informacion: http://3v1n0.tuxfamily.org
deb http://download.tuxfamily.org/3v1deb feisty eyecandy
deb-src http://download.tuxfamily.org/3v1deb feisty eyecandy

Ejecutas sudo apt-get update y sudo apt-get upgrade o bien lo haces con tu gestor de software favorito. En mi caso lo hago con Adept Manager, ya que uso KDE.

Espero serte de ayuda. Por cierto, ¿qué tal te va con la configuración de la tarjeta gráfica?

+1
0
-1
Imagen de pemeru
+1
0
-1

Hola Oscar, este link son los pasos que seguí antes de gag...

http://www.guia-ubuntu.org/index.php?title=Xgl_y_Beryl

Y en esta parte, creo que la cag...

"No te preocupes cuando te pregunte si quieres eliminar ubuntu-desktop, es un meta-paquete y desinstalarlo no romperá tu sistema"

Pero voy a probar lo que me comentas, ahora estoy en el curro, pero cuando llegue a casa lo pruebo y te comento, gracias y un saludo desde Menorca.

+1
0
-1
Imagen de pemeru
+1
0
-1

Por fin..... explico por si alguno tiene lo mismo

 He desinstalado el compiz como me ha indicado Oscar, supongo que algo ha hecho, pero la pantalla seguía negra, luego he hejecutado desde la cónsola el comando "dpk-reconfigure xserver-xorg", luego le he cambiado la tarjeta de video de "nvidia" a "NV" (mi tarjeta es la nvidia), luego he ejecutado "sudo rebbot", lo he reiniciado y ya ta.

No se por que, supongo que la opción "NV" es mejor que la de "nvidia" de la gráfica.

Muchas gracias a tot@s por la ayuda, que gran invento lo de los foros...hasta la próxima duda, que por lo que veo será pronto, jejeje.

+1
0
-1
Imagen de gakna
+1
0
-1

Como reconfiguro la tarjeta gráfica? tengo una ati radeon 9250...intenté poner los drivers propietarios y nada....

Cuando miro en el xserver-xorg aparece la tarjeta genérica Vesa...

ya estoy desesperando, la verdad es que en Windows funciona...no? 

 

+1
0
-1
Imagen de oscarm
+1
0
-1

La verdad es que las tarjetas ATI son un coñazo. Me alegro mucho de haber elegido una NVDIA...

Una vez probé un live CD de una distribución que tenía compiz ya incluido. Lo probé en un ordenador con tarjeta ATI y utiliza el driver radeon, que no es precisamente una maravilla. Existen dos distribuciones de este tipo (que yo conozca, seguro que hay muchas más...), que son trisquel y kororaa. Quizás si tienes oportunidad puedes bajar una y probar así si tu tarjeta funciona. Una vez que sepas si vale o no, decides si seguir rompiéndote los cuernos para configurarla.

Siento no poder ayudarte más.

Un saludo.

+1
0
-1
Imagen de oscarm
+1
0
-1

¿Has visto este post?

http://www.ubuntu-es.org/index.php?q=node/58939

Saludos. 

+1
0
-1
Imagen de gakna
+1
0
-1

Oscar, te pregunto a ti porque me has ayudado mucho. Disculpa que sea tan pesado :) resulta que finalmente logré reconfigurar mi ATI y tener aceleración 3D. El tema es que instalé compiz fusion y funcionaba. Luego instalé los plugins no oficiales: "compiz-fusion-plugins-unofficial" para poder ver los efectos 3D que no me funcionaron por lo que los desactivé en el Compiz Manager. Luego, envalentonado instale unos temas de escritorio para cambiarle la apariencia (T-ish for Clearlooks y OSX iconset, y un fondo de pantalla y descargué un theme de iconos: Innex que no instalé). Ubuntu funcionaba bien. Al día siguiente al intentar prender la computadora veía la barra de ubuntu y luego...negro, la nada...no ingresaba al entorno gráfico. Entré en modo recovery y puse: "sudo /etc/init.d/gdm restart" y logré entrar. Al iniciarse me mostró un error: "Failed to initialize HAL", pero por lo demás todo funcionaba, inclusive compiz fusion. Apagué nuevamente la computadora y nuevamente no pude entrar, pero esta vez, al intentar nuevamente desde el modo recovery el comando "sudo /etc/init.d/gdm restart" no funcionó, tampoco reconfigurar el xorg.org, ni nada, no consigo entrar al entorno gráfico. Alguna idea??? ya busqué bastante en el foro y google pero no encuentro nada. Muchas gracias :)

+1
0
-1
Imagen de oscarm
+1
0
-1

Hola. Bueno, muchas ideas no se me ocurren, así que tendrás que probar varias cosas. En primer lugar yo probaría a reconfigurar gdm. En una consola pon "sudo dpkg-reconfigure gdm". Si no puedes entrar al entorno gráfico, cuando veas la pantalla en negro presiona "Ctrl+Alt +F1", ó "Ctrl+Alt +F2". Verás una pantalla en que se te pide usuario y contraseña. Inicias sesión y tecleas lo que te comenté. Luego ejecutas "startx" y pruebas si funciona, ya que así debería arrancar el entorno gráfico, y si no, reinicia.

Si no funcionase, otra cosa es probar a instalar kdm o xdm en lugar de gdm. Si tienes internet configurado desde el arranque desde la consola puedes probarlo, haciendo:

"sudo apt-get install kdm"

"sudo apt-get install xdm"

"sudo apt-get remove gdm"

Por ciert, ¿usas gnome o kde? Si usas kde deberás ejecutar startkde en lugar de startx.

No se me ocurren muchas más cosas. Espero serte de ayuda.

Un saludo.

+1
0
-1
Imagen de exodus_mx
+1
0
-1

Ami me gustaria que me ayudaran con el Compiz a veces las ventanas, se aparecen blancas o negras, eso a que se deve, mas memoria o como lo puedo solucionar, alguien que le haya pasado lo mismo y que lo haya solucionado, mi tarjeta es una nvidia 6150

La tengo bien configurada y la aceleracion grafica esta activada, los efectos se ven bonitos solo me aparece ese pequenio detalle que me gustaria corregirlo de las ventanas blancas o negras a veces

+1
0
-1
Imagen de oscarm
+1
0
-1

Realizando una búsqueda en Google con las palabras "compiz fusion + nvidia 6100 + ventanas negras", se obtiene la solución, que en este caso es varios enlaces a páginas donde en general se comentan los posibles problemas de beryl y/o compiz y sus posibles soluciones. En tu caso aparece la solución en:

http://www.gskbyte.net/12/2006/informatica/software-librelinux/beryl/res...

Habla de un posible error en el controlador de Nvidia, que por cierto se ha publicado un post anunciando una nueva versión del mismo

http://www.ubuntu-spain.org/?q=node/109

Te sugiero que este enlace lo leas completo pues en la parte final viene un método de instalación más sencillo que el primero que se expone.

Saludos.

+1
0
-1