problema con Broadcom 4318

Imagen de pausidelia
0 puntos

Hola tengo un compaq presario v6000 y tengo una tarjeta broadcom 4318 y no puedo navegar por internet. He visto que hay gente que tiene el mismo problema que yo.Una de las soluciones que vi en un post era que hiciera:

sudo apt-get install bcm43xx-fwcutter.

Yo lo he hecho,pero me sale lo siguiente en la conso

------------ 

Leyendo lista de paquetes... Hecho

Creando árbol de dependencias      
Leyendo información de estado... Hecho
E: El paquete bcm43xx-firmware necesita ser reinstalado, pero no se encuentra un archivo para éste.
la:

-----------------

¿Como se reinstala un paquete?  o como soluciono esto,porque me pongo a instalar cualquier otro paquete y me sale el mismo mensaje.

Por favor ayudarme....soy novata en linux y me gustaria poder configurar la wi-fi.

GRACIAS!! 

 

Imagen de gotxa
+1
0
-1

Hola pausidelia

la documentación oficial de lo que buscas está aquí:
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty

MUY IMPORTANTE: supongo que tienes Ubuntu Feisty (versión 7.04) porque si no es así las instrucciones son _distintas_. No sigas adelante si no es así.

Te resumo... 

Dice que para poner en funcionamiento la tarjeta con ese chipset Broadcom hay 2 formas: con ndiswrapper (un método para utilizar los drivers windozeros en linux) o con el driver incluido en el kernel. Tu sigues la segunda forma. Bien, a mi me gusta más también.

Dice que aunque se utilice el driver nativo ya incluido en el kernel hay que extraer el firmware (las instrucciones que se le dan a los chips de la tarjeta para que hagan lo que los fabricantes quieren que haga). Eso se hace con el fwcutter, es lo que has hecho y posteado aquí. Vale, retomamos el asunto desde este punto ¿ok?

NOTA antes de empezar: no puedes tener Synaptic abierto si quieres hacer dpkg/apt-get/aptitude desde consola... sólo se permite 1 gestor de paquetes funcionando a la vez. Tranqui que no se va a romper, si lo intentas, tu pingüino se quejará de eso y te lo dirá claramente.

1. 

Dice esta guía que hay que habilitar los repositorios Universe. ¿Está hecho? (Abre Synaptic, menu "configuración"--->"repositorios", pestaña "software ubuntu", chequeas la opción de "universe")

Si haces esto, recarga la info de los nuevos repositorios desde el botón "recargar" de Synaptic. Eso es lo mismo que hacer desde consola '$ sudo apt-get update'. 

Seguramente este punto 1 ya lo tengas hecho. Okis. Pero por si acaso...

2.

Seguimos la guia. Dice que cuando hagas ahora

$ sudo apt-get install bcm43xx-fwcutter

te preguntará que si te bajas el firmware a lo que contestas que "yes".

Si no te lo pregunta, dice que sigas las instrucciones de:
http://ubuntu.cafuego.net/dists/feisty-cafuego/bcm43xx/
que consisten en añadir unos repositorios a /etc/apt/sources.list que sí tienen el paquete de firmware. Es muy sencillo hacerlo y se puede hacer desde el mismo diálogo de los repositorios, en Synaptic, pero en la pestaña "software de otros proveedores". Añades las 2 lineas de repositorios que te dice esta página, aceptas los cambios y de nuevo botón de "recargar" de Synaptic.

Ahora sí puedes instalar el paquete de firmware ese. Vía consola con '$ sudo apt-get install blablabla' o vía visual con ventanas, que es lo mismo: puedes encontrarlo e instalarlo desde el propio Synaptic con el botón "buscar" haciéndo una busqueda de "bcm43" (te saldrá todo lo relacionado con esas letras), botón derecho sobre el paquete e instalar o doble click al paquete -del synaptic, ejem...-, aplicas. 

3.

Ya casi lo tienes, pones el módulo en funcionamiento:

$ sudo modprobe bcm43xx

ahora ya debes tener wifi.

Para comprobar pones:

$ iwlist scanning

con esto te dirá qué interfaz de red es la wifi y qué redes encuentra. Cantas bingo y te llevas el bote si has llegado hasta aquí sin errores y además ves la red que quieres.

4. 

Es de suponer que el módulo se cargará ya en cada inicio así que no es necesario más cosas. Y ya sólo queda configurar a gusto para la red wireless que quieres usar. Quizá prefieras configurar la red desde las herramientas de Gnome y no vía terminal... entonces reinicia para (1) comprobar que tienes wifi en el reinicio y (2) para que Gnome sepa de ella en el administrador de red.

Saludos, espero que sirva. Nos leemos por los foros. 

Por un pingüino microondulatorio
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de gotxa
+1
0
-1

Hola de nuevo,
dices "me pongo a instalar cualquier otro paquete y me sale el mismo mensaje". Si se sigue quejando y por culpa de eso no puedes seguir las instrucciones anteriores, nos lo dices y resolvemos el asunto(*). Recuerda decirnos si tienes Ubuntu Feisty o no.

(*)en realidad es ir al punto 2 y añadir ese par de repositorios extra, después recargar la info de nuevos paquetes y decirle que instale ese firmware sí o sí y que no te vacile más que tu le respetas a él xD

GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de Samarkanda
+1
0
-1

Buenas tardes, te escribo porque tengo el mismo problema. Intento hace lo que comentas de entrar a Synaptic, pero me da el mismo error de que el paquete bcm43xx-firmaware debe ser reinstalado.

Yo uso Ubuntu 7.04 (nada de Feisty, que para ser sincero, no se ni lo que es, acabo de empezar con Ubuntu hace un par de días y antes de trastearlo más, me gustaría solucionar antes lo del Wifi).

 

Muchisimas gracias de antemano, un saludo.

+1
0
-1

Aprendiendo cada día algo nuevo sobre Linux, no hay día que no me asombre de alguna manera.

Imagen de jarchila
+1
0
-1

Sinceramente yo tampoco se que hice, pero segui el tutorial al pie de la letra y la wifi me funciona de maravilla. 

buen tutorial hasta con video 

http://www.ubuntu.cymaho.com/category/wireless/

 

Saludos 

+1
0
-1
Imagen de Samarkanda
+1
0
-1

Te doy las gracias por tu respuesta, lo que ocurre que ya seguí ese manual una vez y no me funcionó. Por eso quiero probar con los drivers (no se si se llaman drivers nativos ) pero claro, no me deja instalarlos.

 

Despues de hacer los pasos de la guía que me dice el compañero jarchilla, los deshice con la intención de no tener instalado ni el ndiswrapper, ni nada de lo que dice que hay que hacer después. Creo que logré dejar como estaba

 

Luego intenté instalar los drivers bcm43xx-firmware_1.3-1ubuntu2_all.deb, y fué entonces cuando me dió el error de que no se puede instala, que hace falta reinstalar bcm43xx-firmware.

 

¿Alguna idea al respecto?

 

P.D.: Otra cosilla, ¿dónde puedo sacar un manual ó listado de todos los comandos que se usan en la consola, y sus funciones? 

+1
0
-1

Aprendiendo cada día algo nuevo sobre Linux, no hay día que no me asombre de alguna manera.

Imagen de Samarkanda
+1
0
-1

Bueno, ya he conseguido solucionar lo del error que me pedia reinstalar el bcm43xx-firmware, y ya no me sale el iconito que me avisaba constantemente del error en la barra de la hora.

El problema era que al haber instalado anteriormente el ndiswrapper con el driver de windows, desinstale luego el ndiswrapper, pero no el driver, y por lo visto no pueden convivir juntos.

Para desinstalar ese driver, hay que tener instalado el ndiswrapper, y en modo consola tecleamos lo siguiente:

sudo ndiswrapper -l

y nos dice el si el driver está instalado y el nombre, luego para desinstalarlo:

sudo ndiswrapper -e <Nombre del Driver> 

Ahora estoy instalando el bcm43xx-firmware_1.3-1ubuntu2_all.deb, el cual lleva ya unos minutos procesando, a ver si esta vez lo consigo solucionar.

 

P.D.: Si me he confundido con algún comando coregirme por favor.

+1
0
-1

Aprendiendo cada día algo nuevo sobre Linux, no hay día que no me asombre de alguna manera.

Imagen de pausidelia
+1
0
-1

Hola , si tengo ubuntu feisty. meterme en sypnatic me da un error que dice lo siguiente:

E: el paquete bcm43xx necesita ser reinstalado,pero no se encuentra archivo para éste.

E:error interno al abrir el caché(1). Por favor informe de este error.

lo mismo que al hacer me sudo apt-get install aptitude me sale el primer mensaje.

Veo esto muy chungo, y no se que hacer..

 

+1
0
-1

Delia

Imagen de gotxa
+1
0
-1

Hola,
bueno, vamos a intentar arreglar el problemilla. Se trata de instalar el firmware para que deje de quejarse... se me ocurre un método que no creo que falle (instalar el .deb a pelo), pero es mejor hacerlo desde los repositorios, así obtienes los beneficios de las actualizaciones.

$ sudo gedit /etc/apt/sources.list 

(con esto editas como root con gedit el archivo sources.list). Te vas al final y añades estas líneas:

# para que funcione la wifi (https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty)
# instala el firmware
deb http://ubuntu.cafuego.net feisty-cafuego bcm43xx
deb-src http://ubuntu.cafuego.net feisty-cafuego bcm43xx 

salvas el archivo y sales de gedit.

Ahora recargas info de los repositorios nuevos:

$ sudo apt-get update 

Y actualizas

$ sudo apt-get upgrade

Si todo va bien, en el upgrade te dirá "¿instalo el firmware?" a lo que tu le dices "yes". Esto no lo se seguro, no me ha pasado nunca, pero lo supongo porque ya sabrá de dónde instalarlo.

Si sigue erre que erre con el error, después del upgrade le dices:

$ sudo apt-get --fix-broken install bcm43xx-firmware

Con esto debería bastar para que se instalara el paquetico y se callara la boca.

Si ni con esas te deja, desinstala el paquete problemático (que no es el del firmware, sino el que lo necesita):

$ sudo dpkg --remove bcm43xx-fwcutter

y ahora lo instalamos como debe ser:

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install bcm43xx-fwcutter bcm43xx-firmware

 

Y si ni con esas, posteas y te digo cómo no debe fallar. Espero que no haya que llegar hasta aquí.

Suertes varias 

GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de Samarkanda
+1
0
-1

Si ayer posteé que se me solucionó el problema de "tal" manera, cuál es mi sorpresa cuando esta mañana al encender otra vez el portatil, seguía dándome el problemilla de que tenía mal instalado el bcm43xx-firmware.

He seguido estos últimos pasos que nos das, he añadido esas líneas en el sources.list, y al hacer $sudo apt-get update me sale esto al final:

 

 


Ign http://ubuntu.cafuego.net feisty-cafuego Release
Obj http://ubuntu.cafuego.net feisty-cafuego/bcm43xx Packages
Obj http://ubuntu.cafuego.net feisty-cafuego/bcm43xx Sources
Descargados 39,8kB en 1s (22,5kB/s)
Leyendo lista de paquetes... Hecho
W: GPG error: http://ubuntu.cafuego.net feisty-cafuego Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 580E2519969F3F57
W: Tal vez quiera ejecutar 'apt-get update' para corregir estos problemas

Me he estado informado mejor (que es lo que tendría que haber hecho antes ) y bueno, he estado leyendo que Ubuntu se llama Ubuntu Feisty, por lo que sí, tengo Ubuntu Feisty

Bueno, aunque me da ese error al hacer el update, sigo con con el upgrade, y sí me pregunta si quiero actualizar el bcm43xx-firmware.

 

La faenilla es que ahora mismo no puedo probar el wifi, ya que no tengo ninguna red al alcance, pero al menos no me da ningún tipo de error de que haga falta reinstalar nada.

 En cuanto lo haya podido probar os cuento.

 

Y muchísimas gracias por todo gotxa

+1
0
-1

Aprendiendo cada día algo nuevo sobre Linux, no hay día que no me asombre de alguna manera.

Imagen de livory
+1
0
-1

 Gracias de verdad,

hacìa varios días que estaba peleando con este problema, soy nuevo en Ubuntu, y me estaba volviendo loco.

Así que les digo a todos, que sigan los pasos que describiste en este post...no falla.

 

De nuevo gracias!!! 

LíVoRy.-

+1
0
-1

LíVoRy.-

Imagen de pausidelia
+1
0
-1

Muchas gracias por todo Gotxa.

He seguido los pasos que has indicado y   se ha solucionado el problema. Y la wifi funciona...!!!!!

 

muchas gracias  :-) 

+1
0
-1

Delia