Como consigo la fuentes exactas de mi Kernel?

Imagen de falconer007
0 puntos

Hola a todos, acabio de instalar Ubuntu 7.04 Server... pero necesito las fuentes del kernel. Por lo que tenia entendido bastaba con hacer un apt-get update y luego apt-get install linux-sources.

Pero el problema es que cuando pongo apt-cache search linux-sources aparece una lista:
xen-source-2.6.16
linux-source
linux-source-2.6.20

Y cuando pongo uname -a en mi sistema, muestra que mi kernel es: 2.6.20-15-server

Por lo que no se cual deberia instalar. Por lo que a mi respecta creo que ninguna es la adecuada, ya que deberia haber una linux-source-2.6.20-15-server, pero no estoy seguro. Si estoy en lo correcto, como puedo hacer que encuentre tales fuentes?, habra que modificar/habilitar algo en /etc/apt/sources.list ?

Espero que puedan ayudarme, muchas gracias. 

 

 

Imagen de MarianoC
+1
0
-1

El que tenes que instalar es linux-source-2.6.20
Ya que ahi estan las fuentes del kernel, o sea independientemente de la optimizacion que tenga, en tu caso "server".
El -15 o .15 es solo una pequeña actualizacion de seguridad o programacion, por eso no hay un codigo fuente exacto para cada version (seria infinita la lista)
El que tenes que bajar como te dije antes es el 2.6.20
Para que necesitas el codigo?? vas a copilarlo??

Saludos!!

+1
0
-1
Imagen de falconer007
+1
0
-1

Necesito instalar un programa que crea un modulo dependiente del SO y me pide las fuentes, ni siquiera me sirven los headers. El problema que cuando la version no es la misma, me suele dar un error con vermagic o algo asi, al tratar de insertar el modulo que creo. Crees que funcionara y no habra problema de versiones?, o tendre que compilar las fuentes que baje e insertar el modulo a mano?

 Muchas gracias.

+1
0
-1
Imagen de MarianoC
+1
0
-1

Con esa version no tendrias que tener ningun problema, proba y fijate, total nada malo puede pasar...Cual es exactamente el programa?? Asi pruebo instalarlo yo y te digo...
Si te llega a dar algun error pone exactamente cual es asi vemos que puede estar pasando.

Saludos!

+1
0
-1
Imagen de falconer007
+1
0
-1

mmm no he podido ver si tengo problemas o no... el maldito programa no me permite hacer make... me da errores. Esto algunas veces me paso pero se solucionaba con un kernel mas antiguo, estoy usando el 2.6.20. Sabes alguna forma de poner algun respositorio que  me permita instalar kernels mas antiguos, es decir que cuando haga apt-cache searh linux-kernel aparezcan?

Y ciertamente que no sean de kernel.org, porque necesito que vengan parcheados con ubuntu.  Te agradecería muchisimo esa info.

PD: El programa se llama Sebek, en palabras re simples es como un keylogger pero usado comunmente en Honeypots (mi caso).

 

+1
0
-1