Conseguir Kernel menores a 2.6.20

Imagen de falconer007
0 puntos

Alguien sabe alguna forma (o repositorio) de conseguir kernel antiguos para Ubuntu, osea no tan antiguos algo como el 2.6.15 o 2.6.14. Utilizo Ubuntu 2.6.20 Server, pero tengo algunos errores al compilar un modulo por lo que necesito la forma de hacer algo como un apt-get install linux-source-2.6.15. Podria bajarlo de kernel.org pero necesito que este parcheado con los parches de Ubuntu. Espero que pueden ayduarme, muchas gracias.

Imagen de letex
+1
0
-1

   Lo que pasa es que apt-get te dará siempre la última versión del kernel, o al menos las que estén en los repositorios de tu versión, y la 2.6.15 o .14 son de Ubuntu anteriores.

    Cuando quieres buscar un paquete antiguo, puedes ir a http://packages.ubuntu.com/ , la página oficial de ubuntu de descarga de paquetes .deb, para todas las versiones. (lo tienes enl os buscadores del firefox)

     Si en el buscador de abajo pones lo que buscas y, en este caso, seleccionas como versión dapper, tendrás justo este resultado: lo que buscabas, y con los parches de Ubuntu aplicados!! 

   Un saludo y espero que te sirva de ayuda. En la u?tima de las páginas te salen en rojo las dependendias requeridas y en verde las recomendadas.

    Ciao!!

Ubuntu user number # 12793

Linux user number # 444511

+1
0
-1
Imagen de falconer007
+1
0
-1

Muchas gracias, funcionó.

+1
0
-1