Cambiar resolución de pantalla

Imagen de darkvillano
0 puntos

TENGO EL UBUNTU 7.04,

MI PROBLEMA ES LA RESOLUCION DE PANTALLA QUE ES DE 800X600 Y QUE DE ANTES ERA DE 1024 X 7... NO SE PORQUE SE CAMBIO ESTABA TODO BIEN DE ANTES, PUES LO INTENTO CAMBIAR PERO SOLO AY DISPONIBLES EL DE

800X600 Y EL DE 640X480 COMO MENCIONE ANTES ESTABA DE 1024 Y YA NO HAY ESA OPCION.

TENGO EL WINDOWS XP Y EL UBUNTU, EN XP SI LO PUEDO CAMBIAR, Y EN UBUNTU AHORA NO, ESTABA TODO PERFECTO ANTES, YA LLEVO COMO 2 SEMANAS CON ESTE PROBLEMA.

POR FAVOR LE AGRADECERIA SI ALGUIEN ME AYUDA. GRACIAS.

PD: CON UBUNTU LLEVO UNOS 4 MESES.

Imagen de furtaxi
+1
0
-1

Pero no nos cuentas que tarjeta de vídeo tienes, y como la configuraste..

Claro, imagino que la luz del Caps Lock te ha deslumbrado :) (las Normas, que hay que leerlas...y aplicarlas)

Otra opción , es reconfigurar las X, pero necesitamos algún dato más para orientarte mejor.

De momento, teclea glxinfo  en una consola y pega el resultado aquí. Y lo del lspci, también vendría bien, las últimas tres líneas son las importantes.

Saludos,

Roberto.

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar. Sé amable, tolerante y comprensivo. Disfruta. Sonríe. Ubuntu es más que un S.O.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de darkvillano
+1
0
-1

...:|:DarKviLLaNo:|:...

ESTE ES EL RESULTADO AL PONER EL COMANDO POR SIERTO LA TARJETA DE VIDEO PUES ESTA INTEGRADA CON LA TARJETA MADRE CREO. YA INTENTE EDITAR EL XORG PERO ALLI SI APARECE LA RESOLUCION DE 1024X7... Y TAMBIEN 800X600  640X480

CUANDO INSTALE EL UBUNTU ESTABA COMO 1024X7... Y  ACE COMO 2 SEMANAS SE CAMBIO A 800X600.

Y YA USE EL BUSCADOR Y E ENCONTRADO VARIOS PROBLEMAS COMO EL MIO DONDE DICE QUE EDITEN EL XORG AGREGARLE EL 1024X 7..

PERO EN EL MIO YA ESTA AGREGADO Y NO QUEDA. 

glxinfo:

name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_EXT_texture_from_pixmap
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_point_sprite,
    GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_non_power_of_two,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_vertex_program,
    GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_framebuffer_object, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_point_parameters,
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
    GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
    GL_ATI_draw_buffers, GL_ATI_texture_env_combine3,
    GL_ATI_texture_mirror_once, GL_ATIX_texture_env_combine3,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_NV_blend_square,
    GL_NV_fragment_program, GL_NV_light_max_exponent, GL_NV_point_sprite,
    GL_NV_texgen_reflection, GL_NV_texture_rectangle, GL_NV_vertex_program,
    GL_NV_vertex_program1_1, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
    GL_SGIX_shadow, GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x43 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon

 

lcpci:

 

00:00.0 Host bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia] (rev 05)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
00:0a.0 Modem: Motorola Unknown device 3052 (rev 04)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 6a)

 

+1
0
-1

...:|:DarKviLLaNo:|:...

Imagen de hugolino
+1
0
-1

EDIT: :@!!! se me cortó todo el post por poner el signo puesto a este ">"... :@!!!

había hecho una explicación detallada de esto, pero ahora se me fueron las ganas jeejej, mirá acá http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-config.html sobre cómo configurar correctamente el monitor

DEJÁ DE GRITAR

+1
0
-1
Imagen de carlos tico
+1
0
-1

A mi me paso algo muy parecido, la tarjeta madre es una Intel y si mal no me acuerdo al hacer una actualización de un pronto a otro solo me dejo la opcion de 640X480.

Al accesar las propiedades o configuración de pantalla aparecía correcto el modelo de la tarjeta de video.

Es raro, pero lo único que hice fué volver a seleccionar el driver correcto y no se porque funciono y no he vuelto a tener problemas.

 

+1
0
-1
Imagen de Obelix69
+1
0
-1

Hola!

 Yo tengo un problema semejante. Tengo una gráfica ATI Radeon 8500 128MB y un monitor Mitsubishi Diamon Pro NF720. Las únicas resoluciones que me admite mi Festy Fawn son 1024x768, 800x600 y 640x480 todas a una tasa de refresco de tan solo 61 HZ (el monitor da 85 a esa resolucion). ¿Qué he probado para solucionarlo?. Aconsejado por los diferentes hilos que hay con este problema:

 1.- Utilize el dpkg-reconfigure xorg-conf, pero como no conozco los valores de las frecuencias de refresco de mi monitor se me quedaba la pantalla negra sin mostrar el login o me daba error en la configuracion y me hacia entrar en modo texto.

2.- Cuando intento acceder al Gestor de controladores restringidos me dice "Su hardware no necesita controladores privativos" 

 

Lo curioso del caso es que con Dapper no tenía ningún problema porque me reconocía el solito el tipo de monitor y las frecuencias de refresco, cosa que no sucede con Festy Fawn.

 

De verdad que agradecería cualquier ayuda en este tema que me tiene un tanto desesperado

El contenido actual de mi xorg.conf es:

 

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
    FontPath    "/usr/share/fonts/X11/misc"
    FontPath    "/usr/share/fonts/X11/cyrillic"
    FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/Type1"
    FontPath    "/usr/share/fonts/X11/100dpi"
    FontPath    "/usr/share/fonts/X11/75dpi"
    # path to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load    "i2c"
    Load    "bitmap"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "es"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "ZAxisMapping"        "4 5"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "stylus"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "eraser"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "cursor"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "Device"
    Identifier    "Generic Video Card"
    Driver        "vesa"
    BusID        "PCI:2:0:0"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    28-51
    VertRefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Generic Video Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice     "stylus"    "SendCoreEvents"
    InputDevice     "cursor"    "SendCoreEvents"
    InputDevice     "eraser"    "SendCoreEvents"
EndSection

Section "DRI"
    Mode    0666
EndSection

+1
0
-1
Imagen de Javier M.
+1
0
-1

Las mayuuusculas, por favor.

Ocho semanas es tiempo suficiente para saber que no están permitidas.


 

+1
0
-1
Imagen de Dostoievski
+1
0
-1

Hola amigos del foro, yo queria contar mi experiencia:

Reinstale el Ubuntu 7.04 y tal como me sucedió la primera vez que lo instale al momento hacer la actualización que me pedía y reiniciarlo este se inició con una resolución de 800*600 (y antriormete habia estado funcionando super bien a 1024*768).

Como era de suponer me dirigí a la opción de Resolución de pantalla, sin embargo no teni más opciones de resolución que 800*600, busque ayuda en el foro y encontre este post.

Yo anduve buscando antes de llegar a esto algún problema con las tarjetas ATI (tengo la ATI Radeon X550), pero no encontré algo que realmente se ajustara o lo que yo ''pensaba'' podia estar cusando l problema como es un driver que no me soporta la esolucón (aun no se con certeza si fu eso, pero yo lo hice ami modo)

Ahora lo que te puede servir despuès de todo este palabrerio: Me diriji a SISTEMA>ADMINISTRACIÓN>GESTOR DE CONTROLADORES RESTRINGIDOS y ahí después de meter la contraseña me di cuenta que habia un controlador de la ATI bloqueado, pese a que me decia que "si se presentan problemas con el hardware por ser un controlador privativo no se podra ingresar al codigo de fuente para arreglar el error'' yo igual le di a ''habilitar'' y tomé el riesgo, después de instalarse reinicié, y ahora si estoy gozando de la rsolución de 1024*768.

Bueno camarada, espero que hayas solucionado tu problema de alguna u otra manera.

Un saludo desde Chile!

+1
0
-1
Imagen de enriquejrg
+1
0
-1

Gracias por tu comentario. Algo tan 'tonto' no me permitía aumentar la resolución a algo decente.

¡ Saludos!
 

+1
0
-1
Imagen de DDG05
+1
0
-1

Hola, yo tambien tenia el mismo problema. venia todo bien, hasta el momento que cambie el monitor Five-star por un Samsung y solo me inicio en 800x600. lo que hice fue abrir una consola y escribir  "sudo dpkg-reconfigure xserver-xorg". y elegi el driver VESA y puse los valores correctos de varrido horz/vert como tambien la resolucion. todo lo demas lo deje por defecto.

pero cuando intento leer el fichero de la configuracion (¿esta bien dicho?) con 

                /etc/X11/xorg.conf 

o tambien 

               /etc/X11/xserver.conf

me devuelve esto:

                /etc/X11/xorg.conf: command not found 

o tambien

                /etc/X11/xserver.conf: command not found

Ademas al intertar usar

                 glxinfo

me devuelve esto:

                 name of display: :0.0
                 X Error of failed request:  GLXBadContext
                 Major opcode of failed request:  142 (GLX)
                 Minor opcode of failed request:  5 (X_GLXMakeCurrent)
                 Serial number of failed request:  17
                 Current serial number in output stream:  17

sin ninguna info. por ultimo si uso

                 sudo Xorg -configure

me devuelve:

                  Fatal server error:
Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.

¿Hay algo que esta muy mal, no?
la verdad es que yo recien empiezo y trato de arreglarmelas solo pero en este punto no se por donde o que buscar. por lo menos ya estoy usando nuevamente 1024x768.

lo que se, segun "Informacion del Hardware" es que la placa de video es una MGA G200 AGP, on-board y aparentemente el mother es un Intel 440BX. La pc es una HP Brio PIII. 

espero sirva la info como para que alguien me oriente por donde encarar el problema.

muchas gracias desde ya.

 

+1
0
-1
Imagen de furtaxi
+1
0
-1

Si introduces una orden en una consola (terminal, shell, como quieras), ésta intenta obedecerla.

Pero, en éste caso, le estabas diciendo que ejecutara /etc/X11/xorg.conf , y claro, ésto no es un programa, sino un simple archivo de texto.

Para editarlo, debes usar, por ejemplo, gedit en modo gráfico, o nano en modo texto (cuando arrancas en "pantalla negra")

En éste caso particular, además, como es una orden que afecta al sistema, Ubuntu necesita permisos de root para actuar, así que hay que añadirle sudo.

En resumen:

sudo gedit /etc/X11/xorg.conf si te funciona el modo gráfico

sudo nano /etc/X11/xorg.conf si tuviste que arrancar en modo texto.

En ambos casos, te pedirá la contraseña, la misma que usas para entrar normalmente, y no verás aparecer las letras en el monitor, no vaya a ser que tengas un espía mirando por encima de tu cabeza para pillarte la pass... :)

Saludos,

Roberto.

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar.
Cuando visites un hilo, pulsa marcar para informar a los Moderadores de su relevancia.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de DDG05
+1
0
-1

ok, gracias. sabia que algo me estaba olvidando de poner en el comando. ¿Puede ser que poniendo "sudo cat" tambien funcione lo mismo que "nano" y "gedit"?

 justo antes de leer tu respuesta lei algo en google que no tenia nada que ve, pero vi que apaecia ese comando.

+1
0
-1
Imagen de furtaxi
+1
0
-1

 Es una orden para concatenar dos comandos, y enviar la salida a impresora.

Cuando desconozcas una orden, escribe en una consola:

man nombre del comando

En éste caso,

man cat

y tendrás para qué y como se usa. 

Saludos,

Roberto.

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar.
Cuando visites un hilo, pulsa marcar para informar a los Moderadores de su relevancia.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.