Windows Vista no arranca en Grub

Imagen de jucanbe
0 puntos

Tengo dos discos duros, uno de 200 Gigas (Master) en el cual tengo Linux, y otro de 100 Gb (Slave) en el cual tengo WIndows Vista, que me lo instale ayer.

 Por diversas circunstancias, tengo que instalar el maldito windows vista (si por mi fuera lo rompia), pero tampoco quiero desinstalar Linu, ya que es para mi muy utli, la cuestion es que cuando arranco el ordenador y me aparece el grub, Windows VIsta no aparece, probe a poner estas lineas,

 

title         "Windows Vista"
root         (hd0,0)
chainloader      +1

Por fin aparecio para elegirlo, y aqui es cuando no funciona, me sale

 

Error 13 invalid or unsupported executable format.

¿Alguien sabe como solucionar esto? 

 

 

Imagen de paquino25
+1
0
-1

Sinceramente no se si el consejo que te voy a dar te va a funcionar. Yo tengo windows y linux instalados. Al actualizar el kernel me modificó el grub y desapareció la entrada para windows. Lo que hice fue añadir lo siguiente:

title Microsoft Windows XP
root (hd0,0)
makeactive
chainloader +1

que es prácticamente lo mismo que tienes tu, salvo la línea que dice "makeactive". No se si será eso por lo que no te funciona, pero podrías probar a añadirla. Un saludo

+1
0
-1
Imagen de jucanbe
+1
0
-1

me sigue dando el mismo error

+1
0
-1
Imagen de c0kit0_2oo7
+1
0
-1

Prueba cambiando lo tuyo por esto... 

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title        Microsoft Windows Vista Home Premium
root        (hd0,0)
savedefault
makeactive
chainloader    +1

Salvo que si no tienes Sata... ponle hda1 donde dice sda1 

+1
0
-1

---------------------------------------------------------------------------
lestat@esdebian.org

Imagen de lyoncat
+1
0
-1

Como te comenta paquino, en mi menu.lst, solo hay la diferencia que menciona, pero segun creo, para que no tengas problemas de grub, etc. primero debes instalar el Vista, y a continuación Ubuntu.

Espero lo soluciones.

 

saludos 

+1
0
-1
Imagen de antoniojreyes
+1
0
-1

Tienes que instalar los ntfsprogs (>=1.13.1)

y hacer

sudo ntfsfix /dev/hdXx

donde hdXx es la partición en la que se encuentra el Vista.

 

Saludos. 

+1
0
-1

"El buscador" ese gran desconocido.
Imagen de bubinson
+1
0
-1

... lo he encontrado buscando por ahí

http://www.ubuntu-es.org/index.php?q=node/4288

Saludos

+1
0
-1
Imagen de Yolagp
+1
0
-1

Para reparar el grub lo más simple es ir aquí: http://supergrub.forjamari.linex.org/  y descargar la iso de supregrub, quemarla en un cd y reiniciar con el disco. Arregla el arranque de Linux o de Windows de una manera clara y segura.

Suerte.

YolaGP 

*****************************

Si no te equivocas de vez en cuando, es que no lo intentas.(Woody Allen, creo)

+1
0
-1
Imagen de adrian15
+1
0
-1

Con Super Grub Disk -> Windows -> Arrancar Windows desde 2º disco duro puedes hacer esto mismo de forma temporal.

Para hacerlo de forma permanente las lineas del menu.lst son:

 title windows 2o disco duro

map (hd0) (hd1)

map (hd1) (hd0)

rootnoverify (hd1,0)

chainloader +1

boot

 

 Alá, a "disfrutar" del Vista.

 

adrian15

+1
0
-1