Más de 1 disp.audio, pequeña gran solución

Imagen de bean
10 puntos

Son muchos los casos de ubunteros que tocan este tema.

Esta solución rige para el caso que aún metiendo mano en la Bios hayamos deshabilitado

el chip integrado de la MB y porfiadamente aparezca de nuevo instalada según nos diga alsamixer, o bien

queramos que funcione la integrada, la habilitemos y Feisty porfiadamente nos quiera hacer

funcionar la externa.

Propongo esta soluciòn:

1.- En alsamixer ver cual está funcionando

2.- En terminal para saber nombre verdadero de cada uno de nuestros dispositivos de sonido escribir

 

sudo cat /proc/asound/modules

 

3.- En terminal para ordenar que nuestra default sea la que queremos escribir

 

asoundconf set-default-cardla que quieras

 

(ojo sin espacio entre card y 0 o 1 o 2)

4.- Rebootear

5.- Modificar todos los parámetros de Feisty en Sistema Preferencias Sonido para alsa (dejar ALSA en todo y

marcar la tarjeta antes elegida)

6.- Modificar los parámetros del parlantito arriba a la derecha en preferencias con botón derecho

7.- Modificar los parámetros del parlantito arriba con botón izquierdo con doble click

8.- Adentro del parlantito en archivo en dispositivo marcar el que elegimos como default

9.- Adentro del parlantito en editar preferencias lo mismo

10.- Adentro del parlantito en conmutadores desactivar el output jack si apareciere dejando marcados

solo tone y external amplifier.

Si esto no funcionase solamente quedaría reconfigurar con

sudo dpkg-reconfigure alsa-base

Saludos.

Bean.