Aceleracion 3D Ati 2600 - Ubuntu 7.04

Imagen de jos3ba
0 puntos

Hola:

Soy nuevo en el mundo de ubuntu/linux, hace poco me compre una pc y decidi poner linux gracias a esta comparativa, el problema que tengo es con la placa de video que compre, no he podido hacer funcionar la aceleracion 3D.

He tenido que reinstalar varias veces a ubuntu, por que he instalado mal y al reiniciar no cargaba el entorno grafico y me salia una pantalla azul :(

En una oportunidad instale los driver propietarios de ati, al reiniciar me salia que no tenia el entorno 3D, al ir a la seccion de Controladores Restringidos, y hacer click en la seccion de habilitar me instalaba (no se que), y al reiniciar me salia la pantalla azul y pasaba a modo texto (pantalla negra, letras blancas)

He intentado con Envy, sin embargo me tira un error.

En esta ultima oportunidad he instalado de esta manera:

 

$ sudo sudo aptitude install linux-restricted-modules-`uname -r` xorg-driver-fglrx 

Luego segui los pasos de la guia ubuntu para Instalar los drivers privativos de ATI directamente, y al reiniciar la pc en la seccion de e Controladores Restringidos, tengo marcado Habilitado y estado En Uso,

Sin embargo al querer instalar Compiz Fusion (segun la guia) al llegar a este paso me salta este error :

 

seba@JoSeba:~$ compiz --replace
Fatal: Failed test: texture_from_pixmap support
Checks indicate that it's impossible to start compiz on your system.

Coloco en esta seccion, por que estoy seguro que instale mal algo de los driver de la placa de video,

Mi pc es:

MSI K9AGM2-FIH
ATI Radeon HD 2600 pro
AMD Athlon 64 4200+
2gb ddr2 667mhz
Western Digital 80gb

 

Gracias :) Seba

 

 

 

 

Imagen de TASADAR-F
+1
0
-1

Los unicos drivers que funcionan para tu tarjeta grafica son los nuevos que salieron hace 15 dias. Asi que si quieres que te funcione la aceleracion 3D tendras que bajarte los drivers de la web de ati.com e instalarlos manualmente (de momento en futuras versiones de ubuntu como la de abril del 2008 vendran de serie en el gestor de controladores para que los actives)

+1
0
-1
Imagen de jos3ba
+1
0
-1

Me olvide de este detalle, baje e instale los ultimos drivers de ATI v8.41.7 de 32bits, algo que me quedo en duda es si el procesador de 64 bits tiene algo que ver, ya que yo instale ubuntu 7.04 32 bits a igual que los drivers de ATI.

De todas maneras estoy esperando para que salga la version 7.10 de ubuntu, a ver si corro con mejor suerte con el soporte, en ese caso lo que tengo planeado hacer es:

- una ves que termine de instalar el Sistema operativo, es ir a la parte de controladores restringidos y hacer click ahi para que instale,

-luego instalar los driver de ATI v8.41.7, en este caso, esoty buscando la manera de pasar el .run a un .deb

 

Gracias :) Seba

+1
0
-1
Imagen de TASADAR-F
+1
0
-1

Despues de ejecutar el .run te crea los paquetes deb autimaticamte aunq tienes que hacer algun paso mas para conseguir la aceleracion aqui te dejo la guia.

https://help.ubuntu.com/community/BinaryDriverHowto/ATI#head-796aa4d6d04... 

 

+1
0
-1
Imagen de jorcajo
+1
0
-1

Hola Seba, por desgracia yo no sé contestarte, pero tengo un problema que pienso que tú pudiste tener, viendo la configuración de tu equipo: al instalar ubuntu con tu ATI la pantalla no se quedaba en negro durante el proceso? Qué hiciste, escribiste el comando noapic o algo por el estilo?

Gracias!

+1
0
-1
Imagen de jos3ba
+1
0
-1

en ningun momento me quedo negra la pantalla durante la instalacion, eso si, si por alguna razon se cambiaba la resolucion de la pantalla luego de la instalacion, y antes de instalar los driver de la placa, la pantalla quedaba en 16 colores, la verdad que de linux no se nada, hace 2 semanas que sali de winXP, asi que hay comandos que estoy aprendiendo y programas que no conosco.

La configuracion del la pantalla fue automatico durante la instalacion

 

Seba :) 

+1
0
-1
Imagen de trompeteandos
+1
0
-1

Tengo la misma grafica que tu , pero en un portatil y con los ultimos drivers propietarios de ati, la pantalla se me queda en negro tras el reinicio. Alguna solución?

+1
0
-1
Imagen de TASADAR-F
+1
0
-1

Hay varias cosas que puedes probar.

EN menos de 10 dias va a salir nueva version del fglrx que supongo que corregira errores en tu tarjeta ya que es muy nueva. YA esta disponible para que la gente lo pruebe "no lo han publicado de manera oficial" soporta aiglx ademas de corregir varios fallos.

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-dr... 

Puedes probar el driver "ati" o "vesa" para ver si tienes acceso en 2D

Hay un driver libre que esta implementando Novell gracias a las especificaciones de ati que es especial para las HD. 

+1
0
-1
Imagen de andres_alre
+1
0
-1

He puesto en este hilo mi periplo sin solución:

http://www.ubuntu-es.org/index.php?q=node/67475

 

He tenido los mismo problemas que vosotros, y ahora con la distro 7.10, me funciona el driver de ATI pero no la aceleración 3D... (o tengo la de Mesa 3D que no me da prestaciones...)

 En ese post tengo la configuración de mi xorg.conf, por si os sirve darle un vistazo para al menos hacer funcionar vuestras tarjetas con una resolución decente...

 

Salu2 

 

-Aquel que no conoce la historia, estará obligado a repetirla-

+1
0
-1

-Aquel que no conoce la historia, estará obligado a repetirla-

Imagen de fran-thx
+1
0
-1

Tengo una ati radeon 2600 xt pero no tengo aceleración gráfica.

Lo pudiste solucionar???

+1
0
-1
Imagen de andres_alre
+1
0
-1

Dale un vistazo a mi hilo (el que puse antes). Sí, lo pude solucionar... pero no hice nada más que reinstalar los drivevs de ATI de nuevo, pero una versión más moderna ;)

 

Saludos y suerte 

 

-Aquel que no conoce la historia, estará obligado a repetirla-

+1
0
-1

-Aquel que no conoce la historia, estará obligado a repetirla-