Drivers tarjeta ati y wifi atheros sin conexion a internet

Imagen de vicdaner
0 puntos

Bueno ante todo hola y gracias de antemano que ya se ve que la comunidad ubuntu es muy participativa :p .

Buena a ver lo que pasa es lo siguiente tengo ubuntu instalado en un sobremesa sin conexion a inet y me gusta bastante manejar ubuntu en el, mis conocimiento de ubuntu son basicos asi que ruego me ayuden como si fuera novato xD.

El caso es que tengo un samsung R20 (PORTATIL) con una tarjeta grafica ati xpress1250 y un wifi atheros ubuntu no reconoce ninguno de los dos al intentar instalar y me da un error de xserver por la grafica y no ne deja instalar mas, me sale al modo consola.

He buscado mucho por la red y he encontrado varias soluciones pero ninguna se adapta a mis posibilidades ya que mi unica posibilidad de conexion es mediante el wifi de la universidad  y por tanto no puedo hacer apt-get puesto que el wifi no lo reconoce. Lo que me interasaria es conseguir descargar las aplicaciones que tengo que instalar a un pendrive y luego instalarlas pero esto como se hace???

Los procedimientos que he encontrado son : 

<quote>

  •  sudo -s
  •  killall gdm
  • apt-get install xorg-driver-fglrx
  • depmod -a
  • aticonfig --initial
  • gdm start
  • </quote>

    He googleado todo lo que he podido y más pero ya no se que buscar, gracias por todo.

    Imagen de Goyo
    +1
    0
    -1

    Puedes descargar el paquete desde http://packages.ubuntu.com, creo que no depende de ningún otro así que es sencillo. Asegurate de que sea para tu versión y arquitectura. Luego puedes instalarlo con dpkg:

    $ sudo dpkg -i xorg-driver-fglrx

    Ojo que no estoy del todo seguro de la sintaxis, si no funciona investiga sobre dpkg.

    De todos modos si no lo has hecho ya prueba a hacer apt-get sin conexión, lo mismo el paquete está en el CD.

    +1
    0
    -1
    Imagen de vicdaner
    +1
    0
    -1

    A ver el paquete ya lo he descargado de la pagina, ahora me surgen dos dudas tengo que bajar de esta misma pagina topdos aqellos paquetes que me aparezcan con el piloto rojo al lado (pone depends) o no es necesario??

    Y lo segundo, he metido este paquete en un pendrive ahora como lo ejecuto el paquete, primero deberia de montarlo por consola pero esto como se hace exactamente?? y despues deberia de entrar en la ruta del pendrive no?

     Gracias por vuestra ayuda un saludo!!

    +1
    0
    -1
    Imagen de Goyo
    +1
    0
    -1

    Bien

    Lamento haber tardado tanto en contestar. Las dependencias no te lo puedo asegurar pero creo que ya las tendrás todas instaladas y no tienes que descargarlas. Yo no tengo lo tengo instalado y sin embargo tengo todas las dependencias.

    Para montar el pendrive primero hay que saber que nombre de dispositivo se le asigna. Puedes intentar esto (te pongo mis resultados para que lo veas más claro):

    $ ls /dev/sd*
    /dev/sda  /dev/sda1  /dev/sda2  /dev/sda3  /dev/sda4  /dev/sda5  /dev/sda6

    A continuación enchufa el pendrive, espera un rato a que lo reconozca y vuelve a escribir lo mismo:

    $ ls /dev/sd*
    /dev/sda   /dev/sda2  /dev/sda4  /dev/sda6  /dev/sdb1
    /dev/sda1  /dev/sda3  /dev/sda5  /dev/sdb

    Como ves se ha añadido un nuevo disco /dev/sdb y una partición /dev/sdb1 que es la que interesa. Hay qye crear un directorio para montarla, por ejemplo:

    $ sudo mkdir /media/pendrive

    Y yo conseguí montarla simplemente así:

    $ sudo mount /dev/sdb1 /media/pendrive

    Comprueba el contenido:

    $ ls /media/pendrive 

    Ahora para instalar el controlador:

    $ sudo dpkg -i /media/pendrive/xorg-driver-fglrx
    +1
    0
    -1
    Imagen de javpm
    +1
    0
    -1

    Perdona que interfiera en el hilo pero es que parece que tengo el mismo problema que tu y quisiera solucionarlo.

    Soy novatisimo en el Linux y quisiera aprender. Me dispongo a instalar ubuntu y no me deja de ninguna manera. Todo va bien hasta que me aparece el siguiente error:

    Module Loader present:
    (EE) vesa(0): no matching modes
    (EE) Screnn(s) found, but none have a usable configuration.

    fatal server errror:
    no screens foud

    A partir de ahi no se que hacer. Según parece te aconsejan descargarte un paquete. ¿que paquete es?. He entrado en la página y me he formado un lio tremendo.

    Si ya has resuelto el problema, dime como lo has hecho.

    Gracias y saludos.

    +1
    0
    -1
    Imagen de knowledge
    +1
    0
    -1

    Solo Una pregunta

    1º que Version de Ubuntu tienes instalada

    2º la 7.04 reconoce he instala las ati y las atheros sin problemas alguno

    3º sipudes dames mas detalles de tu sistems instalado, y el tiempo que llevas usando gnu/linux ubuntu

     

     

    Xauu Salu2 Pronto Ubuntu 7.10!!!!!!!! 

    +1
    0
    -1
    Imagen de javpm
    +1
    0
    -1

    La versión que instalo de Ubuntu es la 7.04 y sobre el tiempo que llevo con el Linux ( cero patatero). Ayer mismo lo intenté instalar por primera vez, asi que lo de supernovato me va como anillo al dedo.

    Cuando al portatil, que traia el Vista, le instale el XP y no me reconocia la tarjeta gráfica, no se, siempre me ha pasado con otros ordenadores que por lo menos coge los drivers de una vga compatible. En este caso no. De la página oficial de Samsung  tuve que instalar dos controladores, uno para el chipset y otro el propio de la ati radeon xpres 1250m hasta 256 MB.

    No se si esto tiene algo que ver al instalar el Ubuntu.

    Espero haber aclarado tus dudas.

    Saludos y gracias por tu ayuda. 

    +1
    0
    -1