Problema con drivers Nvidia y funcionamiento Compiz Fusion

Imagen de anandica
0 puntos

Tengo un problema, mi S.O., es Ubuntu Feisty Fawn 7.04.
en su dia cuando instale el sistema operativo, active los controladores que me daba por defecto Ubuntu para tarjetas graficas Nvidia.

mas tarde instale Compiz Fusion, con los repositorios de treviño, pero al cambiar de usuario, en el 90 por ciento de las veces me daba un pantallazo en negro, y tenia que volver a reiniciar el sistema.

buscando, y buscando, al final lo pude solucionar con el siguiente comando en > sistema>sesiones:

compiz --replace --indirect-rendering

con esto de momento parecia funcionar, pero al cabo de un tiempo, unos diez o veinte minutos, parece desistalarse solo y tengo que volver a reiniciar.

¿es mejor que desistale los drivers privativos que Ubuntu me da por defecto y me baje los drivers que aparecen en la pagina de Nvidia?

¿como puedo hacer para que todos los usuarios puedan tener compiz fusion?

Actualmente solo me funciona con un solo usuario.

Imagen de MagoDeOz85
+1
0
-1

pero al cabo de un tiempo, unos diez o veinte minutos, parece desistalarse solo y tengo que volver a reiniciar.

A que te refieres con eso de desistalarse solo...?

Saludos. 

]<----- FacilWare ----->[

-_ y no te compliques _-

-__________________-

+1
0
-1

*****************************************************************

¡Libresfera, la revista libre!

*****************************************************************

Imagen de anandica
+1
0
-1

saludos

pues resulta que al cabo de un rato de estar funcionando bien hace un estraño de milesimas de segundo y se queda sin el cubo y todo lo demas.

ademas, en su dia, en sesiones, inicio, puse el comando : compiz --replace, pues bien, cuando paso de superusuario a otro usuario, la pantalla se queda en blanco, y si lo hago al reves se queda en negro.

la unica manera de que lo haga bien es reiniciar cada vez que tengo que cambiar de usuario, ...que no es precisamente lo mas deseable

la verdad no se lo que hacer, ya quite una tarjeta grafica ati, y puse otra nvidia, y la verdad es que me va mucho mejor con nvidia, de echo antes con ati, solo podia tener beryl.......

¿puede ser que se solucione con la nueva version de ubuntu?

!!!! solo quedan diez dias ¡¡¡¡

+1
0
-1

saludos

Imagen de MagoDeOz85
+1
0
-1

pues resulta que al cabo de un rato de estar funcionando bien hace un estraño de milesimas de segundo y se queda sin el cubo y todo lo demas.

Lo que pasa es que por alguna razon compiz falla y le devuelve el control a metacity. Es algo normal. ya que no es estable y suele tener errores.

Lo de los usuarios... es algo mas estraño. Se me ocurre que en lugar del comando compiz --replace, coloques fusion-icon. Puede que tengas que instalarlo.

sudo aptitude install fusion-icon

Luego cada vez que inicies te aparecera un icono azul en el panel, junto al reloj. Desde ahi podras elegir el window manager que prefieras. Cuando vayas a cambiar de usuario eliges metacity, y luego vuelves a activar compiz.

Saludos.

]<----- FacilWare ----->[

-_ y no te compliques _-

-__________________-

+1
0
-1

*****************************************************************

¡Libresfera, la revista libre!

*****************************************************************