Por que las actualizaciones de las aplicaciones no estan en synaptic?

Imagen de hydralysk
0 puntos

Hola: tengo firefox 0.93 y Rhythmbox 0.85! queria actualizarlos mediante synaptic ya que firefox ya va en su version 1.0 y Rhythmbox en la 0.87! pero no aparecen disponibles en el repertorio!

Que puedo hacer para actualizar estos programas? Sin estar bajando el programa desde la pagina y compilando! es que es para una amiga!

Imagen de fromoze
+1
0
-1

Cuando apuestas por una distribución en concreto, tienes dos opciones, mantenerte dentro de la política de la distribución y sólo usar programas certificados por sus desarrolladores. Esto serían los presentes en la fuente warty -los que aparecen en synaptics con el símbolo de ubuntu-. Luego, si usas ubuntu, basada en debian, puedes incluso acudir a una segundas fuentes 'medio certificadas' como las Universe (con estrellita en synaptics) o incluso ir mas allá, hasta el multiverse. Y el camino, no acaba ahí, pues puedes usar paquetes deb de un repositorio montado por perico, que compila las nuevas versiones de gthumb, crea .debs y los pone a disposición de todos en su blog.

Es decir, que si quieres 'romper' con la política de releases de ubuntu, y adelantarte a tu tiempo, tienes que o compilar o buscarte la vida para encontrar .debs. Eso sí, no te quejes a nadie relacionado con ubuntu de que eso no funciona, ni bug ni leches tampoco, ya que estarías fuera del ámbito de la distribución.

Y no sé, recuerda algo básico en la informática: si funciona, no lo toques. ¿Realmente te aportan esos programas algo necesario en sus nuevas versiones? ¿Vas a usar los bookmarks en vivo como un loco? Todo depende de lo que te quieras arriesgar. Yo paso de complicarme, y menos el mplayer, el monodevelop y el wesnoth; los dos primeros porque no los tengo en ubuntu y el tercero porque es una versión demasiado vieja (ni siquiera la última estable!!!) me quedo dentro de la politica de releases de ubuntu.

Y teniendo en cuenta que es para una amiga... pues mira, quizás incluso te lo desaconsejaría! Piensa que desde otras distribuciones no se tiene ni siquiera el gnome 2.8 en la versión estable! Y si el firefox de ubuntu es un 1.0pre-nosequé parcheado a 0.99 por algo será... no me parece que los desarrolladores hagan su trabajo mal en general, así que tengo fe en ellos :)

Saludiños!

JID: fromoze@jabberes.org y fromoze@jabber.org

+1
0
-1
Imagen de millen
+1
0
-1

Firefox 1.0 se instala muy fácil con el script que trae (si te lo bajas de www.mozilla.com) y a mí personalmente no me ha dado ningún tipo de problema...

+1
0
-1
Imagen de herje
+1
0
-1

Tarde o temprano te los dara.
Cuelgues con flash, cuelgues al interferir con diversos demonios, etc..
¿Crees que los paquetes no se ñaden por capricho? No, simpre hay algún motivo.

Saludos
Herje
http://www.herje.com

+1
0
-1

Saludos
Herje
http://www.herje.com

Imagen de millen
+1
0
-1

Lo sé y pienso de la misma manera que tú.La única aplicación que he instalado que no está en los repositorios de Ubuntu es Firefox 1.0,más que nada por curiosidad y como ya he dicho no me ha dado ninguna clase de problema(no quiero decir que no los de).De todas maneras en caso de que empezara a fallar volvería a la anterior versión que aun está instalada.

Una cuestión sobre Firefox 0.9.3 (si no recuerdo mal la que trae Ubuntu por defecto):¿es posible configurarlo de manera que al pulsar Backspace vuelva a la página anterior?,He estado mirando en las opciones y no he encontrado nada al respecto,sin embargo la 1.0 sí que puede hacerlo(sin configurar nada).Es una tontería pero me resulta cómodo para navegar...

Un Saludo

+1
0
-1
Imagen de herje
+1
0
-1

Que en la web de la aplicación tengas una versión X no significa que simpre funcione correctamente en todas las distros. La compatibilidad de firefox 1.0 no está demostrada al 100% con debian ni con ubuntu, ya que hay diversos fallos.

Confía en quien sabe(los desarroyadores) y ten paciencia

Saludos
Herje
http://www.herje.com

+1
0
-1

Saludos
Herje
http://www.herje.com

Imagen de Anónimo
+1
0
-1

la solucion que encontre fue agregar listas de distribucion locales, en mi caso fue editar las listas de paquetes de forma manual, en consola accedes a modo root

para activar la cuenta root y asignarle un pass:

sudo passwd root
(ingresas tu pasword)

Te logeas con:

su
(ingresas tu password)

y luego con el comando:

apt-setup

(eliges la opcion "configurar manualmente")

Ahi podras agregar listas de actualizacion de diferentes softwares, yo como vivo en Santiago de Chile agrege las listas de actualizacion de paquetes debian mas cercana y la lista de paquetes de ubuntu-es.org.

Lo que deberias agregar es primero la lista ubuntu-es, y luego la lista de distribucion debian mas cercana, en mi caso ubiobio:

#ubuntu-es
deb ftp://ftp.ubuntu-es-org/ubuntu warty main restricted universe multiverse
deb ftp://ftp.ubuntu-es-org/ubuntu warty-security main restricted universe multiverse
deb ftp://ftp.ubuntu-es-org/ubuntu warty-updates main restricted universe multiverse

#ubiobio
deb http://debian.ubiobio.cl/debian testing main non-free contrib
deb-src http://debian.ubiobio.cl/debian testing main non-free contrib
deb http://debian.ubiobio.cl/debian unstable main non-free contrib
deb-src http://debian.ubiobio.cl/debian unstable main non-free contrib

luego de eso, puedes usar el comando:
apt-get updates

y se actualizara toda la lista de paquetes disponible.

Saludos desde Chile.
Pablo Noel.

+1
0
-1