Montar partición y se reconozca al iniciar (Soluciondo)

Imagen de Rutrus
0 puntos

Queriendo hacer pruebas con HURD necesitaba quitar espacio a la partición NTFS que tengo en otro disco duro (hda1). Para poder usar qtparted necesitaba desmontarla, así que lo hice desde consola como root /sudo umount */. Pensaba que ubuntu volvería a reconocerla al reiniciar, pero no lo hizo.

De forma que quiero montar la partición hda1 en media como "Disco 200GB" en media y hda2 como gnu en el directorio raíz "/gnu" (carpeta ya creada y con todos los permisos porque llegué a montar esa partición).

Para montar hda2 funciona con ésta orden:

sudo mount -t ext2 /dev/hda2 /gnu

Para montar hda1 NO FUNCIONA con ésta orden:

sudo mount -t ntfs /dev/hda1 /media/hda1

Aparentemente lo hace, de hecho cuando lo vuelvo a hacer me dice que está montado u ocupado, lo estoy comprobando y el caso es que no me aparece en Equipo, y cuando intento acceder desde consola a /media/hda1 me dice "Permiso denegado", pero al darle permisos me dice "De sólo lectura". Por cierto, /gnu sí me aparece montado.

Al hacer un sudo fdisk -l me sale:

Disco /dev/hda: 203.9 GB, 203928109056 bytes
255 cabezas, 63 sectores/pista, 24792 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/hda1 * 1 23636 189848428+ 7 HPFS/NTFS
/dev/hda2 23637 24792 9285570 83 Linux

Disco /dev/hdb: 40.0 GB, [...]

Preguntas relacionadas:

1.- ¿Qué es lo que pasa con hda1?

2.- ¿Qué hago para que se monten ambas particiones al arrancar?

3.- ¿Cómo cambiar la etiqueta de una partición para que aparezca con un nombre adecuado?

Imagen de Rutrus
+1
0
-1

Solucionado. El problema era que tenía que arrancar con windows para solucionar errores. (Es que de no usarlo...)

1.- Cuando arranqué se ejecutó una aplicación con fondo azul llamada CHCKDSK que reparó los errores. Pensando que todo estaba arreglado, a continuación se reinició el ordenador y aproveché para arrancar con Ubuntu; éste fue mi error, debía reiniciar windows porque Ubuntu detectaba todavía fallos (como cuando cierras Windows de forma incorrecta).

2.- Para que hda2 arrancara al inicio, debía "activarla". Eso lo he hecho fácilmente con el programa disk-manager que he encontrado en http://flomertens.free.fr/disk-manager/ y que instalé directamente como cualquier *.deb.

3.- Todavía no sé cómo cambiar la etiqueta, pero supongo que será fácil; hasta es posible que disk-manager lo haga. Como no el problema no es de mi ordenador...

+1
0
-1