Problemas de resolución y wifi

Imagen de xaguilars
0 puntos

Hola, el otro día decidí hacer una instalación limpia de ubuntu 7.10... al principio parecía que bien pero falla en muchas cosas:

  • Antes de cargar el modo gráfico, mi monitor TFT se "apaga" y siempre me muestra VIDEO MODE INCOMPATIBLE... pero bueno esto con ubuntu siempre me ha pasado... después se carga el modo gráfico y solucionado pero...
  • En ubuntu 7.10 la pantala de login (inicio de sesión) se me muestra en una resolución equivocada... se ve alargado, como en la instalación. La primera vez que inicié sesión, cambié la resolución a la que toca, 1027x768... y siempre que se inicia mi sesión va bien... pero la pantalla de login siempre se ve mal.
  • Ni en la instalación ni después me dejó conectarme a mi red wifi... 7.04 ya tenía problemas con eso... pero conseguí arreglarlo configurándolo manualmente, con ip estática (no dhcp), y poniendo como primer DNS a mi router y después a los de telefónica. Bueno pues el 7.10 de ninguna de las maneras me deja (ni antes ni después de la instalación). Uso un adaptador Wifi USB de Linksys, el modelo WUSB54Gv4. NOTA: En 7.04 mi adaptador tenia el ID rausb0 y en 7.10 está como wlan0 (por si esta información fuera útil para aquellos que puedan solucionar el problema).

Ahora he vuelto a poner el 7.04, porque es con el que me va bien Internet. Mi pregunta es la siguiente:

        Si actualizo desde 7.04 a 7.10 desde el gestor de actualizaciones... cuando arranque el equipo podré elegir si arranco con la versión anterior o me borrará la versión 7.04? Lo digo por si no me fuera bien poder arrancar con la otra... hasta que se solucione el problema del wifi (NSWrapper o como se diga dicen que da muchos fallos y que cuelga el pc, así que no quiero "parchear" mi ubuntu con controladores de windows que a saber... jeje). 

GRACIAS POR CONTESTAR

Imagen de JRshiller
+1
0
-1

Buenas, mira yo tambien tuve algunos problemitas con la resolución, pero lo que hice fue modificar Xorg.

Sudo gedit /etc/X11/xorg.conf  

con eso deberia de aparecer algo más o menos asi

<blockquote>

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Silicon Integrated Systems (SiS) 65x/M650/740 PCI/AGP VGA Display Adapter"
Driver "sis"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "DELL D1025TM"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Silicon Integrated Systems (SiS) 65x/M650/740 PCI/AGP VGA Display Adapter"
Monitor "DELL D1025TM"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

</blockquote>

 

 

si te das cuenta en la sección ;

<blockquote>  Section "Monitor" 
Identifier "DELL D1025TM"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Silicon Integrated Systems (SiS) 65x/M650/740 PCI/AGP VGA Display Adapter"
Monitor "DELL D1025TM"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

 

salen todas tu posibles resoluciones, si lo que quieres es tener solo 1024X720 solo eliminas las más altas. en mi caso yo queria tener más resolución, por eso en la última linea agrege:

 

SubSection "Display" 
Depth 24
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

supongo que con eso solucionaras la resolución,y ojo con la taza de refresco.

reinicia las X con Alt + backspace e ingresa a tu seccion y despues eliges la resolución.

Al actualizar, lo unico que puedes elegir es la versión del Kernel, el Ubuntu queda forever 7.10

y lo de Wifi ni idea.

Suerte!

 

 

 

parte de mi ignorancia es la que me permite aprender siempre.

+1
0
-1

parte de mi ignorancia es la que me permite aprender siempre.