No consigo montar ningún pendrive USB (solucionado)

Imagen de cdsmessiah
0 puntos

Hola compañeros:

No consigo montar ningun usb, ni de forma automatica ni por consola. El mensaje que me da es que opcion invalida al montar el volumen.

Creo que tiene que ver con el fotmato del pen que esta en FAT

Que es lo que puedo hacer

Gracias.

Imagen de topito_u
+1
0
-1

 He cambiado el título a minúsculas. También he mandado a la papelera dos entrads repetidas del mismo hilo. Echa un vistazo a las normas

Con respecto a tu problema, di exactamente lo que has hecho y el mensaje concreto de error


 

Miembro del equipo de moderadores

Normas del foro

Contacto

+1
0
-1

carlos
presencia

Imagen de cdsmessiah
+1
0
-1

Lo siento fue un descuido no volverá a sucecder.

Al introducir el usb me sale este mensaje:

NO SE PUEDE MONTAR EL VOLUMEN

Opción de montaje invalida al intentar montar el volumen.

Además e intentado esto por consola:

sudo mount -t vfat  /dev/sdb /mnt/pendrive/
mount: wrong fs type, bad option, bad superblock on /dev/sdb,
       missing codepage or helper program, or other error
       En algunos casos se encuentra información en syslog, pruebe
   dmesg | tail   o algo parecido

Este es todo lo que se me ocurrio

¿Alguna solución? muchas gracias 

+1
0
-1
Imagen de topito_u
+1
0
-1

Pero yo antes de añadirlo al fstab haría lo siguiente:
Miraría en (gnome):sistema>prefrencias>unidades y soportes extraíbles para cerciorarme de que las tres primeras opciones de la pestaña almacenamiento estuvieran marcadas
Pegaría aquí el resultado de ejecutar el comando mount en una terminal
Pega también el resultado de dmesg | tail que es lo que sale en la advertencia que te manda el sistema

+1
0
-1

carlos
presencia

Imagen de cdsmessiah
+1
0
-1

Si las tres pestañas están las 3 marcadas, el resultado del comando:

sudo mount -t vfat /dev/sdb /mnt/pendrive/
mount: wrong fs type, bad option, bad superblock on /dev/sdb,
       missing codepage or helper program, or other error
       En algunos casos se encuentra información en syslog, pruebe
   dmesg | tail   o algo parecido

Después he ejecutado el comando:

dmesg | tail
[ 1160.816000] sd 3:0:0:0: [sdb] Write Protect is off
[ 1160.816000] sd 3:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 1160.816000] sd 3:0:0:0: [sdb] Assuming drive cache: write through
[ 1160.816000]  sdb: sdb1
[ 1160.816000] sd 3:0:0:0: [sdb] Attached SCSI removable disk
[ 1160.816000] sd 3:0:0:0: Attached scsi generic sg2 type 0
[ 1161.304000] UDF-fs: No VRS found
[ 1161.348000] Unable to identify CD-ROM format.
[ 1166.720000] FAT: invalid media value (0xa5)
[ 1166.720000] VFS: Can't find a valid FAT filesystem on dev sdb.

 Espero que con esto valga, gracias por las molestias

 

+1
0
-1
Imagen de cdsmessiah
+1
0
-1

Alguien sabe entonces cual es la solucion???

+1
0
-1
Imagen de topito_u
+1
0
-1

 ¿En nautilus?. Si es afirmativo, con el botón derecho, ¿te pone si está montado?.

Pega el resultado del comando mount

PD: si no se te contesta, paciencia. No te respondas tú si no es para aportar algo 

Miembro del equipo de moderadores

Normas del foro

Contacto

+1
0
-1

carlos
presencia

Imagen de cdsmessiah
+1
0
-1

No sé porque de repente funciona el comando:

sudo mount -t vfat  /dev/sdb /mnt/pendrive/

Nunca me habia funcionado pero ahora me funciona sin problemas, aunque aun sigue sin montarse automáticamente pero por lo menos funciona que es lo importante.

Gracias!!!!!!!!!! 

+1
0
-1
Imagen de camoran_I
+1
0
-1

Ley de la falta de fiabilidad: Errar es humano, pero, para liar las cosas de verdad, hace falta un ordenador.


Mirando por Internet me he encontrado que es un error (bug) de la distribución. La solución es sencilla pero un poquito larga.

Esta es otra forma de solucionarlo, en modo gráfico.

1) Tenemos que tener instalado el editor de configuraciones de gnome: gconf-editor

Así que comprobamos si está instalado. Sistema>>Administración>>gestor de paquetes Synaptic. Vamos a buscar y escribimos/pegamos el nombre de este programa:

 

 gconf-editor

Si no está instalado, lo instalamos

2) Una vez instalado el programa, lo abrimos:

Aplicaciones>>Herramientas del sistema>>editor de configuración 

3)Navegamos por las carpetas de la izquierda (doble click para abrirlas):

 System/storage/default_options/vfat/mount_options

4) Hacemos doble click sobre mount_options, y seleccionamos Editar. Quitamos la opción "userfree" de la lista.

5) Salimos de gconf-editor, y desenchufamos/enchufamos de nuevo nuestro pen-drive o disco usb. Ahora detectará automáticamente los pendrives y discos externos Usb.

Espero que esto te sirva como solución alternativa.

 

 

 

+1
0
-1

Ley de la falta de fiabilidad: Errar es humano, pero, para liar las cosas de verdad, hace falta un ordenador.

Imagen de pepesoto
+1
0
-1

Esta solución corrige el problema.

La del editor gconf-editor 

+1
0
-1
Imagen de pattygloi
+1
0
-1

HIc elos pasos idicados, pero al realizar el tercero (NAvegar por las capetas de la izquierda)
Me aparece system, y otras subcarpetas , pero no me aparece ninguna con el nombre storage....entonces llego ahsta allí.....
"System/storage/default_options/vfat/mount_options"

+1
0
-1
Imagen de forzasec
+1
0
-1

Bueno pues, los mismos errores de montaje,  no me sale ni pa dios. Ni con la solución aportada.

Si se puede decir algo más sobre este tema lo agradecería. 

Gracia a tod@s.

+1
0
-1
Imagen de forzasec
+1
0
-1

Ostia Alemania!

vale

 sudo mount -t vfat /dev/sdb1 /mnt/usb

 

perdon a todos, pero es que no podía. 

+1
0
-1
Imagen de Pedro Piter
+1
0
-1

A mi me estaba pasando lo mismo, y era porque en /etc/fstab habia una entrada que forzaba a montar el usb como si fuera un cdrom:

/dev/sdb1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

lo he arreglado comentando esa linea, para ello hay que editar el archivo:

sudo vi /etc/fstab

y comentar (se hace añadiendo una almohadilla # al principio de la linea) o borrar la linea.

A ver si tienes suerte y lo arreglas

+1
0
-1
Imagen de loizp
+1
0
-1

ya e quitado el userfree de gconf-editor como se dice en otros comentarios, tambien ya vi las opcion es de permisos de plugdev y estan bien, de igual manera quite los (michis #) de /etc/init.d/mountdev... tambien agrgue usbmount y sus utilidade incluso su configuracion y nada con lograr que monte mi pendrive usb

------------------------------------------ 

cuando hago

$ sudo mount -t vfat /dev/sda1 /mnt/pendrive

me sale  mount: /dev/sda1: no se puede leer el superbloque

----------------------------------------- 

$ dmesg | tail

[ 1862.023992] end_request: I/O error, dev sda, sector 32
[ 1862.024009] printk: 24 messages suppressed.
[ 1862.024016] Buffer I/O error on device sda1, logical block 0
[ 1862.027310] end_request: I/O error, dev sda, sector 32
[ 1863.042652] end_request: I/O error, dev sda, sector 32
[ 1863.044411] end_request: I/O error, dev sda, sector 32
[ 1864.057574] end_request: I/O error, dev sda, sector 32
[ 1864.059327] end_request: I/O error, dev sda, sector 32
[ 1865.072737] end_request: I/O error, dev sda, sector 32
[ 1865.074457] end_request: I/O error, dev sda, sector 32

ya no se que hacer quien me puede dar una solucion porque a mi parecer hice lo que dicen los foros y ninguno me funciona

ademas si doy 

$ sudo mount -t usbfs /dev/sda1 /mnt/pendrive

le monta pero al abrir el directorio /mnt/pendrive me sale unas archivos nombrados como

001 002 003 004 device

 

Free Spirit: Luis Odar Iván Zambrano Paredes Hay 10 clases de personas: las que saben binario y las que no.

+1
0
-1

Free Spirit: Luis Odar Iván Zambrano Paredes

Hay 10 clases de personas: las que saben binario y las que no.

Imagen de toni83m9
+1
0
-1

hola, alguien puede decirme como hacer para que aparezca la pestaña de almacenamiento en unidades y soportes extraibles? xq para montar los usb solo puedo hacerlo usando el editor de particiones. gracias

+1
0
-1
Imagen de cHemarY
+1
0
-1

A mi me pasa con con un disco duro externo de 1,5 TB.

Estuve manejando "Dispositivos de almacenamiento" y tenía un pendrive instalado, pero desde entonces siempre me pide la contraseña root para entrar al dispositivo. Pero en el de 1,5 TB es distinto hago $ sudo mount /dev/sdb1 y me sale el siguiente mensaje: wrong fs type, bad option, bad superblock on /dev/sdb1,missing codepage or helper program, or other error
En algunos casos se encuentra información en syslog,
pruebe dmesg | tail o algo parecido.

Con $ dmesg | tail me sale lo siguiente:
[ 8250.920496] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 8250.922565] sd 4:0:0:0: [sdb] 2930277168 512-byte hardware sectors (1500302 MB)
[ 8250.924122] sd 4:0:0:0: [sdb] Write Protect is off
[ 8250.924130] sd 4:0:0:0: [sdb] Mode Sense: 34 00 00 00
[ 8250.924134] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 8250.924151] sdb: sdb1
[ 8250.965037] sd 4:0:0:0: [sdb] Attached SCSI disk
[ 8250.965140] sd 4:0:0:0: Attached scsi generic sg2 type 0
[17227.385636] FAT: bogus number of reserved sectors
[17227.385660] VFS: Can't find a valid FAT filesystem on dev sdb1.

y con $ sudo fdisk -l me sale:

Disco /dev/sda: 120.0 GB, 120034123776 bytes
255 cabezas, 63 sectores/pista, 14593 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x00022c92

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 3264 26218048+ 83 Linux
/dev/sda2 3265 3590 2618595 82 Linux swap / Solaris
/dev/sda3 3591 14593 88381597+ 83 Linux

Disco /dev/sdb: 1500.3 GB, 1500301910016 bytes
255 cabezas, 63 sectores/pista, 182401 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0xf49fa30f

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 1 182401 1465136001 7 HPFS/NTFS

Ya no sé lo que hacer, quiero volver como antes, sin tener que poner la contraseña ni ná.

Gracias.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de cHemarY
+1
0
-1

He editado el fstab y he borrado las lineas que hacían referencia a los susodichos volúmenes.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de cHemarY
+1
0
-1

Después de casi dos años me vuelve a fallar, pero he probado la solución anterior y no funciona.

El error que me da es:
Error mounting: mount exited with exit code 13: $MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdc1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details

Cuando hago: $ sudo fdisk -l
me da el siguiente resultado:
Disco /dev/sda: 500.1 GB, 500107862016 bytes
255 cabezas, 63 sectores/pista, 60801 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador de disco: 0x000d2f65

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 1 1946 15624192 82 Linux swap / Solaris
/dev/sda2 * 1946 5353 27367424 83 Linux
/dev/sda3 5353 60802 445393920 83 Linux

Disco /dev/sdc: 1500.3 GB, 1500301910016 bytes
255 cabezas, 63 sectores/pista, 182401 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador de disco: 0xf49fa30f

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdc1 1 182401 1465136001 fd Linux raid autodetect

Tengo archivos importantes que necesito de forma urgente recuperar así que no puedo formatearlo.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.