usuario y contraseña vacíos en wvdial

Imagen de roby
0 puntos

Tengo que hacer una cuenta para conectarme a internet con dial-up usando wvdial.
El usuario y la contraseña son vacíos, pero si escribo nada en esos campos del archivo de configuración, me sale un error cuando ejecuto wvdial con líena de comandos: el error dice que no hay usuario y contraseña.
Probé con "" y con '' pero los toma como caracteres.
Es decir:

---------------------------------
número de teléfono = 123456789
usuario =
contraseña =
---------------------------------

Algo así me tiene que quedar el archivo. Pero me da error porque usario y contraseña están vacíos.

Bueno, espero que se entienda mi problemita.

gracias a todos,

Roby Sottini
Estudiante de Lic. en informática
Ushuaia - Argentina

Imagen de Gabriel_M
+1
0
-1

Hola Roby:

Todos los días se aprende algo nuevo, es la primera vez que

me encuentro con una conexión dial-up que no requiere

usuario ni contraseña.

Prueba con

Editar tu archivo/etc/wvdial.conf con la orden

sudo gedit /etc/wvdial.conf

Se debe ver algo parecido a lo siguiente:

 

[Modem0]
 Modem = /dev/modem 
Baud = 115200 
Init1 = ATZ 
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0 
SetVolume = 1 
Dial Command = ATDT 
Init4 = ATM1L3  
[Dialer Defaults] 
Modem = /dev/modem 
Baud = 115200 
Init1 = ATZ 
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0 
SetVolume = 1 
Dial Command = ATDT 
Init4 = ATM1L3  
[Dialer ppp0] 
Username = nombre_de_usuario 
Password = su_contraseña 
Phone = teléfono_de_su_proveedor 
Inherits = Dialer Defaults 
Stupid mode = 1

 

Comenta anteponiendo ; a las líneas Username y Password

y prueba conectarte con la orden

sudo wvdial

Ahora si lo que necesitas es dar enter al pedido de usuario

y al de contraseña

\\n es una opción del comando echo que dice al shell que

añada un retorno de carro al final de la línea, que actúa

cuando esta la orden echo -e.

Te aclaro que no tengo idea si esto funciona en este archivo.

Saludos.

 

Ubuntu: sistema operativo superior, moderno, optimizado, seguro, racional, completo, y evolutivo.

Gabriel

+1
0
-1
Imagen de roby
+1
0
-1

Probé esto en /etc/wvdial.conf:

Username = \\n
Password =\\n

Pero la consola me da este eror: NO CARRIER. te copio lo que me dice la consola. (número_de_teléfono es mi número de conexión)

----------------------------------------------------------

roby@roby-desktop:~$ wvdial
--> WvDial: Internet dialer version 1.55
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Sending: ATDTnúmero_de_teléfono--> Waiting for carrier.
ATDTnúmero_de_teléfono
NO CARRIER
--> No Carrier! Trying again.
--> Sending: ATDTnúmero_de_teléfono
----------------------------------------------------------

Si antepongo ";" ó "#" la consola me dice que especifique un nombre de usuario y una contraseña.

Si sabés que significa cada línea del archivo d eejemplo que me mostras, por favor decime.

Espero que no sea molestia pedirte ayuda,

Roby

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola:

En principio parece que hay un problema de conexión entre tu modem y el modem del servidor.

Después de ATDTnúmero de teléfono.

NO CARRIER

Es que no se pudo conectar.

Prueba ejecutar:

sudo wvdialconf /etc/wvdial.conf

Así intenta nuevamente detectar tu modem y establecer los parámetros correctos, una vez hecho, solo agrega y descomenta el número de telefóno de accceso.

Saludos. 

 


Equipo de moderadores del Foro
Normas

 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola roby:

Necesitaras instalar mc Midnight Commander .

En consola deberás escribir:

sudo dd bs=1 count=1 if=/dev/zero of=zero.tmp cat zero.tmp >> /etc/wvdial.conf

Luego cargas mc con permisos temporarios de root

sudo mc

Te vas al directorio /etc/

Te paras sobre wvdial.conf

Pulsas F4 y se abrirá el archivo

Vas a la última línea y veras que aparece un punto seleccionado en negro.

Te paras sobre él lo seleccionas con F3 y la tecla de desplazamiento lateral (cursor), se pondrá de color verde, vuelves a dar a F3 y con los cursores te vas hasta donde pone Password= y le das a la tecla F5, ahora tiene que poner algo como:
Password=.

Repites el procedimiento para Username=

que te quedará

Username=.

Finalmente borra el . del final del archivo y lo guardas con F2

Saludos.

 


Equipo de moderadores del Foro

Normas

+1
0
-1
Imagen de curuxiera
+1
0
-1

Tengo el mismo problema.
sudo dd bs=1 count=1 if=/dev/zero of=zero.tmp cat zero.tmp >> /etc/wvdial.conf me da bash: /etc/wvdial.conf: Permiso denegado.
Si ejecuto mc o gedit el /etc/wvdial.conf aparece asi:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Modem = /dev/ttyUSB2
New PPPD = yes
Phone = *99#
Idle Seconds = 0
Modem Type = Analog Modem
Stupid Mode = 1
Compuserve = 0
Baud = 9600
Auto DNS = 1
Dial Command = ATDT
Ask Password = 0
ISDN = 0
; Password =.
; Username =.
[Dialer Pepephone]
Init5 = AT+CGDCONT= 1,"IP","gprs.pepephone.com";
Si ejecuto wvdial me vuelve a dar
--> Modem initialized.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.
Cualquier sugerencia será bien recibida y gracias anticipadas.

+1
0
-1
Imagen de curuxiera
+1
+1
-1

Bueno, pues parece que no hay quien lo arregle, o al menos es lo que se deduce de este enlace: https://bugs.launchpad.net/ubuntu/+source/wvdial/+bug/72400

+1
+1
-1
Imagen de Goyo
+1
0
-1

También aparece una forma de apañarlo (no la he probado y no sé si funciona)

https://bugs.launchpad.net/ubuntu/+source/wvdial/+bug/72400/comments/3

So ... it seems that you need to add Stupid Mode = yes (or 1) option to /etc/wvdial.conf. Also I had to set thet username and password to "blank" in order to work.

+1
0
-1