Anjuta no quiere usar Glade :'(

Imagen de felmoltor
0 puntos

¡Hola a todos!

Tengo un problemilla con Anjuta y Glade-3.

Resulta que quiero desarrollar  una aplicación gráfica con anjuta muy simple pero cuando le doy a "Nuevo -> Glade Project" me desaparece anjuta de la pantalla, vamos que se termina el programa, viendo la salida por la terminal veo al final un 'core dumped' despues de montones de lineas ininteligibles sobre el mapeo de memoria y tal y tal.

 Otra cosa que intento es crear la interfaz arrancando el glade, creo la interfaz y luego intentar abrir el archivo .glade desde el anjuta pero así tampoco funciona.

¿Le ha pasado esto a alguien? Dadme ideas.

¡Gracias! 

PD: Tengo instalado el Glade-3 y Anjuta 2.2. 

Imagen de oscar_linux
+1
0
-1

Hola, es posible que te falte instalar alguna libreria, ahi te paso un link de una manual muy basico pero que explica de forma clara como iniciar un proyecto con anjuta+glade incluyendo todo lo que debes instalar.

http://maestrodenada.com/manualanjuta/ 

 

espero te ayude

saludos Oscar 

 

+1
0
-1
Imagen de felmoltor
+1
0
-1

Muchas gracias por tu respuesta, pero ya había visto antes ese tutorial.

¡Mi problema es que me peta el anjuta y voy a llorar! :'(   jeje.

Aquí pego lo que aparece en la terminal cuando intento abrir un "glade file":

*** glibc detected *** anjuta: double free or corruption (fasttop): 0x0854a4a8 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb71f6d65]
/lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb71fa800]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0xb737c961]
/usr/lib/libanjuta.so.0[0xb732757b]
/usr/lib/libanjuta.so.0[0xb7327fd2]
/usr/lib/libgobject-2.0.so.0(g_object_unref+0x16c)[0xb7417aec]
/usr/lib/libanjuta.so.0(anjuta_glue_factory_get_object_type+0x12f)[0xb732795f]
/usr/lib/libanjuta.so.0[0xb731aa2f]
/usr/lib/libanjuta.so.0(anjuta_plugin_manager_get_plugin_by_id+0xa2)[0xb731ae02]
/usr/lib/anjuta/libanjuta-loader.so[0xb53dec61]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x49)[0xb7422c09]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x122)[0xb7415772]
/usr/lib/libgobject-2.0.so.0[0xb7426323]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x8c7)[0xb7427847]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb7427a09]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_activate+0x58)[0xb7ad7fe8]
/usr/lib/libgtk-x11-2.0.so.0(gtk_menu_shell_activate_item+0x14a)[0xb79c238a]
/usr/lib/libgtk-x11-2.0.so.0[0xb79c3f28]
/usr/lib/libgtk-x11-2.0.so.0[0xb79bb178]
/usr/lib/libgtk-x11-2.0.so.0(_gtk_marshal_BOOLEAN__BOXED+0x5e)[0xb79b51de]
/usr/lib/libgobject-2.0.so.0[0xb7413f89]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x122)[0xb7415772]
/usr/lib/libgobject-2.0.so.0[0xb7426973]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x68f)[0xb742760f]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb7427a09]
/usr/lib/libgtk-x11-2.0.so.0[0xb7ad3498]
/usr/lib/libgtk-x11-2.0.so.0(gtk_propagate_event+0x14f)[0xb79ae36f]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x307)[0xb79af587]
/usr/lib/libgdk-x11-2.0.so.0[0xb76fbb9a]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x17c)[0xb737511c]
/usr/lib/libglib-2.0.so.0[0xb737855f]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a9)[0xb7378909]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0xb79af9e4]
anjuta[0x805413d]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0)[0xb71a3050]
anjuta[0x804e101]
======= Memory map: ========
08048000-08056000 r-xp 00000000 08:06 1736588 /usr/bin/anjuta
08056000-08057000 rw-p 0000e000 08:06 1736588 /usr/bin/anjuta
08057000-08697000 rw-p 08057000 00:00 0 [heap]
b2800000-b2821000 rw-p b2800000 00:00 0
b2821000-b2900000 ---p b2821000 00:00 0
b290e000-b2918000 r-xp 00000000 08:06 32643 /lib/libgcc_s.so.1
b2918000-b2919000 rw-p 0000a000 08:06 32643 /lib/libgcc_s.so.1
b2919000-b292e000 r-xp 00000000 08:06 1876760 /usr/lib/anjuta/libanjuta-symbol-browser.so
b292e000-b292f000 rw-p 00015000 08:06 1876760 /usr/lib/anjuta/libanjuta-symbol-browser.so
b292f000-b295e000 r-xp 00000000 08:06 1736591 /usr/lib/libanjuta-ctags.so.0.0.0
b295e000-b2961000 rw-p 0002e000 08:06 1736591 /usr/lib/libanjuta-ctags.so.0.0.0
b2961000-b2962000 rw-p b2961000 00:00 0
b2972000-b2981000 r-xp 00000000 08:06 1876787 /usr/lib/anjuta/libanjuta-search.so
b2981000-b2982000 rw-p 0000f000 08:06 1876787 /usr/lib/anjuta/libanjuta-search.so
b2982000-b29e7000 r-xp 00000000 08:06 1728176 /usr/lib/libgnomeprint-2-2.so.0.1.0
b29e7000-b29e9000 rw-p 00065000 08:06 1728176 /usr/lib/libgnomeprint-2-2.so.0.1.0
b29e9000-b2a27000 r-xp 00000000 08:06 1728178 /usr/lib/libgnomeprintui-2-2.so.0.1.0
b2a27000-b2a29000 rw-p 0003d000 08:06 1728178 /usr/lib/libgnomeprintui-2-2.so.0.1.0
b2a29000-b2a4e000 r-xp 00000000 08:06 1728460 /usr/lib/libpcre.so.3.12.1
b2a4e000-b2a4f000 rw-p 00025000 08:06 1728460 /usr/lib/libpcre.so.3.12.1
b2a4f000-b2a6c000 r-xp 00000000 08:06 1876785 /usr/lib/anjuta/libanjuta-document-manager.so
b2a6c000-b2a6e000 rw-p 0001c000 08:06 1876785 /usr/lib/anjuta/libanjuta-document-manager.so
b2a6e000-b31cf000 r--p 00000000 08:06 151638 /usr/share/icons/gnome/icon-theme.cache
b31cf000-b3ec3000 r--p 00000000 08:06 884693 /home/felipe/.icons/Neu/icon-theme.cache
b3ec3000-b3ed2000 r-xp 00000000 08:06 32615 /lib/libbz2.so.1.0.4
b3ed2000-b3ed3000 rw-p 0000f000 08:06 32615 /lib/libbz2.so.1.0.4
b3ed3000-b3f05000 r-xp 00000000 08:06 1727970 /usr/lib/libcroco-0.6.so.3.0.1
b3f05000-b3f08000 rw-p 00031000 08:06 1727970 /usr/lib/libcroco-0.6.so.3.0.1
b3f08000-b3f38000 r-xp 00000000 08:06 1728212 Cancelado (core dumped) 

Si alguien sabe algo agradezco su ayuda. 

 

www.ecologismo-diario.blogspot.com

+1
0
-1
Imagen de eibriel
+1
0
-1

Buenas!! Tengo un problema similar, el intentar abrir un archivo .glade con Anjuta, o crear un proyecto Glade me aparece ese error...

 

Por lo que leí por ahí quizas es un bug del programa, si es así no habrá más remedio que esperar a que lo solucionen. Pero me parece raro...

 A alguién le andan en Ubuntu 7.10? Sería Anjuta 2.2.0 y Glade 2.12.1 en mi caso...

+1
0
-1
Imagen de robertour
+1
0
-1

agreguen este repositorio e instalan la versión que está ahí...

 deb http://ppa.launchpad.net/robster/ubuntu gutsy main 

primero desintalen la vieja 

OJO en otros foros se ha dicho que es universe

  deb http://ppa.launchpad.net/robster/ubuntu gutsy universe

pero a mi no me sirvió 

 

+1
0
-1