Ayuda para instalar ATi X1900 en Ubuntu 7.10 !!!! (SOLUCIONADO)

Imagen de danfast
0 puntos

Saludos al foro, primero quiero decir que soy nuevo en Linux, vengo desde hace tiempo contemplando cambiar el xp y sus pantallazos azules por linux, al ver esos efectos 3d de escritorio y el rendimiento de la maquina y la estabilidad me cautivo.

pero bueno, el problema es que instalo Ubuntu 7.10 y al instalar los drivers para la tarjeta ati todo parece ir de maravilla pero al reiniciar la maquina se pone la pantalla en negro o aparentemente va bien, pero el rendimiento de la tarjeta de video se ve demasiado pobre y al activar los efectos de ventanas y escritorio se pone la pantalla en blanco.

E tratado con otras distribuciones pero sigue igual.

Me esta costando muchos dolores de cabeza poder utilizarla en todo su esplendor, (en windows xp va de maravilla), pero no pierdo las esperanzas.Lei por todos lados y no logro que funcione adecuadamente. Ayyuuuddaaaa!!!

AMD X2 4600 Am2

Mother ASUS M2NPV-VM

Ati X1900 512 mb crossfire

disco 250 gb SATa 1

I gb RAm DDR2

Imagen de djkernel
+1
0
-1

Bueno, yo tengo una ATI y si me tomó como un mes en buscarle solución, mi primera pregunta es

¿Cuando Instalaste el ubuntu estabas conectado a internet? 

si no es así, vuelve a instalarlo solo tienes que conectar tu cable de red, cuando termine y reinicies te va a decir que hay controladores restringidos sin usar, de ahí los instalas y reinicias, el primer paso esta dado, ahora solo necesitas instalar XGL y listo, como aqui paso a paso

En una terminal Tipea:

fglrxinfo

si te dice que no esta instalado, en la misma ternimal te dice que poner para instalarla

si ya esta instalada te debe de dar esto:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS Series
OpenGL version string: 2.0.6334 (8.34.

Instalar XGL: (En La Terminal)

sudo apt-get update

Y Despues:

apt-get install xserver-xgl

Configura XGL:

sudo gedit /usr/local/bin/startxgl.sh

se abrira un archivo en el pon:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

Salva & Cierra El Archivo

Has el scrip ejecutable:

sudo chmod a+x /usr/local/bin/startxgl.sh

Crea XGL Login:

sudo gedit /usr/share/xsessions/xgl.desktop

se abrira un archivo en el pon
:

[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Comment=Start an Xgl Session
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Applicatio

Salva & Cierra El Archivo

Cambiando La Configuracion Del Repositorio:

sudo gedit /etc/apt/preferences

se abrira un archivo en el pon:

Package: *
Pin: release o=lupine
Pin-Priority: 1000
Salva & Cierra El Archivo

Actualiza El Sistema:

sudo apt-get update

  Saludos

 

+1
0
-1
Imagen de danfast
+1
0
-1

La mayor parte de las veces que e instalado no a estado conecta a internet,

por el momento no tengo en la casa pero si tengo la manera de hacerlo.y voy a tratar ahora mismo. un detalle nada mas , cuando uso el comando "fglrxinfo" no sale nada de ati claro que tu tienes un modelo diferente pero en lugar de eso sale algo de "Mesa" no recuerdo exactamente, sirve de algo? tal vez este ahi un problema.

+1
0
-1
Imagen de danfast
+1
0
-1

La mayor parte de las veces que e instalado no a estado conecta a internet,

por el momento no tengo en la casa pero si tengo la manera de hacerlo.y voy a tratar ahora mismo. un detalle nada mas , cuando uso el comando "fglrxinfo" no sale nada de ati claro que tu tienes un modelo diferente pero en lugar de eso sale algo de "Mesa" no recuerdo exactamente, sirve de algo? tal vez este ahi un problema.

 Espero tu ayuda...

+1
0
-1
Imagen de danfast
+1
0
-1

La mayor parte de las veces que e instalado no a estado conecta a internet,

por el momento no tengo en la casa pero si tengo la manera de hacerlo.y voy a tratar ahora mismo. un detalle nada mas , cuando uso el comando "fglrxinfo" no sale nada de ati claro que tu tienes un modelo diferente pero en lugar de eso sale algo de "Mesa" no recuerdo exactamente, sirve de algo? tal vez este ahi un problema.

 Espero

+1
0
-1
Imagen de danfast
+1
0
-1

cuando e estado en internet si me sale lo de restricted drivers pero nunca e hecho lo demas tendre que tratar

+1
0
-1
Imagen de djkernel
+1
0
-1

lo del fglrxinfo que error te da?? copialo y pégalo, aqui, y si te recomiendo que los instales con conexión a inter, si no te va a dar muchos problemas más adelante, saludos

+1
0
-1
Imagen de danfast
+1
0
-1

me sale diferente

Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.1)    

vamos bien hasta ahora?   segui tus instrucciones al pie de la letra 

+1
0
-1
Imagen de danfast
+1
0
-1

al querer activar los efectos me aparece

"The Composite extension is not available" 

+1
0
-1
Imagen de djkernel
+1
0
-1

Al Compañero rey le preguntaría: ¿Ya lo probaste?, es "n" cantidad de foros tienen problemas por ser Beta o la primera versión final que sale y son pocos los agraciados que logran hacer funcionar esos mugrosos driver's

regresando al tema, vas  bien, eso es lo que te debe de salir, no me preguntes por que pero en gusti asi sale, son los que mejor se acomodan a tu T. de video, sigue las instrucciones reinicia y listo!!, el manual que te pasé es el más estable, el que rey puso, es uno nuevo que salio por el 20 de octubre y está resultando muy inestable.

Saludos!! 

+1
0
-1
Imagen de seaofgrass
+1
0
-1

Con este manual te podras instalar el ultimo driver de ati. Todo el mundo habla maravillas de el, muy mejorable aun, pero viendo lo que teniamos...

Yo sigueindo el manual consegui instalarlo sin problemas y que me funcionase, aunque el rendimiento conseguido no me gusto mucho (yo creo que en feisty con los drivers libres me iba mejor) y segui usando metacity.

EL problema vino cuando hoy me disponia a activar el comiz y me dice que no se puede, voy a mirar glxinfo y me sale un error que ahora me disponia a postear.

Aqui dejo el manual, que ya se me olvidaba.

Instalación manual del driver ATI 8.42.3 en Ubuntu Feisty Fawn 7.04 / Ubuntu Gutsy Gibbon 7.10

 

1 - Procedemos a descargar el driver propietario de la página oficial de ATI-AMD

Descargamos el último driver correspondiente a nuestra tarjeta en www.ati.amd.com/support/driver.html (Última versión 8.42.3). Para los pasos siguientes, podemos loguearnos como Root para omitir el exceso de "sudo"

2 - Instalamos las herramientas necesarias, para ello abrimos un terminal y ejecutamos los comandos:

$ sudo apt-get update
$ sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper
$ sudo apt-get install debconf libstdc++5 linux-headers-generic
3 - Creamos los paquetes .deb:

Abirmos un terminal, nos dirigimos a la carpeta en donde descargamos el driver y ejecutamos:

$ sudo bash ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Ubuntu/feisty
En caso de ser Gutsy Gibbon, reemplazamos por –buildpkg Ubuntu/gutsy

4 - Debemos betar el módulo fglrx

Por defecto los paqutes de Ubuntu Feisty ya que incluyen una versión de un módulo anterior (8.algo), el mismo caso en Gutsy Gibbon. Debemos hacer esto para asegurarnos de que el nuevo módulo del kernel sea utilizado en vez del anterior. Para ello, abrimos un terminal y editamos el archivo necesario:

gedit /etc/default/linux-restricted-modules-common

y en la línea DISABLED_MODULES="" añadimos fglrx, quedando de la siguiente manera:

DISABLED_MODULES="fglrx"

5 - Eliminamos cualquier paquete fglrx viejo:

rm /usr/src/fglrx-kernel*.deb
6 - Procedemos a instalar los paquetes .deb que creamos: 

Abrimos un terminal y ejecutamos el comando:

dpkg -i xorg-driver-fglrx_8.42.3-1*.deb fglrx-kernel-source_8.42.3-1*.deb
dpkg -i fglrx-amdcccle_8.42.3-1*.deb xorg-driver-fglrx-dev_8.42.3-1*.deb

Si te da algún error diciendo que no encuentra los paquetes, debemos instalarlos uno por uno, tal como está escrito arriba, pero con un solo paquete en cada intento.

Nótese que entre cada paquete hay un espacio para separarlos.

7 - Procedemos a compilar el kernel (ejecutamos cada comando por orden):

module-assistant prepare module-assistant update module-assistant build fglrx module-assistant install fglrx depmod -a

8 – Estos pasos fueron eliminados en la instalación de este driver, ya que el mismo crea la carpeta y enlace simbólico, pero no está demás chequearse para asegurar (no importa si ya existen; no sobreescribirá nada):

Creamos la carpeta:

mkdir /lib/modules/$(uname -r)/volatile

Creamos un enlace simbólico:

ln -s /lib/modules/$(uname -r)/misc/fglrx.ko /lib/modules/$(uname -r)/volatile/fglrx.ko

9 - Ahora procedemos a configurar nuestro driver:

aticonfig --initial --input=/etc/X11/xorg.conf aticonfig --overlay-type=Xv

Ahora debemos reiniciar el equipo (no es suficiente reinciar el servidor de X).

Al regresar al nuestro escritorio, abrirmos un terminal y ejecutamos el siguiente comando para comprobar si efectivamente el driver se instaló correctamente:

fglrxinfo

y nos debe aparecer algo como esto:

display: 0.0 screen: 0

OpenGL vendor string: ATI Technologies Inc.

OpenGL renderer string: RADEON X800 GTO # el nombre de nuestra tarjeta

OpenGL version string: 2.0.6958 Release

Si todo está bien, hemos instalado nuestro driver correctamente!

Ahora ejecutamos el siguiente comando para verificar si realmente tenemos aceleración gráfica:

glxinfo | grep direct

y deberá salir algo como esto:

direct rendering: yes

Si el resultado es “yes”, ya tenemos aceleración gráfica en nuestra tarjeta.

www.tuxapuntes.com

+1
0
-1
Imagen de seaofgrass
+1
0
-1

Este es el hilo con el error comentado:

http://www.ubuntu-es.org/index.php?q=node/69378 

+1
0
-1
Imagen de danfast
+1
0
-1


Hice lo del manual y no me dio resultado, me baje versiones anteriores del driver para Ati x1900 y no me dio resultado, si instalo los drivers parece que va bien pero si si pongo enable en controladores restringodos, al reiniciar en vez de salir pantalla de login se pone la pantalla en negro, son muchas las veces que e vuelto a  reinstalar todo el sistema y no logro avances, si desconecto la ati hago trabajar la nvidia integrada parece que van mejor las cosas pero no inverti en esa tarjeta para tenerla guardada. De cualquier manera no puedo ver los efectos en todo su esplendor y me esta costando trabajo entender los comandos de linux y procedimientos, talvez estaba muy acostumbrado a windows, pero sigo buscando soluciones y la esperanza nunca muere,

Ayuda ......otravez
+1
0
-1
Imagen de Plin
+1
0
-1

Muchas gracias a seafograss por el manual paso a paso. A mi me pasa lo mismo que a danfast, aunque en mi caso se trata de una Radeon x800 GTO, lo que me sorprende especialmente porque la del ejemplo del manual parece ser la misma. Cuando completé la instalación, aparentemente todo estaba en orden y pude cambiar la resolución de la pantalla. Pero tras reiniciar el ordenador la pantalla apareció totalmente en negro con algunas manchas y, tras unos segundos, la ventana de aviso de que había que ejecutar Ubuntu a baja resolución. He instalado Ubuntu hoy -por vez primera-, y fue el mismo mensaje de error que me dio tras actualizar en línea los drivers en el proceso de instalación.

En fin, sigo buscando una solución, aunque sea navegando a 800x600 y 60 Hz de refresco.

Un saludo. 

+1
0
-1
Imagen de migueleonm
+1
0
-1

El problema es que el link simbólico

sudo ln -sf /lib/modules/$(uname -r)/misc/fglrx.ko /lib/modules/$(uname -r)/volatile/fglrx.ko 

Se borra al reiniciar, para solucionarlo se puede hacer lo siguiente:

1) Se vuelve a crear el link simbólico (ya que se borró al reiniciar)

2) Se abre el archivo rc.local

sudo gedit /etc/rc.local

3)Copiar estas dos lineas justo arriba del comando "set 0"

rmmod fglrx insmod /lib/modules/$(uname -r)/misc/fglrx.ko

Reiniciar y correr fglrxinfo para comprobar.

Sacado de http://wiki.cchtml.com/index.php/Ubuntu_Gutsy_Installation_Guide

 

 

 

+1
0
-1
Imagen de Plin
+1
0
-1

Gracias migueleonm. Desde luego que después de seguir los pasos que dices algo cambiaba -y los drivers 7.11-, pero el sistema era totalmente inestable, además de no tener aceleración. Por lo menos ya he aprendido con cuáles funciona un poco mejor, de los de ubuntu, y estos son no los vesa que usa el sistema por defecto, sino los "ati mach..etc", con lo cual puedo poner resoluciones más dignas (con la pantalla totalmente descentrada, eso sí) y tengo aceleración 3d. Por ahora me conformo con esto, aunque sospecho que el rendimiento no es el máximo, y creo que simplemente por el momento no hay soporte 100% para este modelo de tarjeta gráfica.

La tarjeta, por cierto, me la vendieron como una Radeon X800 GTO, pero tiene unas frecuencias raras (475-450 en lugar de 400-490) que corresponderían a la X800 PRO, y así me la detectan algunos programas de diagnóstico. La GPU es R420.

http://www.gpureview.com/show_cards.php?card1=356&card2=38

En fin, así están las cosas, seguiré jugueteando con el Ubuntu antes de poder cambiar definitivamente de sistema operativo, empezando por la aparición de unos controladores en condiciones.

+1
0
-1
Imagen de Plin
+1
0
-1

Lo siento, envié el comentario dos veces, y no sé cómo se elimina, jejeje.

+1
0
-1
Imagen de danfast
+1
0
-1

de tanto tratar y tratar, decidi usar la tarjeta integrada nvidia y me a ido mejor, al principio tuve problemas con las ventanas ( sin botones y terminal en blanco) pero ya esta solucionado.

tendre que esperar a que salga una version mas estable de drivers para ati y tenga mejor soporte, mientras tanto usare la onbord.

 

+1
0
-1
Imagen de danfast
+1
0
-1

Por fin logre mi objetivo, de tanto tratar y tratar , instale la version de Ubuntu Ultimate 7.10, que esa era mi objetivo, cheque en el sitio de ati y habia unos drivers nuevos (7.11) y los instale por medio de Envy, y sorpresa funcionaron perfectamente, ya no tengo ningun ploblema.

Lo bueno de todo esto fue que aprendi como moverme dentro de linux, (vengo de windows) y parece que lo entiendo mejor, ahora me gusta mas, pero me gustaria conocerlo mejor.

Gracias al foro!! y Feliz Año Nuevo!!!

+1
0
-1
Imagen de bean
+1
0
-1

si te parece, eso sí, edita el título y pon al lado: solucionado, asi otros que busquen puedan hallarla.

+1
0
-1