ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 WebCam

Imagen de yochule
0 puntos

hola gente....

he estado intentando hace como un mes de instalar la camara y sigo sin poder. pense q despues de instalar la nueva version de cero la camara saldria andando al pelo pero no fue asi. tengo instalada la version 7.10 amd 64.

en varios lugares he leido q esta camara deberia estar soportada con el driver gspca q trae la instalacion de ubuntu, pero no fue asi, asiq instale el nuevo driver gspcav1-20070508, desde la pagina de michel xhaard, pero no puedo ver nada. no pude instalar ni el spcagui ni el spcaview de esa pagina porq (supongo) q estan hechos para 32bit. igua, he estado probando la camara con el camorama, con el selector de sistema multimedia, con el vlc y con el ekiga, pero con todos pasa lo mismo, veo la pantalla negra y no tengo imagen. la camara trae un microfono incorporado q anda al pelo.

si desenchufo la camara y en una terminal hago un dmesg, tengo:

[ 1468.480142] usb 1-1: USB disconnect, address 4
[ 1498.472796] usb 1-1: new full speed USB device using uhci_hcd and address 5
[ 1498.669756] usb 1-1: configuration #1 chosen from 1 choice
[ 1498.672724] usb 1-1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x301B)
[ 1498.759545] usb 1-1: No supported image sensor detected
[ 1498.759596] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: USB GSPCA camera found.(ZC3XX)
[ 1498.759602] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: [spca5xx_probe:4098] Camera type JPEG
[ 1498.759607] /home/marchu/Escritorio/gspcav1-20070508/Vimicro/zc3xx.h: [zc3xx_config:515] Sensor ID:11
[ 1499.435079] /home/marchu/Escritorio/gspcav1-20070508/Vimicro/zc3xx.h: [zc3xx_config:525] Find Sensor UNKNOW_0 force Tas5130
[ 1499.438217] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: [spca5xx_getcapability:1215] maxw 640 maxh 480 minw 176 minh 144

lo q no entiendo mucho, pero puedo ver q se da cuenta q hay una camara q funciona con compresio jpeg, q le carga el modulo zc0301, q segun parece no detecta el sensor de video, no se...

bue, si alguien me puede dar una mano....se lo agradeceria... 

Imagen de yochule
+1
0
-1

mas informacion:

chuleymar@losotro:~$ dmesg | tail
[10200.701996] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: [gspca_set_isoc_ep:903] ISO EndPoint found 0x81 AlternateSet 7
[10200.947191] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: VIDIOCMCAPTURE: invalid format (7)
[10200.952813] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: [gspca_set_isoc_ep:903] ISO EndPoint found 0x81 AlternateSet 7
[10201.169372] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: VIDIOCMCAPTURE: invalid format (9)
[10201.169608] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: VIDIOCMCAPTURE: invalid format (14)
[10201.170119] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: VIDIOCMCAPTURE: invalid format (13)
[10201.170345] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: VIDIOCMCAPTURE: invalid format (16)
[10201.170569] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: VIDIOCMCAPTURE: invalid format (11)
[10201.170792] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: VIDIOCMCAPTURE: invalid format (6)
[11200.460104] /home/marchu/Escritorio/gspcav1-20070508/gspca_core.c: [gspca_set_isoc_ep:903] ISO EndPoint found 0x81 AlternateSet 7
chuleymar@losotro:~$ dmesg |grep V4L
[   45.416332] zc0301: V4L2 driver for ZC0301[P] Image Processor and Control Chip v1:1.07
cuando abro el camorama o el vlc, a la camara se le prende la luz, pero no muestra imagen (solo la pantalla negra). 

la camara es esta: http://www.eurocase.com/version2/ind...d_producto=479

alguien tiene una solucion a mi problema? 

+1
0
-1
Imagen de yochule
+1
0
-1

bueno lo pongo aca, si algun moderador lo quiere poner en una conversacion aparte, ya q es la solución a algo, o por lo q fuera, me parece bien..

en fin, la otra noche me puse en contacto con leandro, un buen pibe, q en media hora termino solucionando el problema.hizo un patch: http://sourceforge.net/mailarchive/forum.php?thread_name=c0fe51708f0aa0a...

de ahí se bajan el patch "cs2102k_and_tas5130ck_gspcav1-20071224.patch", abren una terminal y se mueven donde tengan descomprimido el driver (el de la pagina de michael) gspcav1-20071224 y el comando para usarlo es :

chuleymar@losotro:~$ patch -p1 < /directorio_donde_guardaste_el_parch/cs2102k_and_tas5130ck_gspcav1-20071224.patch (porq por ahi el patch lo dejaron el el escritorio, por ejemplo)

despues
#make
#make install
#depmod -a

y listo.....

PD: no se si servira para toooodddas las camaras con id 0ac8:301b, pero al fin a MI me funciono. espero q te sirva a vos tambien...

+1
0
-1
Imagen de girlnaz
+1
0
-1

holas

busco el patch ke decis pero no lo encuentro

ahi esta el de leandro

por fis si me puedes ayudar

gracias

+1
0
-1

si no puedes ayudar, molesta; lo importante es participar

?@z?& ?

Imagen de yochule
+1
0
-1

fijate en el enlace te manda a un correo q envio leandro, justo debajo del titulo del mensaje dice attachments y esta el link para bajar el pach...

suerte 

+1
0
-1
Imagen de girlnaz
+1
0
-1

muchisimas gracias ke pena conti

pero al hacer # patch -p1 /home/systecom/Escritorio/cs2102k_and_tas5130ck_gspcav1-20071224.patch
se keda esperndo la terminal

ke pena 

+1
0
-1

si no puedes ayudar, molesta; lo importante es participar

?@z?& ?

Imagen de yochule
+1
0
-1

... piensen que esto es un foro de ayuda, asique por fabor escriban con todas las letras en forma clara...

bueno, supongo que habras quitado las almoadillas delante de patch -p1.... tambien supongo que te habras movido a la carpeta gspcav1-20071224?

ojala sea eso, asi la podes sacar andando....suerte 

+1
0
-1
Imagen de lcostantino
+1
0
-1

El problema es que no es patch -p1 patch_file, te falta el <
prueba haciendo

# patch -p1 < /directorio/archivo_patch

( falta el <),

+1
0
-1
Imagen de girlnaz
+1
0
-1

ke pena, si me faltaba el signo menor

el archivo lo tengo guardado en el escritorio pero al hacer como root y ubicada en el escritorio:

root@SERVIDOR:/home/systecomjl/Escritorio# patch -p1 signo_menor_q /home/systecomjl/Escritorio/cs2102k_and_tas5130ck_gspcav1-20071224.patch

me muestra:

can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nru gspcav1-20071224/Vimicro/cs2102.h gspcav1-20071224-kokom/Vimicro/cs2102.h
|--- gspcav1-20071224/Vimicro/cs2102.h 2006-09-14 09:39:38.000000000 -0300
|+++ gspcav1-20071224-kokom/Vimicro/cs2102.h 2008-02-23 16:53:05.000000000 -0300
--------------------------
File to patch:

y no se que archivo me esta pìdiendo ak, y si le escribo el mismo, es decir, /home/systecomjl/Escritorio/cs2102k_and_tas5130ck_gspcav1-20071224.patch
asi:

File to patch: /home/systecomjl/Escritorio/cs2102k_and_tas5130ck_gspcav1-20071224.patch

sale lo siguiente:


patching file /home/systecomjl/Escritorio/cs2102k_and_tas5130ck_gspcav1-20071224.patch
Hunk #1 FAILED at 805.
1 out of 1 hunk FAILED -- saving rejects to file /home/systecomjl/Escritorio/cs2102k_and_tas5130ck_gspcav1-20071224.patch.rej
can't find file to patch at input line 851
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nru gspcav1-20071224/Vimicro/tas5130c.h gspcav1-20071224-kokom/Vimicro/tas5130c.h
|--- gspcav1-20071224/Vimicro/tas5130c.h 2006-09-14 09:39:38.000000000 -0300
|+++ gspcav1-20071224-kokom/Vimicro/tas5130c.h 2008-02-23 17:49:21.000000000 -0300
--------------------------
File to patch:

agradezco de todas maneras todas las respuestas y comentarios

+1
0
-1

si no puedes ayudar, molesta; lo importante es participar

?@z?& ?

Imagen de yochule
+1
0
-1

hace asi, copiate el patch (cs2102k_and_tas5130ck_gspcav1-20071224.patch) y metelo dentro de la carpeta gspcav1-20071224 (osea el controlador q te bajaste la la pagina de michael xaard.... y despues hace asi:
@~#cd /home/systecomjl/camara/gspcav1-20071224 (suponiendo q lo tenes arreglado asi)
@~#patch -p1 signo_menor_que cs2102k_and_tas5130ck_gspcav1-20071224.patch

ahi seguro te sale andando.... (es q no encontraba los ficheros q tenia q parchear, por eso te tiraba error) q tengas suerte y nos vemos (cualquier cosa preguntame en el irc chat #ubuntu-ar) besos

+1
0
-1
Imagen de elmarch
+1
0
-1

Hola girlnaz, estoy intentando seguir los pasos que pones aqui, pero no se que pongo en "signo_menor_que"? podria me aclarar eso por favor, estoy hace mucho intentando hacer funsionar esa camera, é una lastima pq todo lo demas esta perfecto, gracias de antemano...saludos!

+1
0
-1