Compilar compiz-fusion-plugins-unsupported en gusty gibbon

Imagen de andresrinaldi_uy
0 puntos

Instalar compiz-fusion-plugins-unsupported-0.5.2 en (K)Ubuntu Gusty Gibbon

Bueno, despues de mucho tiempo lo logre...pude compilar desde las fuentes los plugins unsupported en gusty!

Luego de haber instalado compiz fusion desde los repositorios oficiales hice lo que detallara a continuacion para instalar dicho paquete.

 

1º Descargar paquetes para poder compilar el paquete

sudo apt-get install build-essential gitweb curl autoconf automake automake1.9 libtool intltool libxslt1-dev xsltproc libwnck-dev libxcomposite-dev libpng12-dev libsm-dev libxrandr-dev libxdamage-dev libxinerama-dev libstartup-notification0-dev libgconf2-dev libgl1-mesa-dev libglu1-mesa-dev libmetacity-dev librsvg2-dev libdbus-1-dev libdbus-glib-1-dev libgnome-desktop-dev libgnome-window-settings-dev python-dev python-pyrex build-essential libxcomposite-dev libpng12-dev libsm-dev libxrandr-dev libxdamage-dev libxinerama-dev libstartup-notification0-dev libgconf2-dev libgl1-mesa-dev libglu1-mesa-dev libmetacity-dev librsvg2-dev libdbus-1-dev libdbus-glib-1-dev libgnome-desktop-dev libgnome-window-settings-dev gitweb curl autoconf automake automake1.9 libtool intltool libxslt1-dev xsltproc compiz-bcop compiz-core compiz-dev libcm7 libcompizconfig0  libcompizconfig0-dev libcompizconfig-backend-gconf libcompizconfig-backend-kconfig libdecoration0 libdecoration0-dev  libemeraldengine0 libgnome-compiz-manager0 libgnome-compiz-manager0-dev phyton-compizconfig

Puede que alguna de las librerias no se usen asi como pueden faltar (en uno de los pasos siguientes aparecera un error mencionando el nombre de paquete que falta...buscando en google el error dira cual paquete instalar)

2º Descargar el paquete compiz-fusion-plugins-unsupported-0.5.2.tar.bz2 desde las fuentes

http://releases.compiz-fusion.org/0.5.2/compiz-fusion-plugins-unsupported-0.5.2.tar.bz2

descomprimir en una carpeta y ejecutar una consola en la carpeta en la que se descomprimio el archivo.

 

 3º en la consola escribimos lo siguiente:

./configure –prefix=/usr 

(puede saltar un error porque falta algun paquete)

 

make 

(si aparece algo como lo siguiente “make[2]: No se hace nada para `all-am'.” no alarmarse que no es un error)

 

sudo make install 

(idem paso anterior)

 

4º en el ccsm ya podremos seleccionar los nuevos plugins que vienen en dicho paquete :D

Tal vez solo me funcione a mi...es que estuve como un mes tratando e instala paquetes de todo tipo :S. Si alguien lo intenta y le funciona por favor avisar...voy a estar en la vuelta, cualquier duda intentare ayudar...no esperen mucho de mi ya que uso linux hace un mes :S...pero bue...por cosas de la vida pude lograr compilar el paquete.

Salu2

Imagen de elclon90
+1
0
-1

Mi problema es> Descargue el paquete http://releases.compiz-fusion.org/0.7.2/compiz-fusion-plugins-unsupporte... luego lo di extraer y bien lo tengo en una carpeta y , aqui viene mi problema, Noce como instalarlo con la terminal. esta es la ruta de la carpeta, /home/chino/compiz-fusion-plugins-unsupported-0.7.2,      agradestu su ayuda

+1
0
-1
Imagen de andresrinaldi_uy
+1
0
-1

Como se trata de un fuente, debes abrir una terminal y dirijirte a donde descomprimiste el archivo:

cd /home/chino/compiz-fusion-plugins-unsupported-0.7.2

Ahora ls para ver si estan los archivos

y para compilar seguir los mismos pasos que puse mas arriba

./configure

make

sudo make install

Salu2 y suerte.

PD: Hay un archivo llamado INSTALL incluido, lo abres con un editor de texto y alli dice como instalarlo, por si acaso... 

Hardware: Lo que golpeas...Software: La causa.

http://www.openstickers.com/ -> Calcomanias Ubuntu-Free Software, etc :D

+1
0
-1

Hardware: Lo que golpeas...Software: La causa.

Imagen de XxAndoxX
+1
0
-1

Intentado instalar el puglin de la nieve, el 0.7.2, en ubuntu 9.10 karmic koala, a la hora de compilar hago lo siguiente:
---
lightzero@lightzero:~$ cd /home/lightzero/Descargas/Appts/compiz-fusion-plugins-unsupported-0.7.2
lightzero@lightzero:~/Descargas/Appts/compiz-fusion-plugins-unsupported-0.7.2$ ./configure --prefix=/usr
----

y empiaza a ejecutar comando y al final sale un error:

checking for BCOP... configure: error: Package requirements (bcop >= 0.5.2) were not met:

No package 'bcop' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BCOP_CFLAGS
and BCOP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

ok tu dices que lo ignoremos y sigamos

entonces pongo lo suiente y sale ese error

---
lightzero@lightzero:~/Descargas/Appts/compiz-fusion-plugins-unsupported-0.7.2$ make
make: *** No se especificó ningún objetivo y no se encontró ningún makefile. Alto.
lightzero@lightzero:~/Descargas/Appts/compiz-fusion-plugins-unsupported-0.7.2$
---

es decir no compila nada y ahi me quedo

navegando por la carpeta encuentro solo dos archivos el "Makefile.am" y el "Makefile.in"
que según yo deberían ser, uno de los dos no se cual, el que con el comando make debería empezar a compilar pero no lo hace, entonces que hago si no compila no instala y si no instala no hay nieve. Espero impaciente tu respuesta

Mirate por dentro eres más de lo que eres ahora, Lion King

+1
0
-1

Mirate por dentro eres más de lo que eres ahora, Lion King

Imagen de XxAndoxX
+1
0
-1

Encontre como solucionarlo en esta página http://www.lathund.nu/2009/11/07/installera-och-kom-igang-med-compiz-snow/, no viene en español pero segui los comandos y listo, al parecer el problema eran las fuentes "compiz-fusion-plugins-unsupported-0.7.2" ya que con las de la página lathud el "makefile si compilo e instalo

Gracias de antemano

Mirate por dentro eres más de lo que eres ahora, Lion King

+1
0
-1

Mirate por dentro eres más de lo que eres ahora, Lion King

Imagen de patagonian18
+1
0
-1

 Abre la terminal y escribes:

cd  compiz-fusion-plugins-unsupported-0.7.2

(apretando el tabulador se autocompleta el nombre, no es necesario escribirlo completo).

Una vez en el directorio, sigue las instrucciones que te dan arriba.

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de manuel carrillo
+1
0
-1

Despues de hacer todo lo de este mini tutorial no me aparece nada que tengo que hacer ???

+1
0
-1
Imagen de andresrinaldi_uy
+1
0
-1

Con nada te refieres a que no te aparecieron plugins nuevos en el ccsm???.

Esta bien instalados, no te dio ningun error la terminal??

Saludos. 

Hardware: Lo que golpeas...Software: La causa.

http://www.openstickers.com/ -> Calcomanias Ubuntu-Free Software, etc :D

+1
0
-1

Hardware: Lo que golpeas...Software: La causa.

Imagen de manuel carrillo
+1
0
-1

lo que pasa es que ya habia descargado el 0.5.2 pero no me sirvio asi que decidi descargar el 0.7.2 pero como ya tenia el anterior y no lo desinstale me da error no me descomprime la carpeta ni por consola ni manualmente gracias por cualquier ayuda y perdon por mi ignorancia XD

+1
0
-1