Wi-Fi a veces si y a veces no

Imagen de linux_padawan
0 puntos

cuando instale por primera vez el ubuntu 7.10 Gutsy me reconocio la tarjeta y todo perfecto.

algunas semanas mas tarde, sencillamente no funciono el Wi-Fi

como no soy un usuario experto y no encontre nada que me solucionara, hice lo que todo buen usuario de wndws hace para solucionar un problema, formatear y reinstalar....

asi, de nuevo, todo perfecto, pero un par de semanas despues, Wi-Fi out!!

si al principio funciona bien, por que sencillamente deja de funcionar???

que puedo hacer esta vez, que no sea reinstalar el ubuntu?

mi laptop es una Compaq Presario R3000, Pentium4, 1Gb-RAM, tarjeta inalambrica: BCM 4306 802.11b/g

 

graxias!! 

Imagen de TASADAR-F
+1
0
-1

¿Te siguen apareciendo redes al pulsar el icono de al lado del reloj o es como si hubiese dejado de funcionar la tarjeta wifi?

+1
0
-1
Imagen de linux_padawan
+1
0
-1

ya no siguen apareciendo las redes inalambricas, es como si dejo de funcionar la tarjeta Wi-Fi

gracias TASADAR-F 

+1
0
-1

Quien te habla mal de los demas, habla mal de ti....es su costumbre

Imagen de linux_padawan
+1
0
-1

Alguna luz en esto del Wi-Fi

+1
0
-1

Quien te habla mal de los demas, habla mal de ti....es su costumbre

Imagen de TASADAR-F
+1
0
-1

Mandame el archivo /var/log/kern.0.log al email y veremos exactamente cual es elproblema.

tasadar2arrobagmail.com 

+1
0
-1
Imagen de dga205
+1
0
-1

A mi me pasa algo similar, tengo una laptop HP c518la y la placa es una boardcom.

Me anda bien la el wifi, pero, solo si estoy cerca del accespoint, si me alejo, e intento conectarme, la señal me da que es buena, de un70 o 80%, pero no me deja conectarme, me pide constantemente la clave wep.

Con windows no me pasa eso, a esa misma distancia del accespoint me conecto sin problemas, y el indicador de nivel de señal dice que es baja, pero entra.

Que puede ser este problema? por que en windows si entra y en linux no? 

+1
0
-1
Imagen de TASADAR-F
+1
0
-1

EL problema es que el driver para windows de Broadcom esta mejor hecho que el de linux por eso en windows no te aparece ese problema.

La proxima version de Ubuntu 8.04 incluira un driver nuevo de Broadcom que incorpora bastantes novedades que puede que solucionen tus problemas 

+1
0
-1
Imagen de Julius-Caesar
+1
0
-1

Hola Padawan.

Yo también padezco de este mal con mi Intel PROwireless 3945abg; El WiFi se pone "en huelga" cuando quiere.

Creo que hay problemas entre "network-manager" y algunos drivers.

Ayer mismo tuve que afrontar una de esas "huelgas" imprevistas e "¡¡ ilegales !!".

Mi solución fué drástica: Desinstalé "network-manager", reinicié, y lo volví a instalar. Problema resuelto.

A tener muy en cuenta:

Una vez desinstalado, no tendremos Internet, obvio pero importante; sin internet ¿cómo lo volvemos a instalar?

Edité el archivo de los repositorios para que el único repositorio disponible fuera mi DVD de Ubuntu (/etc/apt/sources.list).

Con ello volví a instalar "network-manager" a través de Synaptic, sin disponer de Internet.

 

Saludos.

+1
0
-1
Imagen de linux_padawan
+1
0
-1

Muchas Graxias Julius!! 

Bueno, no se mucho de la configuracion en ubuntu, pero me parece muy lógico tu enfoque.

Preguntas:

Hay alguna forma de mantener en una carpeta los repositorios del "Network Manager"? y asi tenerlos disponibles para cuando le suceda esto a uno. Cuales deberían ser estos archivos/ficheros? Puedes enviarme un listado?

En teoría se que se puede, pero no se como hacerlo: se puede hacer un shell-script que te haga todo este trabajito?, desinstalar y volver a instalar el network-manager.

Se que esta no sería la solución definitiva, pero me supongo que servirá mientras la averiguamos.

 

saludos  y muchas gracias!!

 

+1
0
-1

Quien te habla mal de los demas, habla mal de ti....es su costumbre

Imagen de Julius-Caesar
+1
0
-1

En primer lugar, ¿has desinstalado y vuelto a instalar "network-manager"?, en caso afirmativo,

¿te ha funcionado a ti también?

Algunas veces me bastó con reiniciar simplemente, sin desinstalar/instalar nada.

 

En cuanto a tu pregunta, te doy algunas pistas:

Todos los paquetes que descargas/instalas con Synaptic o con el comando apt-get, se guardan aquí:

 

/var/cache/apt/archives

 

Incluso si desinstalamos algo, los paquetes .deb seguirán estando ahí !!!

De hecho, esa ruta es una caché de paquetes, la cual, y que yo sepa, solo se borra ejecutando

el siguiente comando:

 

sudo apt-get clean

 

¿Te sirve de algo esta información?

 

Ahí va algo más interesante:

 

"aptoncd" (instalable desde Synaptic)

 

Este programa te crea una ISO con todos los paquetes + sus dependencias, que te hayas

instalado, en algún momento, con Synaptic o con el comando apt-get.

Imagínate que instalas "tropecientos" programas en tu ordenador. A continuación

usas "aptoncd" para que te cree una ISO con todo eso.

Grabas la ISO y te la llevas a un ordenador que no tiene conexión a Internet.

En ese ordenador usas "aptoncd" + el CD/DVD que has creado, e instalas todo lo

que quieras.

 

No sé si algo de esto te servirá pero creo que,

hay para probar e investigar durante un buén "ratito".

Nos vemos...

A bordo en Sevilla, a 1 de Diciembre de 2007

)=> Julius

 

+1
0
-1
Imagen de mr.potato
+1
0
-1

Contigo he visto la luz.

Ta luecc

+1
0
-1

 


¿Quieres respuestas?: busca " (SOLUCIONADO) " en el textbox de arriba a mano derecha y descubrirás un mundo de nuevas sensaciones. Busca antes de preguntar.

 

Imagen de JoMaRA
+1
0
-1

A mi me pasa lo mismo, aunque hace mucho que no me sucecede y no se porque. Pero me funcionaba bastante bien el siguiente comando:

$ sudo  dhclient
+1
0
-1
Imagen de linux_padawan
+1
0
-1

Hola,

He probado con todos los procedimientos que me he encontrado, con y sin ndiswrapper, con WiFi-Radar, con Wicd, y nada me funcionó.

Encontre este sitio, donde dice que todavía no funciona la coexistencia con bluetooth, y ese detalle lo había pasado por alto, y haciendo memoria, las veces que se me ha desconfigurado coinciden con las veces que he configurado el bluetooth, quisiera pensar que esa es la raiz del problema....

ahora, como desinstalo/inhabilito/quito el bluetooth?? 

 


Quien te habla mal de los demas, habla mal de ti....es su costumbre
+1
0
-1

Quien te habla mal de los demas, habla mal de ti....es su costumbre

Imagen de TASADAR-F
+1
0
-1

He estado revisando tus log y he podido comprobar que en el log del 27 de diciembre el driver se carga correctamente pero en el del 20 de noviembre hay un problema con el famoso firmware que instala el gestor de controladores restringidos

+1
0
-1
Imagen de ketk
+1
0
-1

Por aquí otro más con el mismo problema, lo que ocurre es que a mi sólo me pasa en una red (de 3 o 4 que uso normalmente) en el resto no he tenido problemas.

Los síntomas son los mismos, me dice que tengo red (solo algunas veces) pero no se conecta, o bien directamente no me detecta la red.

Efectivamente da igual el programa que se utilice, con network manager o con wifi radar el resultado es exactamente el mismo.

Yo tengo una intel pro wireless 3945abg.

Por otra parte ¿qué hay de la "solución" propuesta por JoMaRA ($ sudo dhclient).

A ver si entre todos damos con la solución.

--------------------------------------

Hay tres tipos de personas: las vivas, las muertas y las que caminan sobre el mar.

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de linux_padawan
+1
0
-1

Dejame decirte ketk que si intenté el $ sudo dhclient pero no me funcionó en aquella ocasión.

he comentado que si removí todo lo que tenía que ver con BlueTooth y ahora me funciona bien.

 

A ver que descubre nuestro amigo (el es el experto) TASADAR-F, gracias por la ayuda....

 

 

 


Quien te habla mal de los demas, habla mal de ti....es su costumbre

 

+1
0
-1

Quien te habla mal de los demas, habla mal de ti....es su costumbre

Imagen de TASADAR-F
+1
0
-1

Ketk tu tema es diferente porque tu tarjeta es una intel que funciona bastante bien como la mia y tendra algun problema puntual con la esa red.  Avisarte que la proxima version de Ubuntu llevara un driver totalmente nuevo que aumentara la velocidad de la tarjeta mas de un 50%.

El comando: sudo dhclient

Sirve para actualizar la puerta de enlace, ip y dns en caso de que las tengas dinamicas. Se suele usar en el caso de que apagues y enciandas el router y lo tengas conectado por cable de repente pierdes la conexion porque el router a cambiado de ip y la unica solucion es reiniciar o ejecutar dhclient

+1
0
-1
Imagen de ketk
+1
0
-1

Pues si, quizás sea un tema diferente, de momento, haré la prueba con el bluetooth y a ver que pasa (por probar...) y lo del nuevo driver ya lo he estado viendo, si tengo tiempo igual intento instalarlo ya en 7.10 si no, esperaré a que salga 8.04.

Gracias a todos

--------------------------------- 

Hay tres tipos de personas: las vivas, las muertas y las que caminan sobre el mar.

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de linux_padawan
+1
0
-1

Será algo relacionado con el BlueTooth?

Yo opté por quitar el BlueTooth y desactivarlo del arranque. 

por cierto, ya me esta funcionando el Wi-Fi, de echo en estos momentos estoy wireless ....

 

 

 


Quien te habla mal de los demas, habla mal de ti....es su costumbre

+1
0
-1

Quien te habla mal de los demas, habla mal de ti....es su costumbre

Imagen de Julius-Caesar
+1
0
-1

Últimamente no tengo problemas, claro que no me atrevo a tocar el network-manager (nm-applet ) para nada.

He probado el Wicd pero no me convence. Me parece más interesante pero el applet me desaparece cuando quiere.

Referente a desactivar el Bluetooth, ¿te refieres a esto?:

 

Sistema => Preferencias => Sesiones => Programas de inicio => Administrador de Bluetooth

 

Te pregunto para tomar nota, por si acaso me vuelve a fallar, que fallará seguro.

 

Sin ánimo de lucro, Julius.

+1
0
-1
Imagen de TASADAR-F
+1
0
-1

Parece que has descubierto el problema parece que el driver no soporta la coexistencia de ambas cosas.

Yo lo unico que he podido en los logs del kernel es que en los logs de dias que el wifi causaba un error no podia cargar el firmware del wifi pero no se sabia la causa. 

+1
0
-1