Problemas de latencias en Ubuntu Studio

Imagen de marcelu80
0 puntos

Hola a todos,

ya llevo casi 10 meses en Ubuntu y la verdad es que ya me manejo bastante bién en general pero el tema del sonido todavía se me resiste. Tras tener problemas con el Kernel de Ubuntu opté por canviar a Studio con el kernel rt. Ahora empiezo a entrar de verdad en el tema de sonido en Linux.

Lo primero que quiero probar es reproducir y hacer sonar Aeolus (estupendo sintetizador de organo, por otra parte) pero Jack me llena el registro de xrun de color rosa o rojo, lo cual significa que tengo problemas de latencia. He configurado las preferencias de jack de mil formas pero siempre tengo xrun y, claro está, un sonido absolutamente inaudible y lleno de distorsiones. Cierto es que trabajo con la tarjeta de sonido de placa, pero en Win2 reproduzco hasta 12 pistas de VST en Cubase sin ningún problema.

¿Hay algo más que deba mirar? ¿És normal que a pesar de tener el kernel rt todavía tenga problemas de latencia?

 

Saludos amigos.

 

 

Imagen de marcmg
+1
0
-1

 Buenas. Me pasa totalmente lo mismo que a tú. Desde hace tiempo estoy sacando humo para averiguar qué coño pasa con el audio y la latencia con jack. He probado con varias máquinas con placas base distintas, placas de sonido distintas y hasta placas de sonido externas (sound blaster). En todas me pasa lo mismo. He probado con 64Studio y UbuntuStudio. Supongo que de distribución no será, ni tampoco de kernel. Es algun problema con jack. Si pruebas cambiando el frames/period, notas cambio en distorsiones? A mí me pasa que si lo cambio me varia el tipo de distorsion, pero no llego a ningún parámetro en que se me oiga bien.

 Creo que no hay más que mirar... a no sé que haya algun tipo de configuración externa a jack... Pero estoy que ardo para encontrar una solución!

Ante todo un saludo! 

 

+1
0
-1
Imagen de marcelu80
+1
0
-1

Solucionado gracias a los amigos del foro Hispasonic. Se trata de ir jugando con los valores buffer period y frames de jack hasta encontrar la combinación que funcione con tu equipo. La mía 3/256.

 Saludos.

+1
0
-1
Imagen de valacard
+1
0
-1

Saludos yo tengo el mismo problema me podrias dar las especificaciones de tu pc para asi yo jugar con mi config no consigo q quede

la mia es

Procesador 2.2 Dual Core

2mb RAM

256 Nvidia Geforce7900

Sigmatel 7.1 Audio

 

+1
0
-1
Imagen de marcelu80
+1
0
-1

Procesador Intel Core 2 Duo 1.6Mhz

1Gb Ram

tarjeta de sonido Realtek de la misma placa Gigabyte.

Nada del otro mundo como ves. El consejo es que pongas 256 a frames y vayas subiendo los buffer de 2 hacia arriba. Si así no se soluciona cambia los frames a 512 y empieza de nuevo con los buffer. Recuerda reiniciar jack después de cambiar cada configuración para que los cambios surjan efecto. Tampoco te fijes mucho en los xrun ya que actualmente todavía tengo xrun pero el sonido es perfecto y eso que reproduzco varias pistas de midi en tiempo real con instrumentos virtuales. Ves probando con Qsynth o con algun otro sintetizador de los que viene por defecto (p.e. Aeolus+Virtual keboard).

Otro consejo es que te pases por el foro de Hispasonic, donde hay un apartado interesante de Música en GNU/Linux.

Saludos y suerte!

 

+1
0
-1
Imagen de danielcaraj
+1
0
-1

alabados sean!!!! creo que solucionaron el unico problema por el que no me mudaba completamente a GNU linux!!  tenia unos ruidos extraños cuando grababa con ardour. y   por el momento preferia seguir con Sonar.   saben si existe alguna forma de migrar trabajos de Cackewalk hacia Ardour?

todavia no logro la config que quiero, en sonar y usando Asio4all logro 2,x milisegundos de latencia, lo que es muy bueno,  con ardour y  configurando  32 frames y 6 de bufers tengo 4.35 ms. veremos si logro menos latencia.

 por si alguien se preguntara para que uno quiere tan poca latencia, es asi.  es el tiempo que hay entre el momento en que vos le das rec, y el momento en el que empieza a grabar, 2 ms de latencia se considera casi instantaneo, pero mas de 10 ms  ya es audible para alguien que trabaja con secuenciadores como Ardour, Cubase, Sonar, etc.  si usan su placa de sonido para ver pelis, musica, no les va a importar tener unos 20 o 30 ms, ya que cuanto menos latencia, mas uso del CPU

Mi Pc es AMD 64 2000 Mhz, 1 Gb Ram DDR2, Sonido OnBoard Realteck (alc861vd)  

La verdad que me alegraron el dia!! Tamku 

+1
0
-1

---------------------------------------------------------------------------------------------------------------------
Linux User#535363
Normas del foro