Actualización del amule (medio solución)

Imagen de superllo
0 puntos

Ayer (viernes) por la noche apareció una actualización parcial de la distro acompañada de una nueva actualización de amule para aquellos que utilizamos la versión CVS. El caso es que parece ser que no sé por qué pero ahora pide la versión libc 2.7-1 en vez de la que tenemos actualmente 2.6...

Esta versión 2.7-1 está presente en los repositorios de debian pero no de ubuntu, haciendo que el amule deje de funcionar (porque la actualización parcial se lo ha cargado) y no pudiendo instalarlo de nuevo. Como para algunos es muy importante tener la ofuscación de protocolo en marcha me es imposible usar la versión estable (que no lo incorpora).

Calentándome la cabeza me acordé que el repositorio de Treviño está parado desde septiembre, por lo que si os pasa lo mismo que a mi la medio-solución está en descargarse los ficheros de su repositorio e instalarlos a mano.

Los paquetes necesarios son:

  • amule-common_2.1.3.cvs20070903~3v1ubuntu0_all.deb
  • libgeoip1_1.4.0-0+3v1ubuntu0_i386.deb
  • amule-daemon_2.1.3.cvs20070903~3v1ubuntu0_i386.deb
  • amule_2.1.3.cvs20070903~3v1ubuntu0_i386.deb

En ese orden de instalación.

Así he conseguido que la mula vuelva a trotar. Ahroa veré qué es lo que ha hecho la actualización parcial (además de instalarme muchos programas que había desinstalado).

Ale

 

Imagen de Festor
+1
0
-1

Para los que no se queiran complicar la vida, en este post os podeis bajar las ultimas versiones del aMule 2.20 CVS (la version supuestamente inestable xD)

Para todas las versiones de Ubuntu (desde la 6.06):

http://forum.amule.org/index.php?topic=13836.0

De esta forma solo tendreis que instalar un paquete y no liaros con dependencias y libreias y repositorios inestables que pueden dar lugar a muchos problemas.

Según veo las versiones CVS (inestables) de Treviño no es que esten muy actualizadas: 20070903 -> Desde el 3 de septiembre :(

Actualmente la versión 2.20 CVS cuenta con las siguientes características destacables:

+ Soporte de archivos de más de 4 GB
+ Soporte del protocolo de ofuscación (útil al menos para los usuarios de Ono)
+ Soporte UPnP
+ Soporte de nuevos skins (véase este post)
+ Banderas indicadoras de los clientes
+ Decenas (yo diría que cientos xD ) de errores corregidos
+ ...

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de superllo
+1
0
-1

Gracias por la información, esta mañana me he vuelto loco buscando en el foro de amule y no lo he visto (las legañas seguramente). Voy a probarlo. No es tan fácil como el repositorio que estaba usando pero por lo menos saca del problema con un amule actual.

Efectivamente los usuario de Ono (por poco tiempo ya) necesitamos de la ofuscación como agua de mayo.

Ale 

+1
0
-1
Imagen de superllo
+1
0
-1

No me había dado cuenta de quién eras. Gracias por todo lo que hacéis con el amule, a ver si tenemos una versión estable pronto.

 

Ale 

+1
0
-1