Ubuntu 7.10 muy inestable (diversos programas) (Solucionado)

Imagen de Valentín
0 puntos

Hola a todos.

Perdón si el título es demasiado genérico, pero es que estoy experimentando muchos problemas con Ubuntu, y ya no se si es culpa de los programas que dan problemas, de Ubuntu o del hardware de mi ordenador...

El ordenador en cuestión en un portátil con un Intel Pentium IV a 2.88 GHz, 512 MB de RAM y gráfica Intel

En cuanto al sistema, la identiicación de la distribución es lenny/sid, con Gnome 2.20.1 (Ubuntu 2007-10-19) y Kernel 2.6.22-14-generic (#1 SMP Sun Oct 14 23:05:12 GMT 2007)

 

Los problemas que experimento... inestabilidad general (esto parece el ir al médico con malestar general). El programa que más problemas me da es Firefox (2.0.0.11), que se cuelga cada dos por tres y sin motivo aparente (a veces por seleccionar un texto, otras veces incluso sin estar yo delante de la máquina...). La última vez lo tenía ejecutado desde una terminal, y el error que acabó con él fue, cuanto menos, pintoresto:

The application 'gecko' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.

Decir que las X seguían funcionando pese a lo que dice el error, y desde luego yo no maté a Firefox ni a su motor (etaba navegando normalmente, precisamente por este foro en busca de soluciones...)

Otro que recientemente me da errores es Compiz Fusion (hoy ya se murió 2 veces).

Hace dos o tres días volví a casa y el ordenador estaba apagado, simplemente.

Decir que, al menos en el caso de Compiz Fusion y de Firefox, los logs del sistema no muestran nada (no recuerdo haberme parado a verlo el día que se apagó).

Lo que más me jode es que justo ahora que estaba decidido a hacer una migración desde mi sistema principal, Windows XP (gracias, Vista), empiezan estos problemas... me imaginaba a GNU/Linux más estable (yo quiero ser uno de estos con uptime de un mes... quiero olvidar la pinta de mi BIOS)

Espero me podáis ayudar (si me indicáis por dónde investigar, encantado estaré), y desde ya os doy las gracias por vuestro tiempo.

Imagen de Diegstroyer
+1
0
-1

Prueba en el LiveCD a ver si te pasa lo mismo, si no es así, reinstala el sistema de nuevo, igual se produjo algún error en la instalación.

Si te vuelve a suceder, prueba con la 7.04 de forma temporal, hasta que solucionen los bugs importantes de la 7.10 (unos dos o tres meses).

Yo actualmente utilizo la 7.04, ya que probé la 7.10 y me encontré con numerosos fallos (OpenOffice, Rythmbox, Azureus,...) y me volvi a la 7.04 hasta que me asegure de que lo que uso funciona.

Lamento si esta postura ofende a los fervientes defensores de la 7.10, pero hay gente que no puede/quiere pasarse dias enteros intentado solucionar los problemas y necesita ponerse a trabajar con el ordenador.

Un saludo y ya diras!

PD: si te funciona indicalo en el título editandolo con SOLUCIONADO.

 

Live as if you were to die tomorrow, learn as if you were to live forever... Ghandi.

Página de descarga de software Ubuntu: http://www.getdeb.net/

+1
0
-1
Imagen de Valentín
+1
0
-1

El caso es que no puedo iniciar desde una LiveCD.. pues parece que a la BIOS le pasa algo y no puedo bootear CDs de ninguna forma (la lista de prioridad de booteo está bien, y he probado con varios CDs distintos, pero siempre inicia el disco duro... es un tema pa' otro post, xD)

Por depronto he comenzado a utilizar el Kernel 2.6.20-16-generic (hasta ahora utilizaba el 2.6.20-14-generic, pues aunque tenía el más actual instalado, el GRUB parece que está liado y tiene de primero al 2.6.20-14-generic en la lista), aunque no creo que sea significativo.

Dese luego si consigo una solución editaré el título del post para indicar que el problema está resuelto, me parece una buena práctica la de este foto en ese aspecto, pero hasta entonces cualquier aportación será bien recibida. 

+1
0
-1
Imagen de Diegstroyer
+1
0
-1

Era unja instalación limpia o una actualización des de la 7.04?

Si no era limpai, reinstala el SO. 

Live as if you were to die tomorrow, learn as if you were to live forever... Ghandi.

Página de descarga de software Ubuntu: http://www.getdeb.net/

+1
0
-1
Imagen de Valentín
+1
0
-1

No, no era una instalación limpia... ¿y cómo puedo reinstalarlo? Osea, acabo de decir que no puedo iniciar desde un LiveCD... además, ¿¿tendré que reinstalar cada vez que quiera actualizar mi distribución?? No me esperaba algo así...

+1
0
-1
Imagen de Diegstroyer
+1
0
-1

Primera deberias comprobar que lo primero que se inicia es el CD, si no le es... mal vamos, si las opciones de la BIOS estan bien y pasa de ti, o el lector de CD ha cascado o tu portatil tiene problemas serios (comprueba que te lee CD con el sistema en marcha).

Hay unos CD que se instalan sin ser LiveCD, creo que se llaman alternate.

Se instala en modo consola, pero eso si, te tiene que arrancar inicialmente el CD en lugar del disco duro.

Normalemtne puedes actualizar de una distribución a otra, pero se pueden producir fallos, para que sea estable desde el principio y asegurarte que no habrán problemas "extraños", es mejor desde 0.

Para un portatil, la 7.10 es la mejor opción, ya que gestiona correctamente el uso de la bateria.

Como lo instalaste si no te funciona el LiveCD y no tienes el Alternate?

No desesperes, todo en esta vida tiene solución...

Live as if you were to die tomorrow, learn as if you were to live forever... Ghandi.

Página de descarga de software Ubuntu: http://www.getdeb.net/

+1
0
-1
Imagen de Valentín
+1
0
-1

Antes funcionaban los LiveCD, por eso pude instalarlo... y no me preguntes qué hice, porque no hice nada (xDD sí, es lo típico). Simplemente un buen día quise iniciar desde un CD y nada, no le dió la gana... Así quetampoco podré usar el Alternate :S.

Desespero, desespero... la verdad es que sí desespero.

+1
0
-1
Imagen de Diegstroyer
+1
0
-1

Rebisa la BIOS, por que si no arranca des de un medio externo lo tienes muy chungo para reinstalar nada, es más, sólo podrás dedicarte a arreglar el SO hasta que el ordenata casque del todo.

que cosas más raras pasan por este foro...

Ya puedes empezar a deseperar... actualizaste la BIOs en algun momento antes de empezar a tener problemas? (Es que si no arranca de otro modo que desde el disco duro, ni la BIOs podrás actualizar, ni poner otro SO ni nada) 

Live as if you were to die tomorrow, learn as if you were to live forever... Ghandi.

Página de descarga de software Ubuntu: http://www.getdeb.net/

+1
0
-1
Imagen de Valentín
+1
0
-1

Ya, yo también lo encuentro realmente extraño. Más aún, porque estoy seguro de que no hice nada de nada (no actualicé la BIOS ni nada parecido)... lo único que lo podría explicar es que el lector de CD no funcione al inicio del sistema, por alguna razón... :S

+1
0
-1
Imagen de Diegstroyer
+1
0
-1

Pues bueno, viendo que no puedes reinstalar, pasaremos a solucionar los problemas que te suceden.

Pondremos como ejemplo el firefox (pero haz lo mkismo con todos los programas en los que te pase), desinstalalo completamente con purge, ve a tu home y mira que no quede ni rastro de la carpeta oculta de .mozila, si quedase la carpeta, borrala manualmente. Ahora reinstala firefox con aptitude desde terminal (para instalar desinstalar puedes usar synaptic si te es más comodo).

De esta forma perderás la configuración y los plugins, pero te funcionará bien (a mi me paso y me funcionó con todos los programas que tenia problemas).

Es muy importante eliminar las carpetas de configuración ocultas del home de cada programa que falle.

Recuerda que perderás la configuración que tenias de todos ellos.

Un saludo y aver que tal. 

Live as if you were to die tomorrow, learn as if you were to live forever... Ghandi.

Página de descarga de software Ubuntu: http://www.getdeb.net/

+1
0
-1
Imagen de Valentín
+1
0
-1

Es menos drástico que reinstalar el sistema, desde luego.

Pero por el momento el sistema parece estable, con el cambio de Kernel que hice (no creía que eso fuera significativo). Si permanece así unos días, volveré a iniciar con el núcleo viejo, para ver si se repiten los problemas (si lo hacen, ahí estaba el fallo).

Saludos 

+1
0
-1
Imagen de fantasialinux
+1
0
-1

He visto tu comentario....................pienso tienes problemas de hardware.

Si estuviese en tu caso sacaria el hd (por si tienes datos de interes) y montaria otro hd con cualquier sistema operativo a modo de testeo.para salir de dudas.

Tantos fallos y tan inesperados,,,podrian ser debidos a falla de placa-base.

Espero te pueda valer.

Un saludo!

+1
0
-1
Imagen de Valentín
+1
0
-1

No lo descarto... el portátil ya tiene sus 4 añitos, así que... claro que a ver de dónde saco un disco duro de 2.5'. No se, si la cosa se complica lo valoraré, por depronto rezo porque con el nuevo núcleo se mantenga estable.

+1
0
-1
Imagen de jaos
+1
0
-1

Que no te arranque de CD es bastante raro. ¿Te pasa con todos los CD de arranque o solo has probado con el de Ubuntu? Todo puede ser que estes probando con un disco mal grabado o que no sea de arranque aunque supongo que ya habras probado  con otros. No se, pero raro si que es.

+1
0
-1
Imagen de Valentín
+1
0
-1

Sí, he probado con varios CDs, así que de eso no es... yo creo que está estropeado el lector, ya que ahora mismo en Ubuntu no funciona, mientras que hace unos días sí (aunque cuando funcionaba tampoco podía arrancar desde CD...).

Menudo cisco de portátil...

+1
0
-1
Imagen de dairus18
+1
0
-1

Ojala se te solucione pronto con lo del nuevo kernel esperamos tus novedades para si no se soluciona buscar otras opciones. 

La libertad consiste en poder hacer lo que se debe hacer.

+1
0
-1

La libertad consiste en poder hacer lo que se debe hacer.

Imagen de Valentín
+1
0
-1

Hola de nuevo.

Voy a marcar el tema como solucionado, porque no ha vuelto a ocurrir nada... (y he vuelto a probar con el Kernel que daba los errores y ya no los da, con lo que no era eso... ). Me quedo con las ganas de saber qué ocurría :(

Saludos y gracias por la ayuda.

+1
0
-1