Sonido y booteo en Ubuntu 5.04

Hola a todos. Tengo Ubuntu 5.04 en una Compaq Presario Pentiun II 233 Mhz, 512 kb cache, 128 Mb RAM, 40 GB disco duro.
El probblema es que no podia reproducir ningun sonido con el kernel que viene por defecto(2.6.10.5-386).Aunque actualice Ubuntu, con soporte para MP3, etc.Asi que compile mis propios kernels.El 2.6.12.3-686 y el 2.6.13-686. Los conigure,etc.Hice eso porque habia probado SLAX 5.0.6 Live CD y me reconocia el audio desde el inicio sin problemas, podia escucar musica, etc.Asi que compile esos kernels, y ahora puedo reproducir sonidos, en formato .wav al menos.Solo tengo que ejecutar esd como root cada vez que inicio la PC.
Pero esto es muy fastidioso y no me gusta. Asi que pense que debia haber una forma de hacer que esto ocurra desde el inicio por defecto.Coloque un link a /usr/bin/esd en /etc/init.d y le di permiso de ejecucion, pero no pasa nada. Intente con el archivo rc.alsa que genera SLAX 5.0.6 y tampoco. No se que mas pueda ser. Inclui ALSA y OSS en el kernel(no como modulo).
Otra cosa. Compile el kernel con ACPI y sin APM. A la hora de bootear, va bien hasta uncompressing Linux, y luego ya no se ve los mensajes de inicio, solo rayas, hasta que llega a la ventana de login. Luego va normal, pero cuando quiero ir a la cconsola 1(Control+Alt+F1) se ve todo negro y nada mas.Creo que debe ser porque me olvide de incluir algo en el kernel.Otra cosa, no compile el kernel usando kernel-package, sino solo make bzImage, make modules,make modules_install con las fuentes del kernel.org. Claro, sin initrd. Luego lo agregue con mkinitrd -o....etc, etc.
Si alguien tiene una respuesta, se lo agradeceria.

Imagen de hamner_tiradotirado
+1
0
-1

Me di cuenta que ya puedo reproducir MP3. Sin embargo, tengo que ejecutar esd como root previamente para reproducir cualquier sonido. Además, no me aparece el control de volumen.Tengo que llamarlo desde consola(gnome-volume-control).Pero lo más curioso, es que cuando me logeo como usuario principal, no me aparece el sonido por defecto.Debo invocarlo como root.Sin embargo, si me logeo como usuario secundario, este si tiene sonido por defecto al iniciar sesión, tiene el control de volumen, etc.No sé a que se deba.Talvez la configuración de mi cuenta.
¿Alguna sugerencia?

+1
0
-1