Brillo en HP Pavilion (SOLUCIONADO)

Imagen de ErJavis
0 puntos

Hola buenas.

Tengo un portatil HP Pavilion modelo dv2000. He conseguido instalar todo, pero me he dado cuenta que el brillo de la pantalla no lo puedo ajustar. En el aplet del panel del brillo aparece con un simbolo encima rojo como si estuviese deshabilitado...Y con la combinacion de teclas del teclado para ajustar el brillo tampoco me va, pero el resto de combinaciones si, como por ejemplo el de las www, bloquear el equipo, etc.

A ver si me podeis echar un cable por favor....

PD: Como curiosidad deciros que al quitar el cable de alimentacion el brillo aumenta y cuando lo enchufo disminuye. :S

Imagen de ErJavis
+1
0
-1

Nadie sabe?? 

+1
0
-1
Imagen de wnino
+1
0
-1

Hola ErJavis:

Al igual que tú tengo un portátil de la serie dv2000 (dv2222la) y tampoco he logrado controlar el brillo del monitor. La única solución que encontré aquí es un poco manual pero por lo menos es algo. Yo ejecuto así: sudo ./brillo <X> donde <X> es un valor entre 0 y 100

Me gustaría que me comentaras cómo has hecho con el micrófono pues no he podido aún usarlo. Te agradezco la información que me puedas aportar.

Saludos.

_______________________________________________________________________________

Lee y cumple las Normas del foro, Pregunta antes a San Google y si tienes éxito con tu problema, dí cómo lo hiciste, edita el título del post y pónle (solucionado).

+1
0
-1

Lee y cumple las Normas, Pregunta antes a San Google y si tienes éxito con tu problema: dí cómo lo hiciste, edita el título del post y pónle (solucionado).
Imagen de ErJavis
+1
0
-1

Muchas gracias por responder.

Pues he de decirte que para mi sorpresa los ha cogido a la primera, vamos que no he hecho nada. Has instalado todas las actualizaciones?

Yo soy nuevo en el mundo de ubuntu. Conozco un poco de unix por lo que reconozco rapidamente un monton de comandos que usa ubuntu, pero vamos, poco mas. 

+1
0
-1
Imagen de ErJavis
+1
0
-1

Pues no me funciona ... :(

Pongo en la terminal:

sudo ./brillo 100 

y me pone

sudo: ./brillo: command not found 

Que hago mal?¿

Gracias

+1
0
-1
Imagen de wnino
+1
0
-1

Creaste el script  que mencionaba el enlace?  Para ejecutarlo debes ir a la carpeta donde se encuentra el script.  Ah , y otra cosa: una vez creado debes darle permiso de ejecución.

+1
0
-1

Lee y cumple las Normas, Pregunta antes a San Google y si tienes éxito con tu problema: dí cómo lo hiciste, edita el título del post y pónle (solucionado).
Imagen de ErJavis
+1
0
-1

Me podrias decir paso a paso como se hace eso de crear el script? nunca lo he hecho.

Gracias

+1
0
-1
Imagen de wnino
+1
0
-1

Hola ErJavis:

Veo que no consultaste el enlace donde está el script, así que voy a darte la información completa:

Das el siguiente comando desde una consola (vas a menú Aplicaciones->Accesorios->Terminal):

Dentro de la ventana que se abre digitas gedit brillo

Esto te abre un editor de texto (el gedit)

Digitas lo siguiente: (este es el script)

NOTA: Puedes copiarlo desde este post seleccionándolo y luego dando Ctrl+C y pegarlo en el editor con Ctrl+V.

#!/bin/sh
# Setea el brillo de la pantalla al valor pasado como parametro
USER=$( whoami )
if [ "$USER" != "root" ]; then
    echo "Este script debe ser ejecutado como root"
    exit
fi
if [ -z "$1" ]; then
    echo "Debe indicar el brillo"
    cat /proc/acpi/video/VGA/LCD/brightness
    exit
fi
echo $1 > /proc/acpi/video/VGA/LCD/brightness
exit

 

Luego, en gedit, vas a Archivo -> Guardar como y te fijas que la carpeta donde quede guardado el archivo sea en /home/<TuUsuario> donde <TuUsuario> es el nombre del usuario donde estás. Por ejemplo el home de mi usuario es /home/wnino. Le das entonces Guardar. Ya puedes entonces cerrar la ventana del editor.

Por último abres el nautilus desde Lugares->Carpeta personal y buscas el archivo brillo que acabas de crear. Das click derecho sobre él y seleccionas Propiedades del menú contextual.

Vas a la pestaña Permisos y das click en la casilla que dice permitir ejecutar el archivo como un programa, para hacerlo ejecutable. Cierras el cuadro de propiedades y nuevamente vas a la ventana de la consola (terminal) y ahora sí digitas sudo ./brillo 60. Debes tener en cuenta que puedes reemplazar el 60 por valores comprendidos entre 0 y 100, múltiplos de 10, de acuerdo a como veas que cambia el brillo (en algunos casos no notarás el cambio).

Saludos.

_______________________________________________________________________________

Lee y cumple las Normas del foro, Pregunta antes a San Google y si tienes éxito con tu problema, dí cómo lo hiciste, edita el título del post y pónle (solucionado).

+1
0
-1

Lee y cumple las Normas, Pregunta antes a San Google y si tienes éxito con tu problema: dí cómo lo hiciste, edita el título del post y pónle (solucionado).
Imagen de ErJavis
+1
0
-1

Muchisimas gracias. Lo has explicado muy bien. Ya lo he conseguido por fin, aunque eso de multiplos de 10 se lo salta a la torera, porque le doy el valor 90 o 100 y no va, le he tenido que dar el valor 93...pero bueno, no importa, ya soy feliz jejejejeje.

Muchisimas gracias de verdad ;)

+1
0
-1
Imagen de wnino
+1
0
-1

Me alegra mucho  haber servido de ayuda.  No olvides poner  solucionado al título de tu post.

+1
0
-1

Lee y cumple las Normas, Pregunta antes a San Google y si tienes éxito con tu problema: dí cómo lo hiciste, edita el título del post y pónle (solucionado).
Imagen de Danielbluxer
+1
0
-1

conla tecla fn y f7 o f8, donde aparece un sol. aumentas y bajas el brillo... espero les funcione. a mi me funcionó, saludos

+1
0
-1
Imagen de 3lc0nd3
+1
0
-1

debe cambiar la ruta del archivo:

/proc/acpi/video/VGA/LCD/brightness

a:

/proc/acpi/video/GFX0/LCD/brightness

esto se hace en las líneas 10 y 13 del script

3lc0nd3

+1
0
-1

Edward Ramirez

Imagen de hdelacruz13
+1
0
-1

Hola amigos mi problema es parecido al de ustedes pero con algunas cosas distintas, mis botones de ajuste de brillo de mi notebook HP folio 13 se supone se activan con F2 para bajar brillo y F3 para aumentar asi a secas sin tener que presionar la tecla fn, en los botones de ajuste de volumen es la misma cosa solo que son F9 y F10 y esos funcionan con normalidad solo los de brillo no. Yo segui los pasos para reparar este problema con mi laptop pero a mi en el paso de ingresar al terminal "sudo ./brillo.." me dice que la ruta /proc/acpi/video/VGA/LCD/brightness no existe tambien lo intente con /proc/acpi/video/GFXo/LCD/brightness y nada.
revise accediendo a las carpetas una por una --proc/acpi..... pero hasta ahi llega!! no existe la carpeta video y no puedo crearla.
Pense que talvez fue porq modifique el inicio del grub en poner en una parte de "quiet splash" añadiendo esto "quiet splash pci=noacpi" ya que tenia antes un problema al iniciar ubuntu ya que la pantalla se quedaba negra totalmente despues de elegir entrar a ubuntu en el grub.
Menciono todo esto ya que aun no puedo activar estas teclas para ajustar el brillo y de las carpetas que me hacen falta talvez este todo relacionado.
Agradeceria de su valiosa ayuda y si sirve de algo tengo ubuntu 12.10
saludos

+1
0
-1

Hector de la Cruz

Imagen de nahuelisimo
+1
0
-1

uso ubuntu 10.04 y tampoco tengo la carpetavideo dentro de proc/acpi, y por mas que la cree (se debe hacer como root) no serviria de nada ya que se supone que hay archivos y esos no conozco su contenido como para crearlos

+1
0
-1

Prefiero estar en boca de tantos, que ser otro de los tantos con bocas.