Subversion y ldap

Imagen de Denos
0 puntos

Buenas,

He instalado subversion y ldap, los dos aparentemente bien instalados. El problema me aparece cuando intento autentificar en subversion a través de ldap. 

Os dejo toda mi configuración y los errores que me da el log de apache2.

Configuracion de subversion

 <Location /prueba>
DAV svn

SVNPath /var/lib/svn/pruebas

AuthzSVNAccessFile /var/lib/svn/pruebas
AuthzLDAPAuthoritative on
AuthType Basic
AuthName "Repository Subversion"

AuthBasicProvider ldap
AuthLDAPBindDN "CN=admin,DC=mi_dominio,DC=extension"
AuthLDAPBindPassword "mi_password"

AuthLDAPURL ldap://localhost:389/CN=users,DC=extension,DC=com?samAccountName?sub?(objectClass=*)

Require valid-user
</Location>

 Logs

 [Mon Jan 07 14:51:29 2008] [warn] [client 192.168.10.114] [6695] auth_ldap authe
nticate: user laleza authentication failed; URI /prueba [ldap_search_ext_s() for
 user failed][No such object]
[Mon Jan 07 14:51:29 2008] [error] [client 192.168.10.114] user laleza not found
: /prueba

 

Un saludo y gracias de antemano. 

Imagen de Denos
+1
0
-1

Bueno después de estar todo el día peleando yo mismo me voy a contestar. Esta es la configuración de /etc/apache2/mods-enabled/dav_svn.conf

 <Location /prueba>

DAV svn

SVNPath /var/lib/svn/pruebas

Options Indexes FollowSymLinks

AuthType Basic

AuthBasicProvider ldap

AuthName "Repository Subversion"

AuthLDAPURL ldap://localhost:389/OU=mi_grupo,DC=mi_dominio,DC=mi_extension?uid?one?(objectClass=*)

AuthLDAPBindDN "CN=mi_usuario,DC=mi_dominio,DC=mi_extension"
AuthLDAPBindPassword "mi_password"
AuthzLDAPAuthoritative Off

Require valid-user
</Location>

Un saludo, y espero que a alguien le sea de utilidad. Denos. 

+1
0
-1